Log in to reply
 

Mods simply stopped working...



  • Out of the absolute blue, all mods decided to quit working on my son's GTA.
    Cars, person skins, the whole shabang just is not there anymore.
    Replaced all Scripthook files etc, no avail, game refuses to accept the mods, for some odd reason.
    Anyone a clue?

    Thank you.



  • No one with an idea of what it could cause this?



  • @Sammy1970 You would need to provide info for people to be able to possibly see what might be wrong.

    https://forums.gta5-mods.com/topic/13256/how-to-ask-for-help-and-support



  • @chonkie Well, one moment they worked fine.
    Nothing changed on the system, the game.
    Oh, right, my son had a car installed, https://www.gta5-mods.com/vehicles/2015-lamborghini-aventador-lp700-4-stock-interior-color-hq-animated-engine-livery-tunable-autospoiler.
    An OIV.

    Then out of the blue, all added mods just stopped working.
    Trainer works, still, which is VERY strange.

    I tried to re-install with redownloading all needed mod-files, I changed the Config again, nothing though helps.



  • @Sammy1970 I recommend you never use an OIV installer. It could make unnecessary changes that affect other things you don't want changed. I bet that's your issue. You can always manually install files from an oiv.



  • Oh...
    Well, I'll remove these then.
    See if that helps.

    Thank you, sir. :)





  • @chonkie
    I ended up reinstalling everything except the OIV.
    Same deal...
    Scripthook is installed.
    Scriphook.net.
    Dinput8.
    Installed the correct gameconfig.
    Edited the DLC and Extra files as per needed.
    Installed the directories with their DLC files.
    Installed a few police car replaces.
    But no ball...

    I am at a loss, what am I missing?



  • @Sammy1970 Any error logs showing up? Post a screenshot of your folders, like the root folder, mods folder, scripts folder, dlclist.xml, etc. Anything you think might help. Maybe even link the mods you've installed. Without any of that info, it's difficult to tell what could be wrong.



  • Will do ASAP, not on my son's system atm.
    Thank you very much.



  • @chonkie

    0_1594375015658_DLCPacks.png
    0_1594375023765_Mods Folder.png
    0_1594375028844_Root1.png
    0_1594375037001_Root2.png
    0_1594375050482_Root3.png

    Replace police cars: files dropped in both Patch 3 and Patch 18.
    Worked before.

    DLCList:
    <?xml version="1.0" encoding="UTF-8"?>

    <SMandatoryPacksData>
    <Paths>
    <Item>platform:\dlcPacks\mpBeach</Item>
    <Item>platform:\dlcPacks\mpBusiness</Item>
    <Item>platform:\dlcPacks\mpChristmas</Item>
    <Item>platform:\dlcPacks\mpValentines</Item>
    <Item>platform:\dlcPacks\mpBusiness2</Item>
    <Item>platform:\dlcPacks\mpHipster</Item>
    <Item>platform:\dlcPacks\mpIndependence</Item>
    <Item>platform:\dlcPacks\mpPilot</Item>
    <Item>platform:\dlcPacks\spUpgrade</Item>
    <Item>platform:\dlcPacks\mpLTS</Item>
    <Item>dlcpacks:\mpheist</Item>
    <Item>dlcpacks:\mppatchesng</Item>
    <Item>dlcpacks:\patchday1ng</Item>
    <Item>dlcpacks:\patchday2ng</Item>
    <Item>dlcpacks:\mpchristmas2</Item>
    <Item>dlcpacks:\patchday2bng</Item>
    <Item>dlcpacks:\patchday3ng</Item>
    <Item>dlcpacks:\patchday4ng</Item>
    <Item>dlcpacks:\mpluxe</Item>
    <Item>dlcpacks:\patchday5ng</Item>
    <Item>dlcpacks:\mpluxe2</Item>
    <Item>dlcpacks:\patchday6ng</Item>
    <Item>dlcpacks:\mpreplay</Item>
    <Item>dlcpacks:\patchday7ng</Item>
    <Item>dlcpacks:\mplowrider</Item>
    <Item>dlcpacks:\mphalloween</Item>
    <Item>dlcpacks:\patchday8ng</Item>
    <Item>dlcpacks:\mpapartment</Item>
    <item>dlcpacks:\mpxmas_604490</item>
    <Item>dlcpacks:\mplowrider2</Item>
    <Item>dlcpacks:\mpjanuary2016</Item>
    <Item>dlcpacks:\mpvalentines2</Item>
    <Item>dlcpacks:\patchday9ng</Item>
    <Item>dlcpacks:\mpexecutive</Item>
    <Item>dlcpacks:\patchday10ng</Item>
    <Item>dlcpacks:\mpstunt</Item>
    <Item>dlcpacks:\patchday11ng</Item>
    <Item>dlcpacks:\mpimportexport</Item>
    <Item>dlcpacks:\mpbiker</Item>
    <Item>dlcpacks:\patchday12ng</Item>
    <Item>dlcpacks:\patchday13ng</Item>
    <Item>dlcpacks:\mpspecialraces</Item>
    <Item>dlcpacks:\mpgunrunning</Item>
    <Item>dlcpacks:\mpairraces</Item>
    <Item>dlcpacks:\mpsmuggler</Item>
    <Item>dlcpacks:\patchday14ng</Item>
    <Item>dlcpacks:\patchday15ng</Item>
    <Item>dlcpacks:\patchday16ng</Item>
    <Item>dlcpacks:\ssc_gauntlet</Item>
    <Item>dlcpacks:\uparmorhmvdes</Item>
    <item>dlcpacks:\bdivo</Item>
    <Item>dlcpacks:\countachus</Item>
    <Item>dlcpacks:\610dtm</Item>
    <Item>dlcpacks:\lamtmc</Item>
    </Paths>
    </SMandatoryPacksData>

    Extra:
    <?xml version="1.0" encoding="UTF-8"?>

    <SExtraTitleUpdateData>
    <Mounts>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcSPUpgrade:/</deviceName>
    <path>update:/dlc_patch/spUpgrade/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPBeach:/</deviceName>
    <path>update:/dlc_patch/mpBeach/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_MPChristmas:/</deviceName>
    <path>update:/dlc_patch/mpChristmas/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPValentines:/</deviceName>
    <path>update:/dlc_patch/mpValentines/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPBusiness:/</deviceName>
    <path>update:/dlc_patch/mpBusiness/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpBusiness2:/</deviceName>
    <path>update:/dlc_patch/mpBusiness2/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPHipster:/</deviceName>
    <path>update:/dlc_patch/mpHipster/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_MPIndependence:/</deviceName>
    <path>update:/dlc_patch/mpIndependence/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPLTS:/</deviceName>
    <path>update:/dlc_patch/mpLTS/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPPilot:/</deviceName>
    <path>update:/dlc_patch/mpPilot/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_patchDay1NG:/</deviceName>
    <path>update:/dlc_patch/patchDay1NG/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpPatchesNG:/</deviceName>
    <path>update:/dlc_patch/mpPatchesNG/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpChristmas2:/</deviceName>
    <path>update:/dlc_patch/mpChristmas2/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPHeist:/</deviceName>
    <path>update:/dlc_patch/mpHeist/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_MPLuxe:/</deviceName>
    <path>update:/dlc_patch/mpLuxe/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_patchDay3NG:/</deviceName>
    <path>update:/dlc_patch/patchDay3NG/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_patchDay5NG:/</deviceName>
    <path>update:/dlc_patch/patchDay5NG/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpLuxe2:/</deviceName>
    <path>update:/dlc_patch/mpLuxe2/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpLowrider:/</deviceName>
    <path>update:/dlc_patch/mpLowrider/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlcMPHalloween:/</deviceName>
    <path>update:/dlc_patch/mpHalloween/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpApartment:/</deviceName>
    <path>update:/dlc_patch/mpApartment/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpJanuary2016:/</deviceName>
    <path>update:/dlc_patch/mpJanuary2016/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpValentines2:/</deviceName>
    <path>update:/dlc_patch/mpValentines2/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpLowrider2:/</deviceName>
    <path>update:/dlc_patch/mpLowrider2/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpExecutive:/</deviceName>
    <path>update:/dlc_patch/mpExecutive/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpStunt:/</deviceName>
    <path>update:/dlc_patch/mpStunt/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpBiker:/</deviceName>
    <path>update:/dlc_patch/mpBiker/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpImportExport:/</deviceName>
    <path>update:/dlc_patch/mpImportExport/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_mpGunRunning:/</deviceName>
    <path>update:/dlc_patch/mpGunrunning/</path>
    </Item>
    <Item type="SExtraTitleUpdateMount">
    <deviceName>dlc_countachus:/</deviceName>
    <path>update:/dlc_patch/countachus/</path>
    </Item>
    </Mounts>
    </SExtraTitleUpdateData>

    Both DLC and Extra are placed in Update.RPF, DATA.

    Need anything more, good sir?



  • @Sammy1970 Just a fyi, next time you need to post things like what I listed, it would actually be easier for you, less screenshots for one, if you use OpenIV or CodeWalker's rpf explorer. It's also probably actually easier for others to pinpoint potential problems as well, I know it is for me since that's what I'm used to looking at when modding.

    Also, a screenshot of the dlclist.xml is better than how you posted it because that is what will be in your game, and I mention that because each and every entry in your whole dlclist that you have posted is missing the slash after the pack names, even the vanilla packs, but I am going to assume that is a typo error when you put them down, if that isn't the case, then that's an issue you would need to fix.

    The mod dlcpacks I see you have them installed in your vanilla dlcpacks location, they need to be in the mods folder dlcpack location, you only have two vanilla packs in there. That's definitely one issue. Are you editing the vanilla dlclist.xml or are you editing the one in the mods folder?

    Here's a few example pics of where the packs should be and also to show you how it's easier to tell where things are located when trying to help.

    This first pic i'm pointing out the missing slash that I assume is present in your list that was just a typo if you typed them out manually, but also have to think why would someone type out that long list manually instead of copy/pasting it, so make sure your list has those slashes.
    alt text

    This one is my mod folder dlcpack, you don't need all of the vanilla ones in there, only ones with edits to them, but you do need to make sure you put all of your mod dlcpacks there.
    alt text



  • @Sammy1970 Also check your logs and/or post them on pastebin and put the link in a reply. And another thing I noticed, you say you put the replacement car files in 3 and 18, but in your mods folder dlcpacks you have 3 and 16, so I don't know if you just put them in the wrong folder or if you just mistyped which folder you put them in.

    And what is that Trainers folder? I've never seen any trainer need/have it's own folder, usually just the .asi and .ini file in the root folder. I do see that you have the trainerv.asi and .ini in your root folder though, so that's why that still works, but that trainers folder seems unnecessary.
    alt text



  • @Sammy1970 said in Mods simply stopped working...:

    <item>dlcpacks:\bdivo</Item>

    Came here to see if you responded that things were fixed, didn't see any thing so took another quick look at things. Just noticed that dlclist line. If that dlclist line is actually like that in your list, then that will mess things up. The items need to either both be lower case or both be capitalized. And like I said about all of the missing slash marks after the dlcpack names, it's difficult to tell if that is just a typo when you put the info here or if that is how your dlclist actually looks.



  • @Sammy1970
    +1 to post above

    <item>dlcpacks:\bdivo\</Item>
    

    Both 'item/Item's parts in any one line need to either start with lowercase or uppercase, but you can't mix & match (in the same line) or it will break 'dlclist.xml' & stop all dlc from loading.
    Change one of the 'i/I's to match the other to fix:

    Example:

    <Item>dlcpacks:\bdivo\</Item>
    

    OR

    <item>dlcpacks:\bdivo\</item>
    

    Common 'dlclist.xml' formatting pitfalls/rules explained in detail in this dlclist tutorial if you want to know more. :thumbsup:

    ========================

    @chonkie said in Mods simply stopped working...:

    why would someone type out that long list manually instead of copy/pasting it, so make sure your list has those slashes

    @chonkie (EDIT: Me again :) , I take too long to post LOL)
    Just so you know, the missing second slashes in his dlclist data post are the site's fault, it auto removes them from the copy & paste, unless the data is posted using a codeblock :thumbsup:

    @Sammy1970
    How to post a Codeblock for .meta/.xml/.dat data: (alternative to screenshots/pastebin for posting data files on gta5-mods, just in case it's useful, has the advantage of being able to be accurately copied & pasted by someone helping you (given site issue mentioned just above) :thumbsup: )

    ```xml
    Copy these three lines to a blank txt file etc, overwrite only this line, copy all & post into gta5-mods forum post.
    ```
    & it will end up looking like this once posted:

    Copy these three lines to a blank txt file etc, overwrite only this line, copy all & post into gta5-mods forum post.
    


  • I fixed the Item.
    That fixed everything... 1 non-capital I messed ALL up...
    Incredible!!!

    And Eng16, indeed, typo.

    Thank you all, I was going bananas.
    My son kept hitting on me: "Is my GTA done, is my GTA done, daaaaaad..." LMAO

    Well, NOW it is done.
    All because I forgot to capitalize an I, for crying out loud!

    Thank you all, SO much...
    My son loves you guys!!!
    And I am now again a happy daddy. ;)



  • @a63nt-5m1th Good bit of information to know about it being the site's fault and how to input it so it shows up properly.

    @Sammy1970 Good to hear it's fixed and that was all it was, it's nice when it's an easy fix.



  • @Sammy1970
    :thumbsup:

    @chonkie
    Aye, it's handy that codeblock functionality :thumbsup:
    If you want to share the info with someone (without it actually turning into a codeblock when you post it), post it like this:

    \```xml
    Copy these three lines to a blank txt file etc, overwrite only this line, copy all & post into gta5-mods forum post.
    \```
    

    & it will appear correctly, like this (without the slashes), ready for them to copy & paste etc:

    ```xml
    Copy these three lines to a blank txt file etc, overwrite only this line, copy all & post into gta5-mods forum post.
    ```

    Took me a while to work that one out :thumbsup:



  • @Sammy1970 Next time, don't go bananas, go smart! Use a tool like XML Validator Had you done so, it would have immediately told you:

    error on line 55 at column 29: Opening and ending tag mismatch: item line 0 and Item



  • @meimeiriver Thank you, sir, will do so... :)


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.