Log in to reply

What mod is causing fog in Prologue mission?

  • So my game keeps crashing during Prologue right as the garage door opens to the outside and this fog that doesn't exist in the stock game appears outside. I don't have many mods installed, and I've already tried disabling the top suspects; ENB and Forests of SA. Other than that, all I have are Menyoo, AddonSpawner, InversePower and the various adjusters to make Forests of SA work. I can't imagine any of those would create fog. Other than those, I just have car mods like VWE and IVPack.

  • @PermissionToLand
    I don't see any of the mods you mention causing that, sounds more like corruption or an error in a file that might cause it. I would test to see (if you haven't already) whether the problem exists in your vanilla game (by removing 'mods' folder temporarily etc) & then reinstall graphics drivers (using DDU (Display Driver Uninstaller) in Windows Safe Mode), just to eliminate that too.

    Once you have tested the vanilla game & eliminated the GPU driver & also scripts (by renaming 'scripts' folder to something else temporarily (if using a 'scripts' folder) & testing in-game), I would then try backing up '.rpf' archives one at a time & replacing them with vanilla ones (start with 'update.rpf') & hopefully you find which one the problem resides in.

    If you backup one at a time, you won't need to have much hdd space to do it. Move through them & see if reverting any to vanilla fixes it. If it does, use the same principle with folder structures/files in that '.rpf' until you narrow the problem down to a file/internal '.rpf' etc. :thumbsup:

  • @a63nt-5m1th So I've narrowed it down to Menyoo, believe it or not.

  • @a63nt-5m1th Okay, so I found this in the TimecycModifiers.xml for Menyoo:

    <Mod caption="prologue_ending_fog" name="prologue_ending_fog" />

    This has to have something to do with it, right? I have no idea what to do with that though. Just delete the entire line? There's no true/false option.

  • WOOO that finally did it!!! Now to put Menyoo on blast for unadvertised changes that you can't even change from the ingame menu. The other thing about that fog was that it totally obscured the cops in the distance, functionally ruining the mission. What the hell were they even thinking?

  • @PermissionToLand
    Nice :slight_smile:, glad you sussed it out & got it fixed :thumbsup:

    'prologue_ending_fog' is a timecycle modifier in 'timecycle_mods_1.xml' (I should have caught that earlier, but it never showed up for some reason when I searched my file collection for 'prologue'?! (might have typo'd or something :pensive: lol ).


    I'm sure you know where 'timecycle_mods_1.xml' resides :slight_smile:, just covering all the bases for whoever else might read this in future & has the same issue etc :thumbsup:

    Vanilla 'prologue_ending_fog' looks like this:

      <modifier name="prologue_ending_fog" numMods="25" userFlags="0">
        <light_dir_col_r>1.000 1.000</light_dir_col_r>
        <light_dir_col_g>1.000 1.000</light_dir_col_g>
        <light_dir_col_b>1.000 1.000</light_dir_col_b>
        <light_dir_mult>14.000 1.000</light_dir_mult>
        <ped_light_col_r>1.000 1.000</ped_light_col_r>
        <ped_light_col_g>1.000 1.000</ped_light_col_g>
        <ped_light_col_b>1.000 1.000</ped_light_col_b>
        <ped_light_mult>0.600 1.000</ped_light_mult>
        <light_ray_col_r>1.000 1.000</light_ray_col_r>
        <light_ray_col_g>1.000 1.000</light_ray_col_g>
        <light_ray_col_b>1.000 1.000</light_ray_col_b>
        <light_ray_mult>12.544 1.000</light_ray_mult>
        <postfx_bright_pass_thresh_width>0.700 0.000</postfx_bright_pass_thresh_width>
        <postfx_bright_pass_thresh>0.700 0.000</postfx_bright_pass_thresh>
        <postfx_intensity_bloom>0.500 0.000</postfx_intensity_bloom>
        <fog_start>5.000 5.000</fog_start>
        <fog_near_col_r>1.000 1.000</fog_near_col_r>
        <fog_near_col_g>1.000 1.000</fog_near_col_g>
        <fog_near_col_b>1.000 1.000</fog_near_col_b>
        <fog_near_col_a>0.000 1.000</fog_near_col_a>
        <fog_density>100.000 100.000</fog_density>
        <fog_falloff>69.000 70.000</fog_falloff>
        <fog_base_height>125.000 125.000</fog_base_height>
        <fog_hdr>10.000 1.000</fog_hdr>
        <particle_light_intensity_mult>0.500 1.000</particle_light_intensity_mult>

    I've never used Menyoo, so no idea exactly what 'TimecycModifiers.xml' is used for? Just looks like a list of timecycle modifiers Menyoo can/does use or something?!.

    How did you fix it exactly?

    Worth checking your 'timecycle_mods_1.xml' for syntax errors etc (just in case it's not completely Menyoo's fault etc. Could be a combination of things that caused it, worth ruling out, quick & easy to do etc :thumbsup:).

    Check '.xml/.meta/.ymt' files for syntax errors in OpenIV:

    OpenIV > right-click '.xml/.meta/.ymt' file > Edit (Ctrl+Enter) > hit the '[</> XML]' button at the top to check file for syntax errors (button only appears if file opened in 'Edit' mode). :thumbsup:

  • @a63nt-5m1th I just deleted that line entirely from the timecyc file. Searching "prologue" also didn't work for me (I found it by searching "fog"), but I tried again and I think it either took a minute for the results to show "prologue" or I had to hit search twice to get the second instance to show. Not sure if that's the fault of OpenIV or Menyoo.

    Edit: I just realized you're talking about the game's timecyc file. Menyoo has it's own timecycmodifier file in the "Menyoostuff" folder included with it that goes into the main game directory. That's where I found the line and deleted it. I didn't touch the game's file at the location you gave.

    Menyoo has options to change the weather in its in-game interface, but nothing whatsoever that does it in a mission-specific way. And I know I didn't have any weather options enabled in Menyoo while playing the mission, I made sure it was set to default. So this was just coded into the mod with no way to enable/disable it from the interface. So ridiculous.

  • Just checked; no syntax errors.

  • @PermissionToLand
    I was talking about the game's 'timecycle_mods_1.xml' & Menyoo's 'TimecycModifiers.xml'' :thumbsup:
    As they both had 'prologue_ending_fog' in them, worth investigating/seeing if there was a connection/ruling it out etc (Menyoo, must be getting the values for 'prologue_ending_fog' from somewhere etc?).

    It's more info to give to Menyoo mod author if you contact him anyway :thumbsup:
    Does seem on the surface to be fully Menyoo's fault, only Menyoo mod author will know why?
    Bug in the code most likely. Doesn't sound like normal intended trainer behaviour anyway.
    Probably worth letting him know :thumbsup:

    Glad you got it fixed anyway, cheers for letting me know how you did it :thumbsup: (I store bookmarks of problems with details of their solution in case they come up again :thumbsup:)

  • @a63nt-5m1th I'm still getting crashing and it seems to be consistently while firing a gun. Do Menyoo or ENB have any effect on weapons or maybe the fire effect from firing?

  • @PermissionToLand
    I've never used Menyoo so not sure about that (you could remove it temporarily to test).
    I doubt ENB would cause that, but it could also be disabled in-game (Shift+F12 by default, although custom setup keys can vary).


    KeyCombination=16 (Shift)
    KeyUseEffect=123 (F12)

    I would be looking to weapon & possibly weapon audio mods if I was getting crashes while firing.
    If you have edited 'weapons.meta':


    try defaulting it to vanilla.

    Just as a diagnostic test, I would also backup your 'mods' folder 'update.rpf' & then revert it to vanilla & test. If that fixes it, at least you know roughly where the issue resides.

    The 'mods' folder is brilliant for diagnostics, with GTA V being so modular you can easily grab whole '.rpf' archives from the 'mods' folder & place them somewhere else on the same hard drive forcing the game to revert to vanilla for just that '.rpf'.
    Once I've eliminated scripts etc as a possible cause, it's my usual go-to tactic for gaining any info I can on a problem when I have no idea what might be causing it.

  • @a63nt-5m1th Well, it seems like removing ENB stopped the crashing. But I can't find anything in ENB's .ini files that would seem to affect weapons.

  • @PermissionToLand
    Yeah, I don't know of anything in ENB that alters weapons directly, just the general visuals (which obviously does include gunfire visuals, but I think that's unlikely to cause a crash, although can't rule it out completely).

    Can you confirm the issue happens on a vanilla game with just ENB activated & goes away completely when ENB is deactivated? I would test it a few times each, just to be sure.

    Also, did you uninstall your GPU driver in Windows Safe Mode using DDU (Display Driver Uninstaller), & then reinstall the newest driver normally?
    That needs to be ruled out anyway, could easily be a funky part of the GPU driver combined with ENB causing the game to crash :thumbsup:

    If none of that helps, look into running a System File Scan & run chkdsk (follow the 'From My Computer' instruction parts) to check your game & system hard drives for errors, just to rule that out too.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.