Log in to reply
 

Vehicles in front of me disappear, when i get closer



  • Hi,

    i recently recognized, that sometimes driving vehicles in front of me disappear, when i get closer.

    Does anybody have an idea, how to fix this issue?

    Thanks



  • i think your game is lagging...it might be a bug or smth. I know it happened to me at GTA San Andreas years ago...and i had to reinstall the whole game so I lost my progress



  • @Augur89
    Not sure what could be causing that exactly, but here are a few things to eliminate.

    After you have eliminated scripts as a possible cause (rename/move 'scripts' folder temporarily & test in-game etc), try resetting your 'gameconfig.xml' back to vanilla, if it has been edited/custom gameconfig installed etc (make a backup of what you have installed beforehand so you can revert if it does nothing to fix the issue).

    If a vanilla 'gameconfig.xml' fixes the issue, best guess would be you have some sort of error or erroneous value/s in the '<ConfigPopulation>' section, but could be other sections also.
    Reset blocks of 'gameconfig.xml' values back to vanilla, while testing in-game after each reset, until you narrow it down to the value/s that is/are causing it.

    You can use the same principle with '.rpf' archives (reset an individual archive back to vanilla while keeping a backup of your modded one) to track down problems to a specific '.rpf' archive etc.
    Handy tactic if you have zero information to go on & have eliminated other external (scripts etc) sources as a possible cause :thumbsup:.

    A video of the issue happening might help, & any other info you can give us. Does it happen to all vehicles or only specific ones? Is it always at the same distance they disappear? If you look behind you, while driving in reverse, does the same/similar thing happen etc?



  • thanks for your replies so far:

    i made a short video to show you the effect:

    what i can say so far:

    • It's no an script issue (it's still the same when i disable all scripts and mods)
    • using different gameconfig files had no effect so far

    it seems, the effect is limited to specific cars or areas (or both)
    is it possible, that it's a loading the vehicles first and then checking the dlc pack only when i get closer to it?
    if yes, it really could be a corrupt dlc pack. what do you think?



  • @Augur89 Why are you moving so fast? Are you flying, using a jet, or just no clipping? The problem you are seeing is that the game spawns two types of traffic, one would be the real traffic you normally see while the other is fake traffic. Because you are traveling so fast the line between where the fake cars despawn for the real cars is very apparent. If you watch on youtube at .25 speed you can see the cars in the distance are very evenly spaced and look the same, but then as you come closer they turn into real cars with spaces in between. If you drive really fast you can see this effect as well, but its harder to notice because of the height angle. Not really a way to avoid this other than editing your keyholes inside the gameconfig.



  • @InfiniteQuestion
    well i just used a free-cam mode with high speed, which was in my opinion the easiest way to show, what i mean.
    in my opinion, the traffic should never behave like this, no matter how fast i move.

    how do i have to change the keyhole values in the gameconfig to get rid of this issue?

    Thank you



  • @Augur89 more complicated than i know to explain. I don't know exactly how to change it because you change one value and it effects them all, for example you can push the keyhole size further out to prevent you seeing the fake cars, but then without edits to the other values the streets will look empty, but then if you fill that empty space with cars without changing the cull then game crashes but if you don't change the cull right with the creation value then cars spawn behind you out of nowhere.....I can go on but the point is its not as easy as changing one number. Find a gameconfig that has a traffic value you like or experiment with the numbers.



  • ok, i'll give it a try. thank you



  • @Augur89
    Here is a tutorial that covers explanations of the 'gameconfig.xml' '<ConfigPopulation>' values you'll want to edit/play around with :thumbsup:



  • @a63nt-5m1th thank you


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.