Log in to reply

(Unconfirmed) Rockstar Launcher blocking rollbacks?

  • Hey guys, after the LS Summer Update i was able to roll back my game to v1868 and it worked fine until now, however it seems that today's (8/13) Rockstar Launcher update has blocked all previous versions of the game from launching!
    I backed up all of my files, tried to launch in offline mode without success. Has anyone else experienced this issue? Feel free to comment your cases too or provide helpful tips on how to fix this while ScriptHook gets updated


    seems as though if you're using the non-steam version (social club i guess) they've started checking to see if its the latest version or not

  • @Reacon I got that check and I'm on Steam version.

  • @Reacon i’m using the Steam version of the game, i guess they’re really starting to verify everyone’s files regardless of their version :(

  • @Modder33578 It's BS and now I'm pissed off.


    yeah happening to me too now, such bs


    @IreBurn @Modder33578 update, launcher bypass still lets you start the game fine with previous versions

  • @Reacon Using launcher bypass already. Been for months now.

  • @Reacon thank you chief, i’ll test it and i’ll update this discussion if it works.

  • @Reacon nogtavlauncher or gtalauncherbypass? because I'm using the latter and getting that update required message.

  • update: No_GTAVLauncher 1.0 and 2.0 (i tested both downloads) didn’t do it for me. it launched GTA V and i was greeted by a login screen that later showed me a Rockstar servers unavailable message

    @Reacon what mod/version are you using? bc mine is kaputt, thanks Rockstar

  • @Modder33578 These videos did the trick for me. I have epic version but they also outline the steps for Steam.

  • @Modder33578 1.0 working for me but the game crashed after a few minutes of being in game.

  • @ogauge thanks for your help chief, i’ll check the videos and update if it works

    UPDATE: worked like a charm. let’s hope they don’t patch this. i have zero faith in Rockstar’s offline mode as a workaround for this but hey as long as it works...

  • @Modder33578 2nd video worked for me but it's my understanding that scofflineonly works for a limited number of game starts or only for a few days before it requires an actual online login.

  • @IreBurn yes bud, we’ll have to go on and offline a few times until ScriptHook and other plugins get updated. i’ll update this in a few days to let everyone know how it goes and if this process can be replicated for the duration of the updates

  • @IreBurn This is true, believe like 5 days or something. But if you have a couple folders should be easy to switch back and forth between sign on unmodded and updated and signed off modded.

  • I copied the dlc.rpf from the summer update, so hopefully if this works, I can add the new cars? Never tried but I think it might work.

  • Oh yeah, this crap just happened to me. I play on the steam version. This method used to work before this update.

    1. Store a older vanilla version of gta on a stick drive.
    2. Update gta through steam.
    3. Launch updated game and load into story, then exit game.
    4. Delete gtav in the steam directory and replace it with my older copy from my stick drive.
    5. Drag and drop my mods back into the game directory.
    6. Launch game.

    This method used to work flawlessly for some time now. But with this sorry ass summer update, It won't launch my game unless I have my "mods" folder removed(texture mods, a few vehicle replacements and gun stuff) or I just get infinite loading trying to load up story mode. Scripts and .asi mods work though. Very strange.

    I do notice that this newer launcher that updates nearly every time you launch this game is way more aggressive now. This sucks, now I have to mod back a bunch of shit and its near 4-5 hours of work and wait for scripthookv to update. Ugh. :(

  • @TrustNo1

    this works. Been playing for the last hour after doing this.

  • @IreBurn It works without mods, but editing the update.rpf seems to crash it for me. Trying to find a workaround but no luck so far.

  • @PermissionToLand Working with mods for me.

  • @IreBurn

    Thanks for posting the vid, I'll check it out!!

  • @TrustNo1 It was actually @ogauge who first posted it, they deserve the credit.

  • @IreBurn Figured it out, just adding the new DLC exceeded the limit, so I simply replaced the heist DLC with it.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.