Log in to reply

17/08/2020 Pattern Failed Error Solution

  • Some people (Including me), recently downloaded the new version of ScriptHookV and saw that error message:
    "Pattern failed
    Failed 'B8 FF 01 00 00 4C 89 6D E7 66 23 C8 B8 FF 00 00 00' "
    If you're having this issue please read the steps below to "maybe" solve your problem (It worked for me)

    • Download a old version of ScriptHookV, which can be found at gta5mod.net.
    • Delete the dinput8.dll and the ASIloader.log in your GTA 5 main folder.
    • Open the old ScriptHookV files you just downloaded
    • Drag ONLY the dinput8.dll to your GTA 5 main folder
    • Now start the game and see if it will solved your problem
      If it doesn't work for you, you can try some steps that @a63nt-5m1th suggested here below.

  • @Lcesario78
    Do you have CScenarioPoint Patch or WOV installed? I mention it as it's the only place I can find reference to a 'pattern failed' error for GTA V, if you do have at least one of them installed, try installing CScenarioPoint Patch v1.4 that was just released (~16hrs ago).

    If you don't have CScenarioPoint Patch installed, other than making sure everything you have installed is up-to-date, making sure you only have one version of Heap Adjuster installed & have also installed Visual C++ Redistributable 2017 x64, I've no real idea what it could be. First time I've even heard of that error.

    Removing 'dinput8.dll' to fix it suggests it's either in your 'mods' folder files or an '.asi' is causing it (I would suspect an '.asi'). If you get nowhere with any other solutions, try moving '.asi' files one by one out of the game's root folder temporarily (if you haven't already), while testing in-game after each removal & then perhaps do the same for each '.rpf' archive in the mods folder (starting with 'update.rpf') to see if you can identify what is causing it?

    Checking details of the crash in Event Viewer may also give you something to work with also.

  • @a63nt-5m1th I actually just solved the problem, I'il update the post in a few seconds.
    I appreciate your concern anyway!

  • @Lcesario78
    Hi, what gameconfig are you using as the WOV one is out of date?

  • @Algonquin1234 thanks, I've given that one a go but it crashes. I've tried the gameconfig that you can get as a separate download with WOV and got it working 👍

  • I think just figured it out. It is literally the ".asi" file. I just deleted it and now I don't get the error, no crashes so far.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.