Log in to reply
 

Weird GTA V LAUNCHER crashing problem



  • BEFORE ILL SAY SOMETHING , I DON'T KNOW IF ITS THE RIGHT SECTION
    today i wanted to play gta 5 and when i launch the game (gtav_launcher.exe) or try to verify my files
    it will load infinitly
    but before that it shows an error for one second
    and it says
    "there was a error , we are sorry" "there was an unknown error in rockstar games server , try again later." "no errors found with your internet connection" "uncaught syntax error: unexpected token in json at position 181 error:2000.43"
    i didn't find anything on the internet so does somebody know how to help me ?
    PS. Game worked yesterday
    I tried using the "fix" option in uninstall menu
    And yes i have mods but thats not the case , the game is not crashing , the launcher doesn't work



  • yes i know
    i asked 2 people and i already know its something on my side
    even tho i don't know whats the reason
    yesterday it worked perfectly but today it doesn't work
    worth to mention that i deleted some junk folders (but that shouldn't be the case , because after that i launched my game and it worked perfectly)
    i tried reinstalling social club
    nothing
    i tried reinstalling direct x or microsoft....? what was its name?
    and nothing
    i tried removing mods (but not all of them yet , only like reshade enb scripthook or openiv.asi) and nothing
    lets hope it will fix tommorow.. i was so amazed that i modded my gta 5 almost like real life and now it just simply doesn't work



  • yes..
    but thats not the case
    launcher is not working
    game is working
    that means that i can't launch the game because the launcher doesn't work , it just gives infinite "busy spinner" and it doesn't launch the game



  • well as i said its not a game problem but a launcher problem
    ill wait till tommorow



  • still doesn't work.. but i think i deleted the social club by an mistake (weird thing is that i didn't use these folders which i deleted for years , and i didn't save any thing there)
    fucking christ.. (and yes i tried using rockstar social club download but that did nothing) ill try to find some more social club installation files and try to install them.. otherwise.. reinstall



  • apparently i need to reinstall the game.. AGAIN (even tho i reinstalled it week ago..)
    ill do it tommorow



  • @HeySlickThatsMe My advice would be to do what I have just had to do to clear a launcher problem.

    1. Copy all your saved games/video clips somewhere safe from your Documents\Rockstar Games folder
    2. Rename your GTAV folder to something else... see next point as to why.
    3. Uninstall GTAV from your add/remove programmes which will leave your GTAV folder intact, because it won't know what name you changed it to... but if you are worried, copy it somewhere as well.
    4. Uninstall the Rockstar Social Club and all data. This will clear out all data in your Documents\Rockstar Games folder, including any potential profile/cache corruption.
    5. Once you are sure that all that data is gone, rename your GTAV folder back to the original name.
    6. Use the GTAV Setup Tool (from here https://socialclub.rockstargames.com/activate), not the Social Club installer, to reinstall the game. When it runs, point it at your existing GTAV folder (after you have renamed it back ofc) and it will only download the bare minimum it needs to get working again... which will include the Social Club launcher.
    7. Run the game once to make sure it creates all the right Saved Game folders etc... then copy your Saved Games & Video Clips (if you have any) back into the Documents\Rockstar Games folder.

    It's a bit of messing about but it means you don't need to do a complete reinstall. Also, just make sure you don't have any scripts/mods etc... on the first load to make sure the game is only working with clean data, then put everything back... slowly.

    Edit: I should add, I have the Retail version, not Steam... so things might not be exactly the same with the Steam version.



  • i have retail version too :P
    thanks for the help ill try everything



  • aaaanddd its not working.. :C



  • only option for now is whole reinstall
    ill do it asap and i'll see if the problem persists
    if it persists... then i don't even know what to do
    im bored as fuck without gta 5 lol , i had more than 400 hours in this game
    even getting out of the game , installing more mods/doing more mods , opening the game repeat



  • @HeySlickThatsMe Sorry it didn't help. I thought it was worth describing what worked for me as it saves a whole reinstall.



  • yeah i know
    but its something related to files i think (and its weird as hell)
    because nothing did help right now
    now im installing disc 4



  • oh lol now 5



  • im angry as fuck
    it doesn't work after a whole reinstall



  • @HeySlickThatsMe Have you got all the pre-requisites installed that it lists on this page? https://support.rockstargames.com/hc/en-us/articles/203458663

    Social Club should be okay, but what about the Microsoft Visual C++ 2008 SP1, have you tried reinstalling that?

    I seem to have a whole bunch of those but I'm not sure which one applies to GTAV.

    alt text



  • @LeeC2202 It requires Microsoft Visual C++ 2008 SP1 Redistributable.
    Edit: Oh, you already mentioned that. Sorry.
    Another edit: SP1 is the 9.0.30729.17 version.



  • i have that installed.. lel (and why would i uninstall it?)
    alright i clicked fix option
    if it doesn't work then ill reinstall it
    if not then still need to find something different



  • sadly doesn't work
    lets see.. i have some different error and i noticed it now
    but its similiar to this one , let me make some printscreens



  • "there was an error we are sorry"
    "script error"
    "error code: 1000.104"
    let me google that



  • XDDDDDDDDDDDDDDDD
    im fucking done
    i had to delete social club folder.. now it works
    it can be locked lol
    TIP for people which have this problem: delete your socialclub fodler in the documents (Documents/Rockstargames/SocialClub)



  • @HeySlickThatsMe Didn't that folder get deleted in step 4 of my original post? That's very odd... Anyway, good to hear you're back up and running.



  • oh woops
    after i was reinstalling it i only deleted gta 5 folder , my mistake xD
    i didn't read it carefully and i did that fast like flash (because i already wanted to play)


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.