Log in to reply
 

props collision



  • I added some props in the game using Meth0d & Quechus13's AddonProps, but nothing has collision. I'd like to know how can I add collision to the props.



  • I tried to make collision to the props by myself using 3ds max and GIMS evo and this is what I've done:

    0_1598986194142_Untitled.jpg
    0_1598986197317_Untitled2.jpg

    Everything seems fine in Open IV model viewer, I made an embedded collision, but in game it still doesn't work. I still can walk through the object. I'm using Meth0d & Quechus13's AddonProps to get the props in game, but no collision.



  • @Abrian19 If you have zmodeler, I can help you. It's super easy



  • @death7991 yea, I got zmodeler. It's the first app I tried to make collision, but when I want to import ydr/odr files it sends me some errors.



  • @Abrian19 Did you put the collision name in the physicsDictionary line of the prop in the CBaseArchetypeDef in the ytyp? Also, not sure if this actually matters, but try to use a decimal point instead of a comma for the Unk VertOffset part value. I do remember helping someone else in the past with embedded collisions not working and that was one thing I changed along with a few other things that ended up making it work.



  • @chonkie I'm adding the props using the addonprops tool, so I don't have that ytyp type of file. If you know another way to add new props into the game without addonprops I'd be glad to hear



  • @Abrian19 Here's a thread where I've answered this before and included an example pic of how I add props to my game so I can spawn and place them with CodeWalker. https://forums.gta5-mods.com/topic/29898/help-with-object-creation

    If you don't have the ytyp info for the prop, there is a ytyp creating tool on gta5-mods by Skylumz that you can use to create it.



  • @chonkie I tried to use Skylumz' tool to create an ytyp file, but when I try to import it in the open iv it sends me an error:

    Some files not imported, more information below.

    template.ytyp.xml(Line 0): Unable to import META/PSO file.

    Or when I try to make an ytyp file by myself I get this message:

    Open IV is unable to save file changes, please try again later.

    SYS_ERROR_00000005: Access is denied


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.