Log in to reply
 

Per frame drawing of marker cylinder is not working anymore



  • Hi,
    I haven't played GTA V for several months and now that I'm back I face the issue that marker cylinders which are drawn per frame don't show up anymore neither with my teleportals mod nor with other mods using this. The teleportal name display above works, however. My mod does not crash and a fun fact is that when I let my character eat, drink or smoke something with the HumanNeeds mod, the markers are drawn while the animation runs.
    So what specifically has changed while I was away and how can I fix it?
    BTW I'm still on shvdn 2.10.10 because the newer versions make my mods crash. It's still 2.10, right? Bug fixes should not introduce breaking changes but they do in this case. I know V3 is out but that won't work anyway and I don't feel like rewriting all of my mods from scratch as I have retired from modding, actually.



  • It's 2.10.13 now. Should still be compatible with 2.10 though.

    Check if the native implementation changed - don't think it has, but better to be sure.



  • @ikt I've tried 2.10.13 but many of my constructors throw a NullReferenceException. That's why I was wondering about a breaking change in a bugfix iteration. Maybe it's because I reference classes which inherit from Script? I know the shvdn guys don't like that.
    I mentioned the markers are drawn as soon as (I reckon) something is slowing down the thread handling. I've already tried a call to Yield() but to no avail. The Tick event fires once per frame if I don't set an interval, right? Heck it worked flawless before.



  • Now it gets totally weird!
    While playing with an original character the markers are not being drawn but when I change the model to any NPC character they become visible. It can't be because of the different text labels. This and the marker rendering are two different independent threads.
    alt text

    alt text


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.