Log in to reply

Some mods not working

  • Hello everyone! For the last week, I have been trying to mod GTA 5. Although my game runs fine, there are still some mods that are not working. Almost all of them are script mods, such as Vehicles Persistence and RazieLex's Car Lock System. I have already tried re-installing Script Hook V, Script Hook V .NET, and NativeUI multiple times, without any luck. I'm not sure what I can say more. If there's anything you need to search for the cause, such as log files, feel free to ask me. I hope that someone can help me because I'm not coming far myself.

  • @Samjanss0n The mods themselves could be outdated

  • @death7991 Could be, but Persistence II for instance is also not working properly.

  • @Samjanss0n

    Make sure you have the requirements for Script Hook .NET installed as well. Many people miss this part.

    I've also had a few people put files in the wrong spot so make sure the Script Hook and Script Hook .NET files themselves are in the main GTA V directory while the scripts are placed in the "scripts" folder, unless specified otherwise.

  • @IAmJFry I already have the requirements for Script Hook V .NET installed. I also already put Script Hook V and Script Hook V .NET in the main folder, and all the script mods in the scripts folder. These things can’t be the issue for me unfortunately.

  • Ok, so I was looking thru all the mods that are not working, and I came across an error log file for Vehicles Persistence. This is the error log. It contains a lot of errors, so I hope that someone can tell me what it all means, and hopefully find a fix for me.

  • @Samjanss0n
    Ooooh. I thought no scripts were working so that's my bad. Pretty sure because the mod hasn't been updated that's why it's not working. Functions and all of that have been removed or changed in the newer versions of ScriptHookV .NET so I'm guessing that's what's causing the errors such as the " Method not found" errors.

  • @IAmJFry Oh, ok. I can believe that, but I also tried Persistence II and this was also not working... I can download it again and look for a log file?

  • @Samjanss0n
    Yea you can. That one should work as long as you have the requirements listed in the description for that mod as well. I think it's mostly the same stuff though you said you already had.

  • @IAmJFry I downloaded Persistence II, and again no luck... I can also not find a log file for this mod. What should I do next? Oh, and just to clear everything up, two mods are currently causing trouble for me. These are Enable All Interiors and Persistence II. This makes finding the problem hopefully a bit easier.

  • @Samjanss0n
    What are some scripts that are currently working? Also, are you putting both the ScriptHookVDotNet2 and ScriptHookVDotNet3? Just want to make sure to cover everything.

    Both of those mods are up to date as far as I can tell so if you do have all of the requirements downloaded then it should be working.

  • @IAmJFry Some examples of scripts that I’m currently using are Better Chases+ and Pull Me Over. I have also pasted all the files that came with Script Hook V .NET in my main folder. One question. Do I also have to paste the .asi file for Script Hook V .NET in my main folder, or is this not necessary because I have read somewhere that just OpenIV.asi was enough?
    Maybe, the cause of my mods not working is the amount of (script) mods that I have installed. Can it be possible that some (script) mods interfere with others?

  • @Samjanss0n
    Yea, you'll also want the .asi file in there as well.

    I can't look more into it until tomorrow but I really don't think they should be interfering with each other. I'll reply tomorrow after I get a chance to look into it more.

  • @IAmJFry Ok, that’s fine. I really appreciate your help!

  • @Samjanss0n
    Hey do you have Discord? Might be a little easier to solve and talk that way. If we figure it out you can post the solution here if you want for anyone that might have the same issue.

  • @IAmJFry Great idea! My Discord credentials are Samjanss0n#7298.

  • To anyone interested in knowing whether I have solved my issue, the simple answer is no. After six months already, I just can't seem to find the cause of my issue. I have accepted my loss and am now using a persistence mod called Szabo's Persistence Mod which is working alright for me.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.