Log in to reply
 

Dark Screen Effect



  • Hello guys. Is there any chance to disable this dark screen effect when I turn on lights on police vehicle? I'm using this mod for lights https://www.lcpdfr.com/downloads/gta5mods/datafile/18520-better-emergency-lights-16/
    Lights off - https://imgur.com/90c6u2l
    Lights on - https://imgur.com/a/9PYr7ia



  • @Coach I'm seconding this as well. I believe it's called adaptation ( It was called this in Fallout 4 ). It's pretty annoying honestly and a very bad decision to implement something like this into games :(



  • @Coach @Aurora11
    I'd start with 'visualsettings.dat':

    ...\mods\update\update.rpf\common\data\visualsettings.dat

    Vanilla values are:

    # Adaptation
    Adaptation.min.step.size 	0.15
    Adaptation.max.step.size 	3.0
    Adaptation.step.size.mult 	1.5
    Adaptation.threshold 		0.0
    Adaptation.sun.exposure.tweak	-2
    

    I'd probably lower the top three 'size' values to zero, see what you get & then if you're still having issues after that, try out various values in Adaptation.threshold.

    ENB also has some adaptation settings in 'enbseries.ini'. If you have it installed, you'll be able to see any changes you make in-game in realtime. Which may be useful for diagnosing or it could be ENB settings that are causing it to be so pronounced etc. Worth ruling out if you have trouble getting rid of it.



  • @a63nt-5m1th I changed the values and even went crazy too but it's still happening :(( Lowering first 3 to 0 only changed adaptation speed :( It just made the transition instant.

    alt text

    alt text

    I'm having the problem with too bright moon because of this :( While I'm looking straight, the sky is dark and moon color is proper but when I look up, I'm seeing horizontal etheral blue-ish lines (barely visible) moving towards the sky and causing moon to become too bright :(

    If you look closely at the first photo, they are more visible when you look at Mikey's right above the ferris wheel. At the 2nd one, they are seen better when you look left of the head.



  • @Aurora11
    Yeah, I was pure guessing at the 'visualsettings.dat' values :upside_down: . I've never had to edit them as their effect is pretty subtle in my game. You don't notice it unless looking for it.

    No idea about the blue bands, probably a byproduct of mixing different parts of mods together or something?! (I see you've been messing with Redux & NVE a lot recently).

    @Coach This next part may be useful for diagnosing your adaptation issue too:

    I would first confirm it's not in your vanilla game, & then rebuild your 'mods' folder one '.rpf' at a time until you find which files or combination of files is/are causing it.

    Basic Process (it's pretty quick & easy to do it this way, usually less than an hour):

    Preparation:

    • Test remove/switch off any ENB or Reshade
    • Remove all scripts (rename 'scripts' folder etc) & remove any '.asi' mods that alter environment or visuals.
    • Test load the game to make sure it wasn't any of the above causing it.

    Mods Folder Rebuild:

    • Rename your 'mods' folder to something else.
    • Create a new folder called 'mods' where the old one was.
    • One by one, move '.rpf's/folder structures etc from the old (renamed) mods folder to the newly created one (Note: 'move' (not copy), it takes seconds that way, won't take up any more hard drive space & also you won't get confused about what you have or haven't moved already).
    • Test load the game after each addition/group of additions, until you find the one/s causing it.
    • Starting with a vanilla/working '.rpf', use the same process to add files within the identified '.rpf'/s/folder structures to figure out what file/s are causing the issues/s & replace/remove/fix etc

    That^ should be your goto method for file related issues in GTA V. If the issue is in a '.rpf', that method will find it, & if you can find it, you can fix it :thumbsup:



  • @a63nt-5m1th Oh I know it's ok haha :D I was just letting you know about the results :))) I was switched to NVE recently but because of corona problem and couldn't fix it I just gave up and returned back to Redux. Going to save my Christmas money if I can get any to buy GTA Remake :D

    Anywho, it's actually very subtle in my game and I normally don't really noticing the darkening this much as long as I don't look at explosion closely. Although the moon problem was bothering me a bit. but I just took the liberty of duplicating Clear and Extra Sunny timecycles and renaming them with Neutral and Smog. Then I just lowered the moon color values to half and when the moon is too bright, all I have to do now is to switch to the other weather :D



  • @a63nt-5m1th Thanks for tips. Tomorrow, If I will have time I will test your solution. That darking effect happens only on cars from SAHP pack.
    https://www.gta5-mods.com/vehicles/sahp



  • @Coach
    I can confirm that the adaptation esque darkening when the siren lights are on with the vehicles from that pack happens in my game as well.

    Lowering these values in 'visualsettings.dat' will decrease the darkening effect:

    car.defaultlight.day.emissive.on		2000.00
    car.defaultlight.night.emissive.on		1000.00
    

    but obviously, that also decreases the lightbar lights brightness, so presumably not ideal.

    I played around with a lot of values, but didn't really find anything else that could solve the issue any better than that (they all decreased the lightbar lights brightness in some way or another).

    I don't think my 'Mods Folder Rebuild:' advice above will do anything for you either. There doesn't appear to be anything broken with the game per se (apart from not being able to get rid of adaptation completely :angry: ).
    Edit: Perhaps those vehicles could do with an edit in ZM3, their lights are a lot brighter than the vanilla ones & they have more of them too, so the effect is a lot stronger than vanilla vehicles (I'm pretty sure the same thing would happen to vanilla lightbars if you kept pushing the 'car.defaultlight' values higher).

    I reckon your limit, without having much noticable adaptation, will be somewhere near here:

    car.defaultlight.day.emissive.on		300.00
    car.defaultlight.night.emissive.on		150.00
    

    Either increase from there, or lower the values you have & see if you can find a compromise you can live with :thumbsup:



  • This post is deleted!


  • @a63nt-5m1th @Aurora11
    Ok I tried some settings.

    1. Change size to 0 in
      Adaptation.min.step.size 0.15
      Adaptation.max.step.size 3.0
      Adaptation.step.size.mult 1.5
      Didn't help.

    2. Then I tried changed Adaptation.threshold to 5.0 - didn't help. Then I tried change ONLY Adaptation.threshold to 5.0 and it didn't help too

    1. I tried delete whole # Adaptation section - didn't help.

    2. I tried play with car.defaultlight.day.emissive.on
      and car.defaultlight.night.emissive.on
      and it works :).

    I changed some more things in visualsettings.dat:

    	car.indicator.day.emissive.on		to	250.00
    	car.indicator.night.emissive.on		to	150.00
    	
    	car.reversinglight.day.emissive.on	to	25.00
    	car.reversinglight.night.emissive.on	to	25.00	
    	
    	car.defaultlight.day.emissive.on 	to 	500.00
    	car.defaultlight.night.emissive.on 	to 	150.00
    

    Now emergency lights look good and bright. I nearly removed dark effect or completely removed. Other settings are because in this mod indicators are too bright and reverse light is not bright.

    Ok thanks for help.



  • @Coach Very happy you fixed it fren :)))



  • @Aurora11 Oh, btw that dark effect happend on other cars too which I have (LSPD and LSSD pack from 11john11) but it was less intense than on SAHP pack.



  • @Coach @Aurora11

    visualsettings.dat

    # Adaptation
    Adaptation.min.step.size 	0.001
    Adaptation.max.step.size 	0.01
    Adaptation.step.size.mult 	0.01
    Adaptation.threshold 		10.0
    Adaptation.sun.exposure.tweak	-2
    

    Seems to have completely (& I mean completely) fixed the issue for me.

    I even set my brakelights 13x higher than I normally have them (just to test, see pics) & still no eye adaptation/dark screen issue happening :slight_smile: :thumbsup:

    I'm using PostFX = Ultra, just in case that makes a difference, but I doubt it. Adaptation/dark screen issue is probably stronger on Ultra if anything.

    Brakelights OFF:
    Brakelights OFF

    Brakelights ON:
    Brakelights ON

    If you test it out, let me know you're results. Might be a combination of other settings & these ones required to get it to work. So glad it's gone tho :slight_smile: :thumbsup:


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.