Log in to reply

How do you save a dds?

  • I have Photoshop 2020 with the Nvidia plugin and I also have paint.net.
    Most of the time everything is fine, but my last texture glitched - as you move around the textures on the border of the frame flicker and change colours.

    1. what are the best settings to save dds for textures in either or both PS and Paint.net
    2. Is it possible to create a transparent dds texture, with text for example that could be applied against a wall?

  • Is your texture power of two? (eg: 256x256, 512x512 or 1024x1024)

  • @JohnFromGWN
    Try IntelĀ® Texture Works Plugin for Photoshop (Nvidia's DDS Plugin has always been a bit funky for me anyway).
    Download is blue 'Download Plugin' (<direct link) at top/leftish of main page in link above.

  • @HeySlickThatsMe Hi. Yes, textures are always power of two.

  • @a63nt-5m1th Thanks, will download and install. And what settings are you generally using?
    The specific prop I'm having trouble is with prop_b_board_blank
    This is a blank green classroom board and I watch to add text in a chalk font to it. I'm doing this for my students during the pandemic to try to keep them motivated. They love games and so do I.
    When I save the file, either in PS or Paint.net, the texture itself is rendered fine but the thin brown border of the border is what has glitches.
    Any help would be greatly appreciated.
    P.S. I'm a teacher, English, not a programmer.

  • @JohnFromGWN
    The 'pb_chalkboard.dds' texture doesn't have a transparency alpha channel, so just save it as DXT1 with these export settings :thumbsup:


    If an image does have a transparency alpha channel, save it as DXT5 with these settings instead:


    That's pretty much all you need to know for standard diffuse textures. :thumbsup:

    Test out the Intel DDS plugin & see if you still get the glitching. If so, let me know where I can find that prop in-game & I'll play about with the prop/texture & see what it does :thumbsup:

  • This post is deleted!

  • Update: I managed to load the file in Texture Toolkit and create my addon. The change was a dialog in PS asking to load mipmaps. First time I said no, this time I said yes even though i removed the visibility in each layer.
    When I started GTAV I saw I still get the same glitch, you can see the border is not the right colour and it will change as the camera moves.

    alt text

  • https://i.imgur.com/cyaaOyv.jpeg

    prop: prop_b_board_blank.ydr
    Grand Theft Auto V\x64c.rpf\levels\gta5\props\lev_des\lev_des.rpf\

  • @JohnFromGWN

    Try using this 'prop_b_board_blank.ydr' instead & see if the problem persists (backup the original beforehand).

    The wood surround uses a texture called 'Prop_Wood_Fine_02'. I found that texture & embedded it into the 'prop_b_board_blank.ydr' in that download above.

    To edit the textures, you edit the embedded ones obvs. As you know, Texture Toolkit can give you access to embedded '.ydr' textures. Codewalker's RPF Explorer Export/Import XML can do the same (if you ever need another way of doing it at some point etc).

    The edited 'prop_b_board_blank.ydr' above looks fine in OpenIV, so figure it's probably good in-game too, you can confirm that if you want. Test it out & let me know. :thumbsup:

  • @a63nt-5m1th Fantastic! Thank you so much!
    I had problems with PS, crashing Texture Toolkit. Had to open it with mipmaps and then rearrange the layers so that my background and text were a the top....etc.....but now I know how do it.

    One question for you. Obviously I never saw the second texture, what did you use for the .ydr, 3ds Max?

    have no idea how to embed this pic


  • @JohnFromGWN
    Yeah, 3DS MAX 2017 for me.
    You would need a copy of 3DS MAX that works with GIMS Evo with GTA V Support to be able to import & export .ydr/.ydd etc.
    Anything from v9 to 2017 should work with GIMS Evo out of the box (newer versions possible, but need a little work to get them functional, from what I've read). :thumbsup:

  • @a63nt-5m1th I know there is a plugin for blender (as in free) for .odr but not sure about ydr.


    Just another word of thanks for your help. Really appreciated.
    It's very hard to get any specific support on GTAV modding so much of what I've learned has been by trial and error - not the most efficient way to learn, but I"m progressing.
    Cheers and stay healthy!

  • @JohnFromGWN
    Cheers :slight_smile::thumbsup:

    If you right-click on a '.ydr' or '.ydd' in OpenIV & select 'Export to openFormats (.odr) Ctrl+S' you can export to openFormats/.odr & try that plugin :thumbsup:

    Embedded Forum Post Pic:

    • Upload your pic somewhere & copy it's link to the clipboard
    • Type a name for the pic in your post in the position you want it to appear
    • Highlight that name/text by left-clicking & dragging over it
    • Select the picture icon at the top of the text box (4th from right)
    • Press Ctrl+V to paste the link into/over the 'image url' part of the text (already highlighted) & the image should appear in the preview pane on the right of the screen.

    It's basically in this format:

    ![alt text](image url)
    ![Enter Chosen Name of Pic Here](Enter Image URL Here)

  • @a63nt-5m1th Thanks. That was the strangest embed I've ever done.

  • @a63nt-5m1th
    The .odr opened nicely in Blender. Don't know where the texture files can be exported to see the texture that was missing when the .ydr was extracted.

  • @a63nt-5m1th Something still puzzling me. I played with the .odr file in both blender and also just with notepad ++. I can see where you saw the reference to the missing texture:
    DiffuseSampler Prop_Wood_Fine_02
    HardAlphaBlend 1.00000000
    UseTessellation 0.00000000

    But where did you find that texture to embed it in the ydr? I did a hdd search as well as an archive search with OpenIV and can't find it.

    I'm having a similar issue with a prop, prop_table_04 but in this case all files seem to be accounted for based on its .odr.
    I repackaged the .ydr, without changing the textures, created an addon, and it failed as well.
    So I've encountered 3 types of addons so far:

    1. Embedded texture which can be replaced without any issues
    2. Missing texture, the one with Prop_Wood_Fine_02 missing - which you so kindly fixed but I don't know where you found the texture.
    3. Prop_table_04, which at least based on its .odr file, is not missing any textures or files yet will not allow me to create an addon.
      (again regardless of whether i change a texture or just leave it intact)
      The .odr is shown below.
      There are 3 texture files with 3 corresponding .otx files
      1 bound file, 1 skel file, and the mesh itself.
      Every file referenced in the .odr (below) is accounted for yet I'm unable to create an addon.
      In passing I can do the addon process in my sleep now, having done about 20 (successful) iterations - but obviously I'm completely missing the boat on this one.

  • Ok. So after getting some sleep I realized what might be the issue and I was right.
    I used a different approach this time.

    1. Extract files as .odr rather than .ydr
    2. The open format files are all text files, editable in notepad, except for the textures
    3. Looking at the files i realized it must be a path issue because i'm renaming my .ydr so it doesn't conflict with Rockstar game file
    4. I renamed all references in the open format files to be consistent with the new name.
    5. From Open IV i brought the .odr file back in
    6. Opened Game, spawned object, PERFECT!
      next step is to modify the texture file and redo process

  • @JohnFromGWN
    GTAV is a bit of a mess as far as texture use/locations are concerned. There are tons of the same textures duplicated all throughout the game.

    All I really did was use Codewalkers RPF Explorer (CW > 'Tools...' > 'RPF Explorer...') to export the '.ydr' to XML & have a look at what textures it used. I then did a Codewalker Binary Search (CW > 'Tools...' > 'Binary Search...') for 'Prop_Wood_Fine_02' & chose a '.ytd' at random.
    Exported the texture, added it to the ''prop_b_board_blank' folder & then manually added it's details into the '.ydr.xml's '<TextureDictionary>' section.

    To be clear, the texture would have worked without being embedded, I just stuck it in there for ease of editing & to diagnostically remove a variable. :thumbsup:
    If the 'prop_b_board_blank.ydr' I uploaded worked perfectly, it's most likely because of the part of the model I removed, not exactly sure what it was lol, some big invisible (in-game) cream coloured rectangle, just figured making the model as simple as possible (within your specific constraints) might stop the glitching etc.

  • @a63nt-5m1th Thanks again Agent Smith. That one had me puzzled. I'm quickly moving from total noob to noob apprentice.
    So I finally managed to change the texture, just a proof of concept, on this table prop that was not cooperating.
    Thanks for your tip of using .odr.
    One interesting thing. When I did the first pass importing back in OpenIV it went smoothly.
    The second time it created an error with a missing file, wrong path. Inspecting the files path was correct and file was there??
    So in frustration I just dragged and dropped the .odr into OpenIV. Loaded perfectly. Go figure.
    Once more I really appreciate all your help and tips and clarifications.
    I doubt I'll ever be in a position to returrn the favour though.
    Table in back is standard prop. Table in front is just test, replaced texture in PS and created addon.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.