Log in to reply

DLC mods not working.

  • I recently installed the latest version of the game and made sure that all of my modding equipment was up to date (scripthook, gameconfig, mods update folder, etc.) but when I loaded into the game, none of my add-on dlc's appear to have loaded. The game runs just fine, it doesn't crash, and I know that the mods folder itself isn't the problem. I've been using add on mods for years now with no issue. Like I said, my gameconfig (F7YO) and edited dlclist are all there. I've run out of ideas as to what could be the issue.


    @2BombsLater you're on 2189.0 then, right?

    Do a quick test. Take the vanilla dlclist.xml from update/update.rpf and add only one single dlcpack line and see if you can spawn that one?

  • @ReNNie Dude holy shit that worked. The vehicle spawned no problem.

    Yeah I'm on 2189. Is there some issue with my dlclist then? Do I have too many installed or something? I know its not an issue with the gamconfig, otherwise it would crash.

  • @2BombsLater

    Upload your edited 'dlclist.xml' somewhere (Mediafire or some such) & post a link to it here :thumbsup:

  • @2BombsLater

    Try this:

    Change this part:

    		<item>dlcpacks:/podracer/<item> <!-- missing forward slash in closing statement ('<item>') -->

    To this:

    		<item>dlcpacks:/podracer/</item> <!-- forward slash added ('</item>')-->

    That should hopefully fix it :fingers_crossed:
    If not, let us know :thumbsup:

  • @a63nt-5m1th Strange. I changed it but the game crashed on startup. It just force exited out though, no error message or anything. That's progress though, at least we know now that it must be an issue there. Perhaps adding that slash allowed all the dlc's to load, but then another issue happened because of something else?

  • @2BombsLater said in DLC mods not working.:

    Perhaps adding that slash allowed all the dlc's to load, but then another issue happened because of something else?

    Yeah, I'd say so :thumbsup:

    You'll have to go through your 'dlclist.xml' & figure out if it's an individual dlc, combination of dlc's or a dlc limit.

    Remove lines from your 'dlclist.xml' in blocks of 50 or something to start with, five or so loads of the game (~250 dlc's, 200 dlc's, 150 dlc's, 100 dlc's, 50 dlc's... etc) & see if it bypasses the crash on any of them.

    If that works, add back in smaller combinations of dlc's (10 or 5 at a time, down to 1 when you get close etc) to test to see if it's an individual dlc, combination of dlc's or a dlc limit that is causing it.

  • @a63nt-5m1th Ok well I did some experimenting, and I'm pretty sure it's a limit problem now. I tried narrowing down the dlc's and came to a group of 4, but removing them didn't do anything. I still don't understand what's actually causing the problem though. I should be all good, I have the gameconfig, the heap adjuster, and packfile limit adjuster. I shouldn't be hitting the limit.

  • I'm having the same problem. I can't add any new DLCs without my game crashing on startup. Packfile limit adjuster doesn't help. It doesn't seem to matter what dlc it is, either. I've tried different ones one at a time and none work.


    @2BombsLater right, I actually experienced this exact same problem when messing with 2189.0 and adding in several MLOs on top of my existing dlclist.xml with cars, weapons, Alex106's stuff, Forests of... etc. Suddenly all my Add-On vehicles were invalid, that's why I asked you for this small test.

    You could try and increase ArchiveCount in gameconfig.xml and PackFileLimitAdjuster to around 5200 for a bit more testing?

    Me, myself and I threw in the towel for now, have a modded update.rpf on 2189.0 with NVE etc but went back to my modded 1868.0 as primary version for mods :/

  • @ReNNie Tried both, no luck. Well that sucks. I don't have an older version that I can use. Guess I just have to wait until something changes then? I've tried just about everything. I just don't understand what could be wrong. I've been trying to get ahold of somebody else's gamconfig who has a lot of add ons just to do some experimenting with it.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.