Log in to reply
 

.rpf archive is corrupted after closing OpenIV



  • I made a huge carpack by myself (4.5 GB) , and after closing OpenIV and running it again, vehicles.rpf corruptes. I dont want everytime replace corrupted archive with backup file . Also , I need to run gta 5 with opened OpenIV , because it won't start without it. How do i fix this?


  • MODERATOR

    @xDev0n RPF files can't be higher than 3.5GB size (max recommended), otherwise the game will corrupt them. You'll have to split your RPF into 2 carpacks (so 2 RPF files) and keep both of them under the 3.5GB limit size.

    Also, first try defragmenting your actual RPF file with OpenIV. It might help you for now if you haven't done that already.



  • @Reyser it helped me, thanks! It also fixed texture loss on some places of map


  • MODERATOR

    @xDev0n Good to know it helped you :thumbsup_tone1:



  • @Reyser Thanks for your help Reyser!
    How do I defragment my vehicle.rpf file?
    It is 4.1 GB I think and I don't have any backup of it (my bad).
    Do you have any solution?
    Thank for your reading!



  • @budy-belgium You do realize you're in a 10 month old thread?
    To defrag, go into Edit Mode, highlight your rpf, go the File Menu, Defragmentation.



  • @JohnFromGWN I do realize it but I knew someone would see my question.
    I tried to defragment my vehicle.rpf but it doesn't defragment it despite the fact that I selected it.
    It finishes the defragmentation by telling me "it's completed" but I'm still not able to open it.
    The dlc.rpf is the only one that I can defragment.
    I want to defragment the dlc.rpf.



  • @budy-belgium using OpenIV create a new folder and a new rpf.
    Extract all files from old folder to desktop and drag and drop into new one.
    Delete old folder, backup if required, then rename new folder with old name.
    If necessary create new subfolders with new rpfs but hopefully that won't be necessary.
    This will fix the issue and bring your file back to normal size.



  • @JohnFromGWN I thank you for the help you brought me but it didn't work.
    I made what you recommended me to do but it failed.
    I also discovered that all files can be successfully defragmented except my vehicles.rpf. (the file that is corrupted)



  • @budy-belgium ok try this.

    1.extract your files from vehicles.rpf to your desktop

    1. Delete the vehicles.rpf
    2. Choose a vehicles.rpf from a working mod and place it where the deleted one was
    3. Delete all the files from the replacement vehicles.rpf from step 3
    4. Import, drag and drop, all your files from the desktop in your empty vehicles.rpf

    That's gotta work, if not you have other issues like your hard drive.



  • @JohnFromGWN The problem is that I can't import my files inside my original vehicles.rpf because my file is corrupted.
    I tried many ways to import them in OpenIV (Extract - Save content/Export) and it only extracted the vehicles.rpf.
    I tried to replace the vehicles.rpf from a working mod by the wanted one but it failed...



  • @JohnFromGWN I sent a message to OpenIV. I hope they can solve this problem as I didn't find any working solution on the internet.

    I always find a solution when I mod GTAV. I have to admit that this is the toughest problem I ever had.
    And it was caused by something really stupid compared to all the modding non-sense I've done before.

    Once again thank you for your help, I'm sure I'll find a solution.



  • @budy-belgium I really don't understand why this isn't working. If you want, put your vehicles.rpf with all the models on Mediafire and I'll try to create a vehicles.rpf for you. Are you exceeding any limits for file size? Is it greater than 4GB?



  • @JohnFromGWN Yes it is, I wasn't aware that a vehicles.rpf above 4GB would make the file corrupted.



  • @JohnFromGWN Here is the dlc.rpf where is my vehicles.rpf.
    https://www.mediafire.com/file/bxx1a6prek1s0r5/dlc.rpf/file
    It isn't necessary to help me if you don't have time, I'll find a solution anyway.
    I already started redownloading all the cars (it takes time but I'll finish it one day).

    Once again thank you for the help!!



  • @budy-belgium Hi. I misread or misunderstood your post sorry. I thought you meant you got a corrupt error message only when you tried to defragment the vehicles.rpf file but that's not the case, you can't even open the file. So my suggestion to extract the cars and then reimport them in a new vehicles.rpf is useless.

    Only fix is to start from scratch. Not sure why you are redownloading? Did you not keep the originals.

    https://openiv.com/bugs/view.php?id=669



  • @JohnFromGWN Originals are locked inside the vehicles.rpf. But don't worry I'll redownload everything back with some improvement in some vehicles.

    It'll take time but I can allow myself to spend it.



  • @budy-belgium Suggest you do 1 car at a time.
    Test to open.
    Backup the vehicle.rpf.
    Do 2nd car.
    Rinse and repeat.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.