Log in to reply
 

Need help: Getting old GTA 5 Install working again.



  • Hi everybody and thanks in advance for any tips and (hopfully) a solution.

    Let me first say, I wanted to do a search, but it seems the forum no longer has one, so this might be a double post ...

    And here is my situation/problem.
    I haven't played GTA in a few months... Back in 2019 I installed my GTA with mods and it was all fine. Thanks to launcher bypass I wasn't bother by updates or anything. I was happy as could be.
    Now a few days ago, I wanted to get back into GTA, but whenever I started my install it said something like "You need Rockstar Launcher to play"
    Adding a scofllineonly into commandline presented me with a "Need to be online for activation" error. Since I would have no problem with GTA connecting for activation (I own/purchased the Warehouse/DVD version of GTA) I removed the commandline again.
    But then again was stuck with the Rockstar Launcher thing. Weird to me is: my installation and game wasn't updated for months, even before Rockstar Launcher existed...
    So after I assumed there is no way around this, I decided "Fine, lets install that rockstar launcher virus then"
    Installation of this Forceware was without problems and I managed to avoid any kind of autoupdates of my game. But now GTA does not even start ...
    No error, no start screen nothing... Uninstalling Rockstar Launcher and installing an old version of Social Club brings me back to the same error. either I get a "Social Club to Old" Error or an "activation error" if I force the game to be offline ....

    I guess long story short: Is there any chance to play old (modded) installs or did Rockstar finally succeed in ensuring they always force the newest version down our throat?
    If the latter is the case, I guess I just give up on GTA, because it's just too much of a hassle redoing all the mods.

    P.S. According to the version.txt in my install I'm running version 1.0.231.0



  • @Sabrina2001 Unfortunately, the cockstar launcher is a requirement to play GTAV, since the release of a stupid little update after the Diamond Casino & Resort update released in July 2019.

    What game version was you on prior the game updating? You can check by going to update.rpf > common > data and looking at version.txt.



  • @WGotch07
    I see ... Then I guess that's it with GTA for me if that stupid launcher is needed. Personally I wouldn't mind having another crapware installed (CPU is strong enought for having background shit running) But the problem seems that as soon as I install the launcher my current install won't start at all ...

    And the version.txt inside the update.rpf > common > data, it says the following about my version:
    Version number - the number set here will display in the game

    [VERSION_NUMBER]
    1604.1-dev_ng_live

    version number for install files in non-final builds
    [INSTALL_VERSION_NUMBER]
    0

    version number for savegame files in non-final builds
    [SAVEGAME_VERSION_NUMBER]
    0

    version number for replay files in final builds
    [REPLAY_VERSION_NUMBER]
    4

    version number for Online
    [ONLINE_VERSION_NUMBER]
    1.46

    If I remember correctly the diamond casion update is/was the last one I have done back in 2019. But I don't recall or know if I had a little update shortly after that ...



  • Oh and also checking the file creation /modification dates on my install seems I did the install on May 22, 2019.
    For almost all files (except mods) this is either the creation or modification date. So I must have files from before July 2019 (by roughly 2 months)



  • @Sabrina2001 Thats the Arena War build, which was released in December 2018.

    @Sabrina2001 said in Need help: Getting old GTA 5 Install working again.:

    If I remember correctly the diamond casion update is/was the last one I have done back in 2019. But I don't recall or know if I had a little update shortly after that ...

    Yeah, the DC&R update was launched on the previous launcher, but then cockstar decided to bring out the cockstar games launcher right after.



  • If you don't have the 1604.1 gta5.exe and gtavlauncher, then I guess you'll have to bite the bullet and start over again on the latest version of the game.



  • @WGotch07 said in Need help: Getting old GTA 5 Install working again.:

    @Sabrina2001 Thats the Arena War build, which was released in December 2018.

    Ah perfect! At least I'm on a way old GTA Version. Because one thing I know for sure, I installed this back then (apparently on May 22 in 2019) and first thing I did was put the launcherbypass.asi in there, to avoid updates for every and just stay on my version forever.

    Again,personally I would have no problem with that rockstar malware running in the back, but from research I've done the past hours, this f**kery has some sort of hash-check so it won't allow an old game to even start (which is probably why it won't start.

    Strange thing is, why it won't pass/go thru activation! If I go back to an old rockstar social club, I either get it to start into the "You need to download rockstar launcher" message or "You're offline, activation cannot be loaded"
    Even that didn't do the trick >> https://www.lcpdfr.com/forums/topic/97437-how-you-can-avoid-the-gta-update-retail-users-only/

    I guess I'm doing something wrong :(



  • @WGotch07

    @WGotch07 said in Need help: Getting old GTA 5 Install working again.:

    If you don't have the 1604.1 gta5.exe and gtavlauncher, then I guess you'll have to bite the bullet and start over again on the latest version of the game.

    alt text

    According to the properties tab, I do have these versions for my files.
    So I guess I must be doing something wrong here ...
    As said, I NEVER updated my GTA Install past this version every since I installed it on May 22, 2019. I only updated/downgraded Rockstar Social Club and Rockstar Launcher a few times.

    Maybe my tries are more fruitful if I find what's causing my install to nag about the activation. Once I get past that the "-scOfflineOnly" commandline should yield results..
    Wasn't there some sort of offline activation for GTA 5 ? Like with a manual code or something?



  • @Sabrina2001 Yeah, your doing it right with -scOfflineOnly should work along with the GTAVLauncher Bypass. Weird.
    I believe there wasn't an offline activation for GTAV, there was for GTAIV though.



  • Have you tried without the commandline and just used the launcher bypass?



  • @WGotch07 said in Need help: Getting old GTA 5 Install working again.:

    @Sabrina2001 Yeah, your doing it right with -scOfflineOnly should work along with the GTAVLauncher Bypass. Weird.
    I believe there wasn't an offline activation for GTAV, there was for GTAIV though.

    Thanks for that! :thumbsup: Knowing that I atleast do it (or something) right here, gives me a little hope...

    @WGotch07 said in Need help: Getting old GTA 5 Install working again.:

    Have you tried without the commandline and just used the launcher bypass?

    Yes. If I start it without the commandline.txt (just clicking gta5.exe) starts the game and then instead of the loading screen I get "You need to download Rockstar Launcher to continue" [Not the exact wording, but could make a screenshot]

    Starting it with the commandline.txt (the -scOfflineOnly) starts the game as well, but during the loading screen I get a "Activation requires internet connection, cannot load offline profile" [Also not the exact wording, but could make a screenshot]

    What I also tried was, to bend over and install the Rockstar Launcher Malware, but then double clicking on gta5.exe (with or without commandline.txt) just gives a short flicker and the game closes.

    I also tried downgrading Rockstargames Social Club Install (separate from the GTA 5 install, which always stayed at this version above), but older versions before v1.2.1.9 give a "Your Rockstar Social Club is outdated, you need to update" message on GTA 5 startup and all versions starting v1.2.1.9 give the "Install Rockstar Launcher to Continue" message.

    I also tried this method >> https://www.lcpdfr.com/forums/topic/97437-how-you-can-avoid-the-gta-update-retail-users-only/
    Barely letting the Update start, but it seems either Rockstar is no longer handshaking activation that way or they are actively blocking my activation due to not being on the newest GTA 5 Version

    And this launcher mod >> https://www.gta5-mods.com/tools/no-gtavlauncher
    does essentially the same as the launcherbypass.asi in that it either starts into "Download Launcher" or "Activation Offline" message ...

    What I was wondering, if I move out my GTA install into a backup location and install the most current version. After installing that current version, I could just put EVERYTHING (including the unmodded files from my old install) into the mod folder, that could work maybe? I know one is never supposed to simply use an old update.rpf with an updated game, but if ALL files are old in the mod, they should work together?
    Just grasping at straws here, because redoing all mods again (and everytime rockstar shits out a new update) is not worth it ...

    And again, thanks for helping meand trying for a solution! I truly appreciate it!!



  • @Sabrina2001 Using an old update.rpf with a updated game will not work I'm afraid.

    @Sabrina2001 said in Need help: Getting old GTA 5 Install working again.:

    Yes. If I start it without the commandline.txt (just clicking gta5.exe) starts the game and then instead of the loading screen I get "You need to download Rockstar Launcher to continue" [Not the exact wording, but could make a screenshot]

    I do not know why this is happening, considering that 1604.1 is before the cockstar launcher bs. Only thing I can think of is delete social club manually and re install it - Find Social-Club-v1.2.4.1-Setup.exe from somewhere, and install that.



  • @WGotch07 said in Need help: Getting old GTA 5 Install working again.:

    @Sabrina2001 Using an old update.rpf with a updated game will not work I'm afraid.

    I assumed as much. My idea would have been to not just use the old update.rpf in the mods folder, but everything from my current GTA (including unmodded files)
    Like an install within an install :stuck_out_tongue_closed_eyes:

    @WGotch07 said in Need help: Getting old GTA 5 Install working again.:

    I do not know why this is happening, considering that 1604.1 is before the cockstar launcher bs. Only thing I can think of is delete social club manually and re install it - Find Social-Club-v1.2.4.1-Setup.exe from somewhere, and install that.

    I will try that specific version now! I think I have almost all Rockstar Social Club Installers, including that one. But up until this point the highest version I tried was 1.2.3.1

    Honestly (I know this forum doesn't like it) I was even searching google for one of these crack-patches. But my luck, that appearently my game version was never cracked (only before and after)



  • @Sabrina2001 Probably because the 1604.1 update was a minor update, and it wasn't important I guess.



  • @WGotch07
    Well, I will try with the rockstar social club 1.2.4.1 soon.
    At the moment I'm duplicating my GTA install, because I'm gonna see about another approach. When I start my game offline it nags about activation. So once my install is duplicated (better to have another backup for this) I once again go thru with the launcher malware. But this time I do let is update my install and this should also double check the activation and/or drops it in whatever social club folder. I then try starting my old/current install again from the secondary location. So basically rockstar launcher and a up-to-date install are acting as an activation slave and playing is done on the backed up secondary install. But if all this fails, I'm done with GTA 5. As much as I love the game (and I truly do) it's just not worth it going thru all the deep modding, addons etc. every few months when rockstar games shits out another money grabber update for their online service. Or maybe a future rockstar launcher disables the version check. From what my research showed, this is the main issue why old GTA won't start anymore when rockstar launcher is active and used (even with bypass) It just kills the game right at start up.

    Might also be worth trying to simply replace the gta5.exe with a new one?

    Or (another maybe) I will see if there are any chances on modding via steam... Because stupid me paid for the steam version as well once.
    To be honest (for every one reading this, now and future) this grinds my gears the most. Back in 2013 I paid for it on the PS3, then again on the PS4 and I bought the Steam version and the warehouse/DVD version. And what do I get for being an honest customer? Fuckery and a headache!
    Should have gotten a patched version way back some years and never bother being a supporting customer :cry:
    But hey, maybe someone reads this and gets some details, that help them if they have an issue or in a few months or whatever the situation about shitstar launcher changed.
    And if anyone needs old Rockstar Social Club installers, I now have almost all of them ...



  • @Sabrina2001 Yeah, I understand.

    @Sabrina2001 said in Need help: Getting old GTA 5 Install working again.:

    Might also be worth trying to simply replace the gta5.exe with a new one?

    You can, but I doubt it will work though.

    Modding with the Steam version is much better, for one, you continue running old version's of the game. But Steam version also requires the cockstar launcher in order to play it, even though Steam is a launcher itself...



  • @WGotch07
    I think I read some where the past hours (with all the reading I did) that on steam it's also possible to block updates and even install old versions. So in theory I would need to get/install 1.1640 from there and then I could copy over my mods folder.

    One way of another, I just have to achive one thing: Get a working GTA 5 install, that I can mod and won't have to redo every few months because it gets updated.
    So I guess I would be open to updating once or switch over to steam and redoing all my mods if I had some sort of assurance I won't have to do it all over in a few weeks/months.
    Obvoiously one can never be 100% sure, for a long time the "launcherbypass" was a sure thing, and that was good enough as it is!

    @WGotch07 said in Need help: Getting old GTA 5 Install working again.:

    You can, but I doubt it will work though.

    As they say "desperate times need desperate measures" Try and fail (or succeed). Maybe I try the "Full install into the mod folder" Idea too. For now it's still far more easier than start from scratch, because it's basically copy+paste in win-explorer.



  • One thing I wonder, if anyone else reading this might wanna pitch in.
    Does anybody have an old version (or maybe even 1.640.1) still running.
    The fact that I get either directly bumped to the "Install rockstar launcher" or "Activation not possible offline" does make me think that the issue (especially activation) is not a problem on my end, but rather rockstars. That they no longer accept/verify connections coming from Social Club and only do it thru their launcher.
    That would essentially make my copy "not-activated" because it can no longer activate thru Social Club.
    Similar to how other old game that need to connect to an activation server fail, if the server was closed. And it might be (it's 2021 now and the malware launcher came in 2019) that GTA installs are no longer validated if the activation check comes from Social Club or GTA 5 itself and not Rockstar Launcher. In that case we would see some uproar sooner or later, as all old (non-launcher versions) stop one after the other ...

    Another indicator for this is, when I (just for checking) followed these instructions >> https://www.lcpdfr.com/forums/topic/97437-how-you-can-avoid-the-gta-update-retail-users-only/
    It didn't seem to trigger the mentioned "handshake"
    Even letting the update run thru, just downloaded ~80mb and ended in "Need to download rockstar launcher", so it seems even if I wanted to update my current GTA Install, I can only do that with Rockstar Launcher now and not Social Club ...



  • @Sabrina2001 It's done through their launcher now



  • I assumed as much :sob:
    So I guess that means I can no longer activate my old GTA install without their shitty launcher. (or go the way of patching ...)
    Well, it's getting late here (10pm US Pacific Time), so I stop my efforts for today.
    Maybe tomorrow I get it activated and ready for offline mode or something else. Definitely gonna be lots of "trial and error" and copy+paste

    @WGotch07 but thanks so much for trying to help!! Really appreciate it!!




Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.