Log in to reply

My Add-Ons doesn't show up in any Trainer, even though i'm doing everything right. [SP]

  • Hi, so basically i got tired of modded GTA:SA with 999999 crashes every 1 second, so i planned to get some mods on GTA 5 (ONLY SP). Basically i planned to Add 3 Cars, and 2 sounds for them. But when i added only 1 car (just to test if works) it doesn't show up in trainer car search (I used Spawn Modded Cars and Menyoo).
    Basically i did ABSOLUTELY EVERYTHING right. I even watched a video with same mod and MADE EVERY SINGLE STEP.
    Yes, the car is in "dlclist.xml". Yes, i'm on Steam, Yes, i do have EVERY SINGLE REQUIERMENT I NEED (scriphook V, scripthook v.not etc.). And yes, i do have Mods folder (i even tried to do with vanilla updates folder, yet nothing aswell).
    Here's my "dlclist.xml" just in case.

    <?xml version="1.0" encoding="UTF-8"?>

  • @LIkeyIy

    @LIkeyIy said in My Add-Ons doesn't show up in any Trainer, even though i'm doing everything right. [SP]:


    That's not right, needs to be <Item>dlcpacks:/fd2/</Item>

  • @WGotch07 Ok, but what about "a80"? That's Toyota Supra, but it doesn't work aswell

    UPD: oh forgot to mention, i fixed that already, yet same problem.

  • @LIkeyIy Got a modded gameconfig? And by the way, which Supra mod is it?

  • @WGotch07 Modded gameconfig, and AlexHIT Supra

  • @WGotch07 Also i noticed that i can't play Online for some reason. I just tried to check maybe if i load at least once for online, perhaps something changes. But no, it just says "Sign in for Social Club to play Online" but yet i signed in. Perhaps for some reason my game is broke? Even tho i already reinstalled it yesterday

  • @LIkeyIy Honestly, I don't know why you having issues with Social Club on your end. I use the Steam version too, never had that one before.

    As for the car, it works on my end. Have you tried using a different trainer? Since Menyoo is somewhat out of date.

  • @WGotch07 Yeah i said i'm using AddonSpawner aswell, and tried with Simple Native Trainer. Yet nothing there aswell (Says either model doesn't exist or smh like that)

  • @LIkeyIy Weird, with Simple Trainer, it should show up in the Added Vehicles Menu in Vehicle Spawning.

    Your sure the mod is in the correct place? (mods > update> x64> dlcpacks)

  • @WGotch07 Yeah it's 9999999% there, i even used normal update folder (since i won't play Online). I can even stream to you my dlclist and dlcpacks, absolutely everything is right

  • @LIkeyIy Okay. I get it. But it still doesn't add up...

    What other mods do you have?

  • @WGotch07 Uhhh... Except for the trainers... Nothing? I only have that one Supra and Honda Civic FD2. Nothing else

  • @LIkeyIy Use either Add-On Spawner or Simple Trainer, I don't know if it would cause side effects if your using both at once.

    I just installed both of those cars and they both appear in Simple Trainer.

    What gameconfig you using?

  • @WGotch07 Well it's called "Gameconfig (1.0.2245) for Limitless Vehicles V25.1". With stock settings.

    Also, isn't it that gameconfig matters only if you have like a lot of mods and you have crashes? I don't seem i have any crashes, just mods doesn't appear at all.

  • @LIkeyIy Yeah. But I'm trying to rule out things that might be causing this problem of yours.

    Did you replace the vanilla dlclist.xml with the modified one? I know sometimes people can forget to do that.

  • @WGotch07 I replaced like both dlclists, that one in mods, and that one in vanilla "updates"

  • @LIkeyIy Ah. Your supposed to replace the one in the mods folder.

    And keep the modified game files in the mods folder, not in the game directory.

  • @WGotch07 Wait, so basically "dlclist.xml" should be completely clear in vanilla folder right? Or no difference? Since i will be using SP only, basically i don't care about ban in Online at all.

    So basically i need to delete my car.rpf's in vanilla, and then delete everything about them in "dlclist.xml" right? And keep them only in Mods?

  • @WGotch07 Ok done, still nothing...

    Bro it starts to annoy af... I even installed NVE's auto installing Lykan Hypersports, even it doesn't work. Something with the game, EVEN IF AUTO INSTALLING MOD DOESN'T SHOW!

  • @LIkeyIy Jesus, I really can't fathom this out.

    If I was you right now, I would verify the game files. Then start over with the mods folder:

    • Create the sub folders within the mods folder (update > x64> dlcpacks)

    • Add update.rpf to the update folder in mods.

    • Add the car mods to dlcpacks

    • Extract the dlclist.xml from update.rpf > common > data

    • Edit the dlclist, add the lines <Item>dlcpacks:/fd2/</Item> and <Item>dlcpacks:/a80/</Item> below <Item>dlcpacks:/patchday24ng/</Item>

    • Replace the dlclist in update.rpf

    • Replace vanilla gameconfig with a modded one

  • @WGotch07 Well i guess i will try to reinstall the game... again. But this time in Epic Games (just in case).

    But before that i will try that

  • @WGotch07 Alright i reinstalled the GTA 5 to Steam, but when i opened "dlclist.xml" there was old "dlclist.xml", that one from previous GTA 5. Basically i see this smth like that:
    When i first time tried to add Add-On, i messed up with dlclist somehow, and now it's saved from now on or idk. Basically for some reason either OpenIV shows old xml's, or GTA 5 for some reason keeps them even after the reinstall.
    Tomorrow i will try to download Epic Games one, perhaps i will do clear start there...

  • Hi. Did you update your mods/update/update.rpf. Don't know if that will help.
    I don't use addon cars but I'm assuming you can spawn them with code?
    I've spawned addon props i've created myself so hoping that would work with cars as well.

    Vehicle Veh = World.CreateVehicle("Veh", Game.Player.Character.GetOffsetInWorldCoords(new Vector3(0, 2, 0)));

    I write in VB.NET I think that's the correct syntax for C#.

  • @WGotch07 Contrary to most OS paths, I don't think it matters if you use a backslash or forward slash. RS packs are always with a forward slash but mods often use the backslash, but I could be wrong.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.