Log in to reply

How can I disable automatic dimming of the screen when bright lights are visible?

  • On all versions of GTA 5 (mostly next gen) be it PS4, Xbox, PC, the default behaviour with the stock game is to dim the entire screen when there is a bright light.

    For example, if you're in normal third person view on a completely stock unmodded game driving a car, spam H to turn headlights on/off. you will notice the screen gets dimmer.

    I really dislike this cause it makes everything much much harder to see and makes me enjoy the game less.

    I tried turning up the brightness of the game a lot, but it doesn't remove this behaviour and that makes nights really non immersive, and all lighting looks flat.

    This has been a thing for years. I tried googling and searching forums with many many different wordings of this problem, but I haven't found anyone who's managed to disable this yet.

    How can I turn off or alleviate this behaviour?

    Thanks in advance. All help is much appreciated.

  • @sjain


    Try this:

    # Adaptation
    Adaptation.min.step.size 	0.00001
    Adaptation.max.step.size 	0.0001
    Adaptation.step.size.mult 	0.0001
    Adaptation.threshold 		100.0
    Adaptation.sun.exposure.tweak	-2

  • Thank you for your fast reply. I did that and the effect is minimised by 99.999% so it is simply not noticeable at night unless you stare into your monitor looking for it.

    However, it has a side effect in that if I spawn in an interior then walk outside during the day, it looks like this: https://imgur.com/a/fkXqfX6

    I'm not sure if this happens if you first spawn outside.

    I'm guessing this is not fixable?

    I tried setting sun.exposure.tweak to -3, but no avail.

    EDIT: Weird, it seems tabbing out of the game and back in fixes it. When I set the time to night however, its too dark. But again, tabbing in and out fixes it. Can't remember if i paused before tabbing out but try that.

    EDIT 2: Ok, seems alt tabing only fixes for the current area. When you start driving around or going up hills it slowly gets way too bright again https://imgur.com/a/VWwAXRO

    I can live with that, but would you know a way to avoid having to do that by any chance?

    Also side note, I'm currently using this with my custom improved spotlight and led setup: https://www.gta5-mods.com/misc/improved-spotlight-and-led-lighting#comments_tab


  • @sjain said in How can I disable automatic dimming of the screen when bright lights are visible?:

    I can live with that, but would you know a way to avoid having to do that by any chance?

    Nah, it doesn't do that in my game.
    I'm using these values, maybe try that (darkening effect may be slightly more apparent):

    # Adaptation
    Adaptation.min.step.size 	0.001
    Adaptation.max.step.size 	0.01
    Adaptation.step.size.mult 	0.01
    Adaptation.threshold 		10.0
    Adaptation.sun.exposure.tweak	-2

    You can also lower these values to reduce the darkening effect also. Maybe find a compromise etc:




    isn't adaptation also controlled over ENB?

  • Thanks for the reply. Thats really odd because im on a 100% stock game. Just deleted my mods folder and tried repasting your values with stock visualsettings, but the issue persists. What game version are you on? If its not too much trouble please could you send your entire visualsettings file? I run my game 100% stock and this is the only fix i ever want.

  • I made some changes. Having gotten tired of only being able to use mods like VisualV, NVR when they are uptodate (otherwise bugs, etc), I wanted to customise my game via a more update friendly "portable" way, i.e. ENB for car damage, fixes, lens removal and better MSAA combined with ReShade for simple colour adjustments (thats all i really want tbh, and I understand ReShade better and find it friendlier than ENB)

    ENB made a huge fix to the overbright cars (im dumb, i just realise now its cause i managed to disable ingame bloom with it). I have literally everything disabled in ENB (except car damage, MSAA fixes, game fixes & chromatic abberation removal enabled) and ReShade fully disabled right now, but it still fixes it (and only it i.e. it doesnt mess up anything else). Also seems to fix sky being blindingly bright.
    before/after: https://imgur.com/a/P6XBU3f | https://imgur.com/a/clsNmK7 | https://imgur.com/a/1Wr90iu

    Whole game looks way sharper now. Shimmering jaggies literally magically removed themselves for a 5-10fps hit (i was already at 90+ already in all times and weathers), distant stuff isn't blurry, and the lens effects being removed means i can see stuff clearly finally.

    The only issue is, the adaptation getting stuck (too bright day / too dark night) still happens, even with adaptation enabled in ENB: https://imgur.com/a/8ngzrr4

    Any specific settigns i need to tweak in ENB for that? Also, i made another discovery, going into firstperson then out fixes it. So its 100% some weird game bug. Really odd that I experience this on fully stock and a63nt-5m1th doesnt.

    So the last issue is just that adaption getting stuck, then i need to extend those lod distances where stuff pops in right infront of my car, then im happy

    Oh and, even tho i have all effects disabled in enb it still messes with
    trees, any idea what to do about that? am i missing a setting https://imgur.com/a/A7rAmRV

    as a general noob question, how can i tweak the enb effects? changing stuff in the inis and menus has no effect, yet still, it fixes the bloom issue by itself and changes vegetation. disabling/enabling aa or bloom settings doesnt do anything, where do i find the actual settings to control

    also this issue - with enb installed alone, whether or not global effect is on/off, the grass shimmers. its only grass and small vegetation but it flickers a lot. AO is off. any ideas? you need to look closely. https://streamable.com/eu6jv8 might be a dll issue

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.