Log in to reply
 

A white interior for the Barracks instead of the normal interior texture.



  • So as i was spawning in the Barracks i noticed that its interior was white and the seats in the back were the underneath of the Barracks texture, i have honestly no clue what happened as i dont mess around with textures. Any ideas on how to fix this?



  • Upon further inspection, the Biff does the same thing.



  • @Ethical
    Will probably take a little investigation to find the exact issue, but here's a place to start :thumbsup:

    Use Ctrl+F3 in OpenIV to search for 'vehshare_truck.ytd' & check the appearance of the 'vehicle_generic_truck_interior' & 'generic_truck_dial_detail' textures.

    'vehshare_truck.ytd' has at least two locations in the game files & both files are identical.
    Any issues with one of them, just use the other (if working) to replace it.

    A Few Additional Questions:

    • Are your Barracks & Biff vanilla?
    • How do the textures appear if you open the 'barracks.yft' &/or 'biff.yft' with OpenIV's Model Viewer (double-click file)?
    • Does the TipTruck &/or 'tiptruck.yft' have the same issue?


  • @a63nt-5m1th All of the effected vehicles and their textures look fine in the model viewer and they are vanilla.



  • @Ethical
    Make sure all your 'mods' folder 'vehshare_truck.ytd' files are identical.
    The easiest way to do this is to pick one & use it to overwrite all others.

    Does the TipTruck (&/or other trucks like 'utillitruck' etc) have the same issue?



  • @a63nt-5m1th Yeah they did have the same problem, i got the problem all fixed as it was a pack that did some weird thing to the textures and when the pack was removed the problem went away, thank you for your assistance.



  • @Ethical
    Nice one :slight_smile: :thumbsup:

    General vehshare Info:
    Conflicting vehshare textures are probably the most common cause of vehicle textures being missing/using the wrong texture/flickering etc.
    Usually solved by making sure all the vehshare files the game loads are identical. :thumbsup:

    If you have two or more vehshare files containing different textures, but you want/need to use both, you just import the extra textures you want from one into the other & then use that to replace all others of the same name.
    Two different textures with the same name cannot be used together in the same vehshare file obvs.
    You would need to either choose between them, or if that's not possible, use CodeWalker's 'Export to XML...' to edit the vehicle's '.yft'/'_hi.yft' & change the name of the texture used there & then rename duplicate textures accordingly.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.