Log in to reply
 

%80 of the cars in the traffic is only Black (BUG)



  • Hi guys i have a problem in GTA V, Vehicles in the traffic %80 of them black and rest of them only gray,white and red color.. i dont know how is this happened im not using any mods, Long time ago i used vehicle mods but i dont think this revelant becaouse i unistalled and deleted my entire game files (save game included) but still didnt work, I reported R* supoort but they dont care abouth singleplayer issues. I dont know how to fix this problem, i searched everywhere for this problem but seems like this is extremely rare bug and didnt find no one solved it.. Its really weird for me, Any suggestion ? also sorry for my bad english i hope i made my point.

    i7-4790 3.60ghz

    16GB ram

    2 TB HDD

    Nvidia 1660 Ti 6GB

    there is like no variety in car colors in traffic
    exepctions are those rusty/utility/public service vehicles

    civilian personal cars are pretty much like this

    80% black cars
    10% white
    10% red

    and sometimes very rarely a unique color



  • I'm having the exact same problem, I have tried uninstalling and reinstalling, making brand new accounts and buying gta all over again, its really frustrating, did you find anything that fixes it?



  • @makavelinow Definitely sounds like a graphics card issue. Update your drivers would be the first step. Do you have problems with any other games?



  • @JohnFromGWN My graphic card always updated, even i checked now before texting this, I dont have problems like this in any other game.



  • @makavelinow Strange. Try resetting all the graphics and advanced graphics to default? Sorry can't help much more than that.

    P.S. Do you have any ENB or visual/graphic modification addons installed? If so, that's likely the cause.



  • alt text

    Issue still continue after Gta Online Tunning update, I send Ticket abouth this issue to Rockstargames Support but i feel like they ignore Singleplayer problems.. I dont like using mods but with this issue i want help from modders.. How can i solve this ? Not only color but sometimes same variety vehicles spawning at same place.. I clean installed even reinstalled my windows 10, that didnt worked at all.. My game files are pure.. I still dont know what went wrong.. Is there are any people having same issue like this ? I saw some people have same problem.



  • @WGotch07 Yes, i did more than that, as i said i reinstalled Windows 10 lol.



  • @WGotch07 I did that too, I disabled "cloud saves" so i can make fresh start.. none of them did work.. As i said i never used mods before, Its all clean install.



  • Here is some another pictures from diffrent locations.

    alt text

    alt text



  • @makavelinow just curious. If you select a black textured car can you change its colour with your trainer?



  • @JohnFromGWN As i said i dont use any mods at all. I can change color of vehicle i stole in los santos customs.



  • @makavelinow Apparently there is a black car bug. I realize you dont use mods but in the description of this mod they mention this bug.

    https://bg.gta5-mods.com/misc/sparky-s-traffic-overhaul



  • This post is deleted!


  • @makavelinow found this link with same issue
    https://gtaforums.com/topic/790002-why-are-there-so-many-black-cars-in-gta-v/

    In this case, going back to 2015, it was defective media. U might want to try another clean install rather than just reinstalling which means manual deletion of game as well as save games in the documents folder. I know you tried this already and it must be frustrating AF, but it is the only case i could find with same issue and a fix, at least for that user.

    Only other thing i can think of is reinstall directx or rolling back your video drivers. What else can you do? Sometimes it seems like the GTA gods are messing with us. I had a bug where there was black debris floating all over, maybe affecting less than 1% of users. Had to delete the texture files to fix it. Go figure.



  • @JohnFromGWN Thanks for trying to help but i searched almost everywhere on internet even link you send, I didnt find any fixes, As i said, i didnt only reinstall the game, I install my whole Windows 10 from zero, That didnt worked at all, I think this is abouth game engine issue that rockstargames refuse to fix. I know not everyone having this exact issue but there is really something wrong that this issue rarely happening for some people. We all know rockstargames dont give a f abouth Singleplayer bugs, they wont even bother adding new vehicles to singleplayer mods. I send tickets to their support team year ago and here is a link of conversation https://support.rockstargames.com/requests/18655468 Its like they avoiding to fix this problem. even one of them said "its a game design not a bug" LOL.. I was playing this game since day 1, its like they mocking with me..



  • @makavelinow There is something you could try but it's kinda crazy. You would need to temporarily mod your game so you could use OpenIV and it would mean changing game files - which would be overwritten at next update and repeating process.

    This would involve modifying some or all of the common carvariations.meta files. Because there are hundreds of models, you would need to edit several files, each containing multiple models - contrary to addons which have their own carvariation files.

    The next step would require caution. You would extract the file to a text editor and then do a search and replace on the black color. Changing as many as you want, skipping others so that you still have some black cars . Each car in carvariations has about 4 primary colors I think.

    Just a thought.



  • @JohnFromGWN Im gonna try mod you send "Sparky's Traffic Overhaul" if that fixes my problem, i wont use original game files anymore lol. But as you said next update may delete this mod but maybe until then i can truly enjoy this game if mod helps to fix my problem.



  • This post is deleted!


  • @JohnFromGWN HEY! I installed mod you shared "Sparkys Traffic overhaul" and this totally fixed color variety issue and also added online vehicles in singleplayer traffic too.. I dont know how much i should thank you.. Normally im not into using mods and messing with my games files but this mod not only fixed my problems but also made this game more interesting by adding online vehicles.. Its shame that next update will ruin this for me by deleting mod :/ Until then im gonna try to enjoy this modded traffic.. Thank you a lot !



  • @makavelinow great news, enjoy



  • @WGotch07 thankfully very few reports of this, however it has existed long before the last updates so there are likely other causes.

    https://gtaforums.com/topic/903665-black-cars/



  • Here is a links of same issues shared in another websites, There are really a lot of people having same problem and i think most of them reported R* support instead of sharing with community but as i said R* support really dont care abouth singleplayer problems, If i had problem with shark cards im pretty sure they would respond in seconds lol. I keep sending them Tickets even made video abouth issue to prove them becaouse some support team think screenshots is not proof, Its become tiring that R* try to avoid to fix my problem so i gave up and open post here, Thankfull you guys helped me with mod fix and also added online vehicles to singleplayer game, Made my experience way better..

    https://steamcommunity.com/app/271590/discussions/0/613958868352088557/

    https://steamcommunity.com/app/271590/discussions/0/142261352665297050/

    https://www.reddit.com/r/GrandTheftAutoV_PC/comments/8rml4o/fix_for_black_traffic_issue/

    https://gtaforums.com/topic/790002-why-are-there-so-many-black-cars-in-gta-v/

    https://steamcommunity.com/app/271590/discussions/0/615085406664663737/

    https://steamcommunity.com/app/271590/discussions/0/1638668751258056434/

    https://steamcommunity.com/app/271590/discussions/0/517141807566548331/

    https://steamcommunity.com/app/271590/discussions/0/611704531881486789/

    https://steamcommunity.com/app/271590/discussions/0/2148721524005238388/



  • @makavelinow i rarely look at the steam forums because the community is toxic and posters are either clueless or trolls or both, but yeah more frequent than i imagined. As for R* isnt customer service in general dead?



  • @JohnFromGWN No but their respond to Singleplayer issues is like takes 2 days, for online content extremely fast like literally in 10 min lol.



  • @makavelinow did you encounter any error when you tried installing the mod cause mine says game files corrupted when i try to run the game with sparky's traffic mod


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.