Log in to reply

How to spawn unreleased DLC cars in SP without SH ?

  • Hi,

    each updates I see tons of youtubers showing the new DLCs cars, how they do that without scritphook ?
    There was a mod working with dinput8.dll that allowed to spawn new car by their name with the cheat menu but it doesn't work since long time.

    Any idea ?

  • @Sukhoi Some forum members wrote that they have done this.

    I imagine the process will go something like this, but haven't tried it.

    1. Copy GTA5.exe (2245) from a backup to overwrite the updated one (2372). This will allow you to run the update with all your mods and trainers. This is the easy part and it does work.

    2. Now you need to copy 1 of the 2 dlcs, mptuner to your mods folder, in the dlcpacks folder.

    3. Next edit your dlclist.xml in your update.rpf, again in your mods folder.

    4. Then apparently you can spawn new cars using Simple Trainer or the addon spawner mod.

    I've only done Step 1 because I have no interest in vanilla cars. If the steps are wrong or incomplete or only for either Steam or Epic, but not both, I hope someone will correct this.

  • Almost correct, you can skip step 2 entirely, you don't need the folders in your mods folder for them to work. As long as the mods dlclist has been updated they will work

  • Thanks for your answers guys, I image there is no way to get an old gta5.exe legitly?

  • @ItsJustCurtis Thanks for information.
    Just curious, does the updated entry to dlclist.xml use the game folder path or just the mods folder path which is the default path?
    In other words, the entry is simply:


    Is that right?

  • @ItsJustCurtis Ok I tried this for fun and it doesn't work for me. I tried with Menyoo and got invalid model. Tried with C# even though it was not in intellisense and nothing happened, no spawn.

    So I downloaded the addon vehicle spawner, went into the Los Santos Tuner DLC menu and it returned an error saying I was using the wrong version of GTA5 - which obviously I am given I used the previous version of GTA5.exe so that ScriptHook would still be working.

    How did you get this to work? Obviously you did something else. I'm on Steam.

    Did you copy update.rpf from the games folder (the updated version) to your mods folder? If you did then obviously it overwrote your editable files including dlclist.xml and gameconfig.xml. That's the only step I didn't do.

  • I did nothing more than add the mptuner and patchday25ng lines to the dlclist in my mods folder.

  • @ItsJustCurtis Your game won't start modded with the current SH. So what else did you do? Copied over GTA5.exe for sure, but any other files? Did you leave your mods version of update.rpf as is or did you update it because OIV told you to and then you made your edits to dlclist.xml?

    Also, what did you use to spawn. I tried "euros".

    1. I tried Menyoo - invalid model error (either from Vehicle spawner or object spooner)
    2. I tried C# which is the only way I normally spawn anything - no errors, no spawn
    3. I installed (and then uninstalled) the addon vehicle spawner. It correctly told me I had an outdated version of GTA5.exe - which is expected, if not I could not have launched the game in its modded form without the previous version of GTA5.exe, not with the current outdated SH.

    Sorry if I'm asking lots of questions because I tried exactly what you did and nothing spawned. And again, I'm just curious, will never use this DLC.

  • As I say, thats all I did and it worked. Now that the new scripthook is out I had a bit of work to get my old mods working properly, but if you don't have that much installed then copying the new update.rpf accross will work fine.

  • @ItsJustCurtis Thanks. Just goes to show every setup is different, Steam vs Epic, installation paths etc. Never worked for me and the new update is unstable for my setup, even with new version of gameconfig, so I reverted back - don't need this DLC.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.