Log in to reply

GTA V Crashing Whenever I Use Add-On Cars

  • Basically in the title. Regardless of what gameconfig I use, the game keeps somehow becoming corrupted every time I add an Add-On vehicle.

    I make Add-On vehicles the last thing I install just by order of complexity, and everything works fine before I try to install them. As soon as I add the archive to dlcpacks and dlclist, the game throws a corrupt data error. (Again, this is with ANY car mod I use, not just any specifically)

    The only way I've gotten car mods to work is by installing them early on and adding my other mods after, but the same error happens if I try to change anything after that. I'll leave a list of my mods below. This includes all necessary files like Scripthook, SHVDN, gameconfigs, etc.

    Addon Vehicle Spawner
    Real Gun Sounds
    Skin Control
    NVR (with some optionals; tried with and without any that effect vehicles)
    California Architecture
    LA Billboards + LA Roads
    GTA V Remastered
    Open Interiors
    Ped Status
    Realistic Top Speed and Acceleration (with the handling.meta for the LS Tuners update)

    Please let me know if anyone has any ideas.

  • @Wargamerstev63 There is only one foolproof way I've experienced troubleshooting GTA V and that is to temporarily remove most of your mods and install one at a time.

    The great thing about this systematic technique is that you don't need to touch dlclist.xml (except if one addon depends on another) and you don't need to uninstall - all you do is temporarily move or rename files so that they don't load.

    In your case, you're getting a corrupt data error, which I've gotten a few times, but never with a vehicle addon. Have you modified any vehicle files such as carcols, carvariations, vehicles.meta, handling, etc? A syntax or similar error could result in corrupt data.

    Getting back to the point, my advice to you is to first do a verify integrity followed by moving all your mods, except Menyoo and gameconfig/heap/pack, to a temp folder.
    Remove all other mods - those in scripts, those in dlcpacks, and those in your game installation folder (except OpenIV, SHV, and dinput8.dll. You can leave SHVDN as it will not cause issues even though it is not a requirement for Menyoo nor addon vehicles).

    Now install one vehicle addon and see if it loads. I would download a recent vehicle as they are unlikely to cause issues versus a car mod from say 2016.

    One last thing, when I did get corrupt data errors in the past, it was due to one of two things: corrupt saved game files - but I never got that error message, just that something was corrupt. The other one was when I damaged a texture in an rpf.

    Ooops...one more note: the more script/mission/visual mods you install, the more likely your system will crash due to outdated files or conflicts. This reinforces the practice of adding mods one at a time, testing for stability, and only then adding other mods. This doesn't apply to vehicles or peds, at least from my experience installing over 400 addons, because they have never crashed my game - well not during load that is. :)

  • @JohnFromGWN Firstly, thanks for the reply.

    The only vehicle files that have been touched are the handling.meta files. The Realistic Top Speed and Acceleration mod edits all of them, and the download currently has a manually installed handling.meta file for the Tuners update. The only thing is that this all works fine until I add an Add-On vehicle, verifying that there are no syntax errors with the handling files (because they wouldn't effect any Add-On cars anyways)

    I'm instead just going to reinstall the game and start from scratch (not a huge deal, I have fast internet). I will add in all the necessary things to get the add-on cars running and let you know if they work properly.

    And in regards to the gameconfig, I've tried Dilapidated's gameconfig as well as F7YO's latest config and the config included in NVE; none of them have had any effect after the issue appears. I will try your instructions with Dilapidated's because his is the most recent (updated for 1.0.2372.2, while F7YO's is 1.0.2372.0).

    I'll let you know how this goes, and if I still have the problem, I might try reverting back to an older save game to see if that changes anything.

  • @Wargamerstev63 Ok. I can tell you however, that reinstalling is unlikely to solve your problem. A verify integrity works just as well and is much quicker. From your reply, the issue would be with the modified vehicle cars - I would bet on that.

  • @Wargamerstev63 I've tried both gameconfigs recently and switched over to Dilapidated for the first time because the author impressed me, he was gracious enough to help others on these forums. Also, I added a packfile mod for the first time since I bought the game. For now my game is at its most stable despite having added more vehicles and peds. I do stay away completely from missions and scripts and enbs. Only forests and RCA and some interesting racing maps.

  • @JohnFromGWN Okay, I can confirm that the game works with SHV, SHVDN, Menyoo, Addon Car Spawner, Native UI, and an Add-On vehicle

    Edit: Can confirm the game works with Realistic Top Speed and Acceleration when installed AFTER the cars, but any cars after that and the game corrupts. Think we may have found the culprit.

  • @Wargamerstev63 good detective work, call in the punisher

  • @JohnFromGWN Thanks!
    Managed to fix the OIV installer as well. For some reason the creator must've forgotten to remove 2 folders that were installing together in 2 separate places. This is what was causing the corruptions when I installed any addon cars. Deleted the offending folders, edited the assembly.xml, and voila, the mod works as intended.

    Even took the liberty of updating the OIV to include the separate Tuners Update handling file!

  • @Wargamerstev63 its amazing how sloppy some modders are, yet a poorly designed mod might work on some systems and not others.

  • @JohnFromGWN You may laugh at me now lol the game corrupted again when I added another car after installing my mods. So it must be something else. I've been trying to figure this out for days lmao.

    Back to the drawing board.

  • @Wargamerstev63 sounds frustrating AF. What exactly is the error message you're getting?

  • @JohnFromGWN ERR_FIL_PACK_3

  • @Wargamerstev63 Ok, you have this installed?


    You didn't need it before with most gameconfigs, but it is recommended now.

  • @JohnFromGWN Yup I had that and Heap Adjuster. I've played around with stuff and found out it was actually VisualV. Was just updated like 2 weeks ago and people in the comments have been having issues.

    Went without that and any NVR stuff that touches cars and I've been good.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.