Log in to reply

Problem with installing scripthook

  • I have been away from the game for a very long time and have lost touch with it and its updates. As soon as I downloaded the game, I immediately started the install order (ScriptHook, ScriptHookV.net, NativeUI). I downloaded all the latest versions that fit the version of my game, but I kept getting the game crashing when loading into single player mode after 20 seconds. According to the logs, all the time stopping on the file ScriptHookVDotNet.asi. If I delete dinput8 or ScriptHookVDotNet.asi, the game works without crashes, but respectively no mods work. I tried all the ways I found, but it's still bad. It came down to the game configurations and everything else. I downloaded all the packages people suggested and even that did not help. I thought that the game was updated and is updating Scripthook, but moderator in the post September 6 wrote that version 1.0.2372.0 still works. Help solve the problem.

  • // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\Windows\system32\dinput8.dll" => 00007FFDB9B90000
    API: "DirectInput8Create" => 00007FFDB9B9A570
    API: "DllCanUnloadNow" => 00007FFDB9BABBA0
    API: "DllGetClassObject" => 00007FFDB9BABC70
    API: "DllRegisterServer" => 00007FFDB9BB60A0
    API: "DllUnregisterServer" => 00007FFDB9BB6430
    LOADER: Loading *.asi plugins
    ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\LUA.asi"
    "LUA.asi" => 00007FFDA0E50000
    ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\openCameraV.asi"
    "openCameraV.asi" => 00007FFDBBA50000
    ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FFDB9420000
    ASI: Loading "C:\Program Files\Rockstar Games\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" => 00007FFDBBF20000
    LOADER: Finished loading *.asi plugins

  • // GTA V SCRIPT HOOK (build Jul 23 2021, v1.0.2372.0)
    // (C) Alexander Blade 2015-2021
    [13:46:26] INIT: Started
    [13:46:26] INIT: Success, game version is VER_1_0_2372_0_NOSTEAM
    [13:46:26] INIT: Registering script 'LUA.asi' (0x00007FFDA0E7E6A0)
    [13:46:27] INIT: Registering script 'ScriptHookVDotNet.asi' (0x00007FFDBBF21480)
    [13:46:30] INIT: Pool 1 extended
    [13:46:30] INIT: Pool 2 extended
    [13:46:30] INIT: Pool 3 extended
    [13:46:30] INIT: Pool 4 extended
    [13:46:35] INIT: GtaThread collection size 189
    [13:46:35] INIT: wnd proc 0x00000000FFFF05F3
    [13:46:35] INIT: IDXGISwapChain 0x00007FFDD1B096B8 (0x00007FFDD1AFCDE0)
    [13:46:35] INIT: IDXGISwapChain set
    [13:46:35] INIT: DX init started
    [13:46:35] INIT: DX feature level A000
    [13:46:35] INIT: DX init succeeded
    [13:47:28] CORE: Requesting thread creation
    [13:47:28] CORE: Creating threads
    [13:47:30] CORE: Started control thread, id 37 active 1
    [13:47:30] CORE: Started thread 'LUA.asi' (0x00007FFDA0E7E6A0), id 38 active 1
    [13:47:30] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00007FFDBBF21480), id 39 active 1
    [13:47:30] CORE: Launching main() for 'LUA.asi' (0x00007FFDA0E7E6A0), id 38
    [13:47:30] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00007FFDBBF21480), id 39

  • @Richard-Moriz hi. Being on Steam, I'm not as familiar with your version, but I will provide you with some suggestions. First however just a comment on your topic subject.

    Scripthook and the community Scripthook don't create any problems whatsoever and the installation process is a bit of an exaggeration, you simply dump the files in the GTA5 root folder, or call it the installation folder, where GTA5.exe is located.

    My suggestions. You mention you have mods that don't work, you even have from your log what i guess is the Lua plugin. I get the impression that you installed quite a few components. What im going to suggest is you go step by step.

    1. Start with OpenIV. Install its recommendations for open camera and the asi loader although it gets installed in step 2 as well.
    2. Add Scripthook V, don't install native trainer, it's not needed.
    3. At this point let's keep things real simple, so let's not install any other tools or scripts, no lua, no nativeui, no Scripthook dotnets, no maps, no addons, nothing.
    4. Now add either Menyoo or Simple Trainer, not both.
    5. Start your game, does the trainer work?

  • @JohnFromGWN You are a magician. The game started and the trainer opened. Did everything like you said. I have one more question, I do not like to download a lot of mods, I am interested in one particular mod "Jumper". How should I proceed, what would this mod run without crashing?

  • @Richard-Moriz I'm glad it worked. For the jumper mod:

    1. You already have ScriptHook V.

    2. Now you need ScriptHookVDotNet.
      Link is at the very bottom of page. Extract the files and place them in same folder as GTA5.exe

    3. NativeUI. You will need to create a scripts folder as a subfolder of your installation (root) folder.
      Then place the files there. You wrote you had the file.

    You should be good to go. Holler if you have any problems or if/when you're ready for other mods.

    ScriptHookV --Put in the main game folder

    ScriptHookVDotNet --Put in the main game folder

    NativeUI --Put in the "scripts" folder

  • @JohnFromGWN
    It's bad. I put ScriptHookVDotNet, threw it in the main folder where gta is. I also threw NativeUI in the folder scripts, which I created in the main folder with gta. The problem with the crash while loading the single player is back. I tried running the game immediately with the "jumper" mod and it crashed and tried without the mod, it also crashed.

  • Problem solved! I guessed what the cause might be, but I solved it anyway. I installed the .NET Framework 4.8 and Visual Studio without additional packages (standard). After that, everything started to run. On the last computer everything started well because I had started coding before and I had to install all the packages for that and thus the mods opened well. On my new computer all the packages were missing and now everything works fine!

  • @Richard-Moriz thank you for posting your solution. We often overlook the fact that scripthook dot net requires the net framework, 4.8 or higher. This would explain why some users can't run their script mods.

    What i don't understand is why your game crashed when you removed the mod. I can understand if it kept the dotnets from loading, but not crashing.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.