Log in to reply
 

UPDATED.rpf - no backup - NOW nothing works. HELP



  • help OK SO I SHOULD HAVE KNOWN BETTER, I PRESSED THE OPENIV "YOU HAVE A NEWER VERSION OF UPDATE.PRF... ive been playing for years and like an idiot i pressed it. So now nothing will work. It crashes at loading page. Now what? I was using 2245 it was working PERFECTLY. I JUST USED IT LAST NIGHT. then BAM.
    what do I have to do to get it to play agaom?



  • @VLADIMPALER72
    You posted the same mistake before, right?
    https://forums.gta5-mods.com/topic/35060/addon-folder-now-causes-startup-crash-even-when-empty

    So now you have to redo your dlclist.xml with all the addons you have in dlcpacks. Then you should definitely update GTA5. There isn't any reason why you shouldn't update.

    If you want to stay with 2245, you need to install that version of Scripthook, and you will still need to update dlclist.xml. In your topic you clearly say no backup. Now you know why you need a backup.

    Regardless of the option you choose, you will need to reinstall gameconfig.xml, . This is likely why you crash at load time given you now have the game version rather than a modded version. Another reason to update everything. If not, find an old version of gameconfig.xml.



  • @JohnFromGWN My question is though........... ive stayed with the same version of scripthook which worked for a while literally since last night. I already updated my dlclist and used my gameconfig backup. [ i didnt backup entire update.rpf for 2245].
    Ive also tryed using the current version, updated dlclist and newer gameconfig from multiple people nothing works.

    The only thing I did differently is updated update.prf. Im trying to get 2245 to work again because its been the most stable for me.

    ps. i DO have my gameconfig ive been using and one which has been working until today.



  • @VLADIMPALER72

    When you hit the button, OpenIV copied the game version of update.rpf and replaced everything in yours.

    Let's see what's impacted.

    1. You're correct that Scripthook and GTA5.exe are not impacted. In fact, as you surmised yourself nothing other than Update.rpf was changed. Your heap and pack (if you have a pack) will be untouched too. In other words, almost nothing was changed.

    2. However, two important modding files were replaced. One is your dlclist.xml which you say is now updated. The second is your gameconfig.xml which you say you had a backup. All the other files in update.rpf should not cause any crash at load screen AFAIK.

    So I can't explain what is breaking your system because you seem to have restored the key components. What I can share with you is that after the tuners update my system broke. It took a few tries for me to get the right gameconfig and interestingly it didn't work with the heap recommended by the modder. I had to mix and match, I also had to install a packfile mod which I had never used.
    Check out this post if interested.
    https://forums.gta5-mods.com/topic/35789/gta5-911-help-and-checklist-what-to-do-when-mods-make-you-mad/7

    I'm going to suggest you do this. First, check your dlclist.xml for errors, syntax errors for example. From what you describe that's the only thing that really changed with editing on your part. Next, if necessary:

    1. Do a verify integrity just to make sure all game files are ok.
    2. Disable all mods by renaming dinput8.dll to dinput8.bak
    3. Start your game to see if it works without mods.
    4. If your game runs, rename dinput8 back to dinput8.dll and rename your mod folder temporarily.
    5. Start your game and if it crashes you have a script or trainer error.
    6. If your game runs, you will need to reinstall your mods one by one or in small batches to see if one or more are causing the problem (also rename your mods folder back to mods).


  • @JohnFromGWN SO i renamed dinput8 and even put away the mods folder, crashed. I have everything updated.
    I also tried to start with nothing added to the dlclist, crashes. I tired the combos and already had the latest pack limit adjuster and heapadjuster.

    I tried with the 2245 and the latest version of the game. im stumped.



  • @VLADIMPALER72 Are you using the Steam version or Epic/Rockstar version.

    If the game won't run without mods, that's not good news, but it greatly simplifies the troubleshooting.

    I'm a little stumped too.

    How about you try this. Backup all the .exes you have with 2245 and most of the smaller files, don't back up the x.rpf files, and only backup the root folder and make sure you have the Scripthook version required for 2245.

    Now do a verify integrity and let the game update to the latest version. Check and see if it runs properly - you're now launching an updated game, but with dinput8.dll renamed so you have no mods. If the game (latest version, no mods) runs you know that your PC hardware and software are not part of the problem.

    The final step then would be to take your backup 2245 files and overwrite the root folder. Then rename dinput8.dll back so it will load mods.

    This process may or may not fix your problem but it does work when you have a forced update and want to revert back to the previous version while you wait for a SHV update. I have done this btw, with only SHV and GTA5.exe and it worked perfectly in the past.



  • @JohnFromGWN Ill try that tonight. Im using epic. Could it be that its a shv issue? Iev tried 2060 with its own update, but then im in the rut of finding a working config, same with 1.45 and 2215. How are you running yours, latest version? Whered u get your config? I tried using the one in the link you sent the 4th one but it didnt work.



  • @VLADIMPALER72 I'm always updated and i used option 4 in the link, gameconfig from dilapidated but not his heap.

    https://www.gta5-mods.com/misc/gameconfig-xml-dilapidated

    https://www.gta5-mods.com/tools/heap-limit-adjuster-600-mb-of-heap



  • @JohnFromGWN Ok so 2372.2 runs singleplayer no mods. I tried your setup but it wouldnt work. I tried with 2245. I had 2245 running with the latest shv and it worked fine. up until i updated update.rpf.

    ill keep trying the 2245.



  • @VLADIMPALER72 i still don't understand your resistance to update and end all your problems. The tuner update broke my perfectly stable setup and given i don't use any cars other than addons and i don't care about the car meet garage i could have simply rolled back because i had all the necessary backups.

    Instead i found a combination that allowed me to run the update without crashing. Since then, I've added about 100 addon peds (none of which are mp shemale) and about 50 vehicles without issues.

    Today my setup is quite different because i installed all the major map extensions and to eliminate conflicts i created 9 different setups all sharing common files to virtually eliminate duplication.

    All that to say i encourage you to update unless you have a 2015 environment you desperately want to keep.



  • no resistance. I AM trying both 2245 and 2372.2, i just cant seem to get 2372.2 updated to run using ANY of the methods youve said or ways I know how. I will try to redownload gtav, and just run everything one at a time, new download of all of my mods to see why its conflicting.



  • I GOT IT TO RFGEAKIN WORK AFTER 8 HOURS!!!!!!!! so...... when the outage happened i thought i messed up the game so i deleted the whole thing only to find out I couldnt use the launcher. so yes, i was pissed. so finally it downloaded. i added scripthook, mods no problem, i only added to dllist my cars, no problem...... juilionib problem, and addons when added crashed my junk. so.. i redownloaded julios mods, deleted eevrything having to do with addonpeds, re did everything, and poof. im using 23.72.2, i will back this up once all my skins are back, then make sure not to every update my update.rpf. id played for over a year without doing it and never once a problem.



  • "none of which are mp shemale" 🤨 Hmm. 🤔


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.