Log in to reply
 

Can't download Scripthook



  • Seriously how can I download this thing?

    I thought maybe he would upload the file itself in gta5-mods at least but even in here it's still redirecting to his buggy website which is when I press the Download button it's just redirecting me to the main dev-c blog.

    I can't download neither GTA V nor RDR2 scripthooks from there and I really need them both :(

    I found some people saying at the reddit changing the link from https to http helps but when I do it just redirecting back to the https link and there I am unable to download it either.

    Anyways so does anyone has a working solution for this problem please? :( or maybe anyone know's Alexander Blade's official discord so I can go there and ask perhaps :/

    Many thanks in advance <3



  • @Aurora11
    http://dev-c.com/GTAV/scripthookv

    Just tested, link works and so does download. Bookmark it.



  • @JohnFromGWN Thank you very much, but it's still redirecting to main page for me :(

    I just don't understand why people making things so damn complicated while they could just upload it google drive or mediafire or somewhere simple like this.



  • @Aurora11 I don't understand why you're being redirected. Maybe you need to clear your browser cache?
    Which browser?
    Try this
    http://www.dev-c.com/GTAV/scripthookv

    Edit: I did a google search and found you're not the only one being redirected to blog. My guess again is a browser issue.



  • @Aurora11 I just had this same issue. Trying to remember how I resolved it.

    @JohnFromGWN Ok that's strange. Your first link worked for me but the second one did the redirect.


  • MODERATOR

    https doesn't work properly on Alexander Blade's website, so you need to use the http version.

    http://www.dev-c.com/gtav/scripthookv/ should work. Make sure you don't have HTTPS Everywhere or similar plugins enabled while downloading it.



  • @ikt Both links I gave were http, not https. i've never been redirected but obviously others have.



  • @ikt It redirected me at the link you posted. Nevermind I have Smart HTTPS extension. Good to know that it needs to be disabled for that site to work.



  • Also, for future reference, Firefox has a built-in HTTPS-only mode. If you're using Firefox and don't have any HTTPS extensions installed, try turning off the built-in HTTPS.

    HTTPS



  • @Jitnaught I'm using FF and I can essentially put whatever url I want, complete or incomplete, without any issues. No insecure messages, no plugins necessary. Just vanilla Firefox. Even this works for me:

    dev-c.com/GTAV/scripthookv

    However on the tablet, with Opera (because FF Android is a steaming turd), the SHV site was redirected.

    Solution, changed search engine from google to duckduckgo. Actually I just searched from duckduckgo.

    So this appears to be an issue with browser and google dns. At least for my tablet.



  • @Aurora11 Try this search. It replaces google search with duckduckgo. Link will appear at top of search results.

    https://duckduckgo.com/?q=scripthook+v&va=b&t=hc&ia=web



  • @JohnFromGWN The built-in HTTPS-only mode for Firefox is disabled by default AFAIK, so that would be why you don't have any issues. If you want to see what I'm talking about, go to about:preferences#privacy, scroll to the bottom and turn HTTPS-only mode on.

    The issue with Google is that it returns an https result for dev-c.com. DDG returns an http result.

    Google
    Google

    DDG
    DDG



  • @Jitnaught im surprised we don't have more reported issues at update times.



  • @Jitnaught I haven't quite understand the techinicality but thank you very much. I will do that HTTPS-only mode thingy on.

    It's weird though, like most people were saying when you type the link with http instead it's downloading, but I'm not much of an expert with these thingies so I never know :/



  • @Aurora11 Are you using Chrome? Firefox?

    The technical details. As @ikt first wrote, the AB site doesn't handle https properly (the secure version of http). The reason I was able to get to download page is because I was using http rather than https. Now in your case, even though I gave you http links to click on, your browser forced them to https - thus resulting in an undesired outcome, a redirect to the blog. As @Jitnaught wrote, and this is for Firefox, you can fix this in your settings.

    Rather than do this each time at the site level, you can set it permanently. Just to add to what @Jitnaught wrote you can do this by typing about:config as your url or do it from Settings like this:

    From the top menu, Tools, Settings, then Privacy & Security and scroll all the way down. At the bottom you will see a section called HTTPS-Only Mode with 3 options with radio buttons. Select the last one, set for Don’t enable HTTPS-Only Mode. .

    Again as @Jitnaught wrote this should be the default setting. I bank online so I can tell you it does not need to change and your secure connections for https will be maintained. But again, this is based on FF, not Opera, or Chrome, or Edge, or IE etc.



  • @JohnFromGWN Oh true I'm using Firefox. After changing that setting, it's able to open the http links.

    Also I tried with Edge too and I think it's not auto converting http links to https. So it was able to get the working download page. Haven't checked with chrome but I'm not really using it anymore after I started Firefox. It feels more honest, faster and privacy caring protection. Unlike how google could sell it's own a** for 2 bucks of ads...


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.