Log in to reply
 

Falling through the ground on Add-On Maps but can see them



  • @JohnFromGWN It stopped working after I installed it.



  • @Rct Ok. let's try that again.

    Did the December Contract update break this mod or it never worked period.
    Also, is your issue falling through the ground, which is this thread, or is your issue that you installed an MLO and it isn't appearing.
    These are two totally different issues.
    If your MLO isn't appearing you need to go back to basics - did you add it properly to the dlclist.xml, do you have all the requirements, etc.

    The steps outlined above are suggested as solutions for collisions - not for the mansion appearing.



  • @JohnFromGWN Sorry, if I confused you but what happened is that I re-installed it after I noticed there were no collisions, the update must of broken it but I wasn't using mods at the time. The problem is when I try your fix, the entire building MLO just disappears like it was never installed properly in the first place even though I know I installed it correctly.



  • @Rct In one of the first posts in this thread they said they found a fix that worked for Malibu as well.
    The difference is they set the overlay to true as well.
    So try that?

    <overlay value="true" />
    <disabled value="true" />
    <persistent value="true" />


  • @JohnFromGWN still nothing, I can get the props from the game to spawn and they have collision but I cannot get the building itself to appear without it losing its collision.



  • @Rct Pretty frustrating. Also in the thread was this:

    Notice the additional line for load completely.

    <overlay value="false" />
     <disabled value="true" />
     <persistent value="true" />
     <loadCompletely value="true" />


  • @JohnFromGWN Again, still nothing, here's my content.xml file here to look at and see in there are any issues:

    <?xml version="1.0" encoding="utf-8"?>
    <CDataFileMgr__ContentsOfDataFileXml>
    	<disabledFiles />
    	<includedXmlFiles />
    	<includedDataFiles />
    	<dataFiles>
    		<Item>
    			<filename>dlc_malibu_mansion:/%PLATFORM%/levels/gta5/malibu_mansion.rpf</filename>
    			<fileType>RPF_FILE</fileType>
    				<overlay value="false" />
    				<disabled value="true" />
    				<persistent value="true" />
    				<contents>CONTENTS_DLC_MAP_DATA</contents>
    				<loadCompletely value="true" />
    		</Item>
    		<Item>
    			<filename>dlc_malibu_mansion:/%PLATFORM%/levels/gta5/malibu_mansion_metadata.rpf</filename>
    			<fileType>RPF_FILE</fileType>
    			<overlay value="false" />
    			<disabled value="false" />
    			<persistent value="false" />
    			<contents>CONTENTS_DLC_MAP_DATA</contents>
    		</Item>
    	</dataFiles>
    	<contentChangeSets>
    		<Item>
    			<changeSetName>CCS_malibu_mansion_NG_STREAMING_MAP</changeSetName>
    			<filesToEnable>
    				<Item>dlc_malibu_mansion:/%PLATFORM%/levels/gta5/malibu_mansion.rpf</Item>
    				<Item>dlc_malibu_mansion:/%PLATFORM%/levels/gta5/malibu_mansion_metadata.rpf</Item>
    			</filesToEnable>
    			<executionConditions>
    				<activeChangesetConditions>
    				</activeChangesetConditions>
    				<genericConditions>$level=MO_JIM_L11</genericConditions>
    			</executionConditions>
    		</Item>
    	</contentChangeSets>
    	<patchFiles />
    </CDataFileMgr__ContentsOfDataFileXml>
    


  • @Rct You didn't change the metadata section, all the values are false.



  • @chonkie @Rct
    Exactly



  • @chonkie I just tried setting the disabled = true on the metadata and still I'm not getting anything! I think when I make disabled = true that it disables the thing from loading in, either that or my game is just cursed.



  • @Rct suggest you start with a fresh file and start with the suggestions here once more, being sure to include the Metadata file. Dont add the load tag in your first attempt because only one user has reported it as part of their solution.



  • @JohnFromGWN I'm gonna stop trying to fix this I think my game is just cursed I even moved all my other mods and created a new mod folder and it still wouldn't spawn in.



  • @JohnFromGWN You know, while we're here fucking about with the content.xml files, we should try looking into another mystery; EncryptedReality's maps.

    For some strange reason, there's been a bug where the majority of his maps just don't work for hardly anyone, including me. Like, it'll work for 1 in 10 users. And it's weird how that's the case. Because it's simply just the usual of adding the folder and then adding it to the DLC list. Yet, they never work.

    And I was wondering if maybe something regarding the content.xml file has something to do with it, for whatever the reason may be.



  • @Rct In your response you say that you switched diabled to true, did you switch any of the other values that were mentioned in the previous posts to switch?



  • @chonkie I did, actually and it still makes everything disappear.



  • @Rct Ok, so I figured out what was going on, I had a leftover script from the liberty city mod called "lcmapdisabler" and when I removed that and applied the fix, everything started to work!



  • @Rct thanks for sharing the issue and the cause


  • MODERATOR

    fun fact, that very script is created by the three musketeers elcreador, Filip/FV Design and LorenVidican... that last individual even tried to monetize on a -not so good solution- for the collision issue that we removed from the website



  • @ReNNie monetize the fix? That's absolutely disgusting. What a POS.



  • @WGotch07 Sorry can't test it because I'm reverted but looking at your pastebin the xml is fine, only suggestion would be to remove the files to enable since it was not included in some of the fixes...just throwing that out.



  • @WGotch07 I think you may have stumbled upon something here because the main dlc.rpf folder is named Dubai, not PalmIsland which is further down. So that's another thing to try when all else in this thread fails.



  • @WGotch07 said in Falling through the ground on Add-On Maps but can see them:

    @ValerioLombardi

    CCS_akina_NG_STREAMING_MAP

    Needs to match the dlc name

    Try CCS_akinaforv_NG_STREAMING_MAP

    @WGotch07 Interesting that you caught this error here. Slightly different from your fix for Dubai. Folder name was Dubai and that was your fix, but the actual rpf was called palmisland. Seems Dubai won.

    I'm keeping track of possible fixes in Falling through the ground on Map



  • well i managed in fixing the falling through the map situation but now the external of my building isnt updating textures to match changes.. I.E )building now has windows and doors) but still showing vanilla .



  • @JohnFromGWN friend , i don t have dlc folder under gta 5 main folder. i download menyoo spooner and map editor maps and all of them is problem. i fall through map. those maps has only .xml file. how can i edit maps to fix ? any idea ?



  • @cevoneo Sorry but I don't think anyone has reported collision issues on Menyoo (xml) maps.

    This thread , Falling through ground on map summarizes solutions that have been reported to date, well most of them.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.