Log in to reply

Falling through the ground on Add-On Maps but can see them

  • @cevoneo I have my DLC folder in my root, but that's exceptional.

    Your path should be something like this:
    \SteamLibrary\steamapps\common\Grand Theft Auto V\Mods\update\x64\dlcpacks

  • @JohnFromGWN thanks for replying , but this path is for maps with folders. Menyoo stuff and map editor maps have no folder in dlcpacks. They just have one file and it s .xml . You select from inside menyoo object spooner or map editor menu. Yes i think it will be solution for maps in dlcpack. Thanks

  • @cevoneo Yes I use Menyoo and I know exactly where the folders are. You wrote you had no dlc folder under GTA5, i just provided the path.

  • @Yogeshk Thank you, your fix worked for the SFLV dlc.

  • Ok, guys I downloaded the Los Venturas and San fierro remake mod and i got it to show up on the game, only problem is whewn i go there by helicopter or try and walk i go right through the dang map. I'm not sure how to fix it. I currently have the LA Revo mod with the march updates in it. I don't think that that in particular is causing the unsolid map addon, but if you guys could help me with a solution to this problem it would be greatly appreciated! If you need any screenshots of my .XML files like the gameconfig or whatever let me know.

  • @DeadLegends1984 go thru this post for solutions including your specific map. Collisions have nothing to do with gameconfig

  • This post is deleted!

  • This post is deleted!

  • does anyone solve the problem san fierro maps


    @bbex read through the post and all the replies. SF fix is in here

  • @Reacon , @bbex

    Fixes known to date are summarized here, although not SF or LV specifically, most are generic.

    The reference in this thread to LV, same map as SF, is not clear, just says solution worked but didn't name the user, so start with minimum and then test and try additional lines of xml as per thread linked below.

    Or revert, 0 issues with 2372 for example.

    Falling through ground

    This the first step:

    Fix 2
    Change certain values in the content.xml file for each map or MLO. This file can be found at the highest level of the folder structure of the dlc.rpf package. There could be more than one per addon.
    alt text

    This isn't recommended for new users or those with limited PC skills. Read the thread here. Credit for solution to @YHWHDios and @wert12.
    Screenshot below is used as an example only to show tag to be edited. Refer to thread above for more details. Remember to change all the tags described above - don't forget the metadata tags.

    alt text

  • Interesting... I'm having this issue with the ikONprojects mod (https://www.gta5-mods.com/maps/ikon-projects-mlo-net-ymap) where there are a few locations added on the main GTA V map. The mod says we need "online maps" enabled - I assume he means MP Maps? Also, has anyone else tried this mod and is having similar issues of falling through the ground?

  • @Suzerain001 if you look at simple trainer it explicitly has an option to enable online maps. Not sure how Menyoo handles it as I don't use any online stuff.

  • This post is deleted!

  • @JohnFromGWN
    it didn't work on the san Fierro map. i need tutorial video

  • This post is deleted!

  • @bbex i can't help you more than that because myself i have a bulletproof solution.

    I have no issues after updates, no collision woes, in fact no issues whatsoever. And I have every single major map, MLO, and race track installed, along with hundreds of peds and vehicles.

    Update after update, my game remains stable and error free.

    This wonderful solution is called reverting.

  • @JohnFromGWN @Yogeshk

    (SFLV)problem solved thank you very much
    I'm thinking of making a tutorial video for other people

  • @bbex That would be helpful. I wish there was a general solution that fixed all the collision mesh issues rather than doing every broken MLO, every broken map, one by one.

  • Hello everyone, hope the thread is not considered dead yet. What about the MLOs that don't load interiors at all? I don't simply fall through them, they appear like the doors of the building are invisible, and there's nothing inside. I change the values accordingly to the instructions, and for some it works, for some other not. there's one specific case where the outer shell of the building goes back to its "vanilla" state, as if i didn't install the mod at all. Any suggestions?

  • @Effe78 Unfortunately the only one size fits all is to revert your GTA5 version, and without guarantees that future MLOs will be backwards compatible.

    There are many different MLOs, some follow standards, others don't, so you need to try different solutions. I don't have any collision issues with any mods, but I've captured and consolidated reported solutions here:


    Visibility issues are a completely different matter, best to start new topic or contact author on mod page. While there check the comments for possible fixes.

    Edit: just a general suggestion that linking to a mod with your particular issue, only one is needed, will allow forum users to help. Just writing certain MLOs really is of little value.

  • @JohnFromGWN Thank you for the info, once i tried reverting and the game was crashing every 10 minutes, plus i would like to get the online updates stuff. I'll consider reverting again as the ultimate extrema ratio. I was rather trying to understand those values and what they actually do when set to true/false so one could try to act accordingly to what the non-working mod does. Also trying to understand the reasons why certain MLOs don't have collision, some crash the game, some other don't load interiors. But yeah i know, getting a degree in astrophysics or neuroscience would be easier :P

  • @Suzerain001 Yes, You need enable online maps with trainer (I prefer simple trainer...) here: Teleporting/ Other Teleports/ Enable MP Maps.
    About the coll error. I have latest update, without any change in the xml-s, and there is no issues for me. Maybe you have colliding with some other mod, or like @F7YO have a similar error, if used an older savegame, and maybe change Youre gameconfig... :thinking:

  • @ikON unfortunately every single game configuration is different. Consequently the solutions are not necessarily the same for each user. What we do know with absolute certainty is that the updates caused the interior problems for SP maps. I'm singling out SP because it has nothing to do with enabling online Maps.

    With version 2372 there aren't any of the issues described above in this thread. At least i haven't encountered a single issue.

    Now here's the best part, my game is updated to 2628, legit Steam purchase, but i fixed all issues above by changing a game file, only one single vanilla file, and that's GTA5.exe. Back to 2372, no problems (with SH ofc).

    Interestingly, although my experience is limited with Fxserver, i found some MLOs with missing interiors when i had 2372 and the corresponding server build. To fix this, i reinstalled FiveM with the latest build and swapped the 2372 GTA5.exe with the 2628 one.
    That fixed the issue. I just swap those files on startup, SP or FiveM.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.