Log in to reply
 

ScripthookVdotnet crashes on load (not startup), even with no scripts installed



  • ScripthookVDotNet crashes the game halfway through the loading screen for story mode. I have the latest version of both ScripthookV and GTAV on steam. No scripts in my scripts folder. Crashes when the dotnet files are there, doesn't when they aren't. That's all the information I have.

    This is the log:

    [17:04:11] [DEBUG] Loading API from .\ScriptHookVDotNet2.dll ...
    [17:04:11] [DEBUG] Loading API from .\ScriptHookVDotNet3.dll ...
    [17:04:11] [ERROR] Failed to create console: System.NullReferenceException: Object reference not set to an instance of an object
    at System.AppDomain.CreateInstanceFromAndUnwrap (System.String assemblyName, System.String typeName) [0x00000] in <bee01833bcad4475a5c84b3c3d7e0cd6>:0
    at <Module>.?A0xc1aa4bd5.ScriptHookVDotnet_ManagedInit () [0x00188] in <aa59ca740a294b85bf8729f9b735058a>:0



  • @Explodingcr Hard to help without more info. What version of game are you using, did this happen before or after update, can you post your asiloader.log and your scripthookV.log.

    Also do you have the latest version of SHVDN.
    https://github.com/crosire/scripthookvdotnet/releases

    One quick test you can do since you don't have any scripts, temporarily rename your Mods folder and start game.



  • GTAV version is 1.55. I just recently decided to mod the game, so I only installed SHVDN after the update. I do have the latest version. I'm not using OpenIV so I don't have a mods folder.

    asiloader.log
    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\windows\system32\dinput8.dll" => 00007F0019880000
    API: "DirectInput8Create" => 00007F001989CDA0
    API: "DllCanUnloadNow" => 00007F001989D660
    API: "DllGetClassObject" => 00007F001989D670
    API: "DllRegisterServer" => 00007F001989DA40
    API: "DllUnregisterServer" => 00007F001989DA60
    LOADER: Loading *.asi plugins
    ASI: Loading "Z:\home\kinder\games\steam\steamapps\common\Grand Theft Auto V\NativeTrainer.asi"
    "NativeTrainer.asi" => 0000000001A50000
    ASI: Loading "Z:\home\kinder\games\steam\steamapps\common\Grand Theft Auto V\OpenInteriors.asi"
    "OpenInteriors.asi" => 0000000002180000
    ASI: Loading "Z:\home\kinder\games\steam\steamapps\common\Grand Theft Auto V\ScriptHookVDotNet.asi"
    "ScriptHookVDotNet.asi" => 00000000021C0000
    ASI: Loading "Z:\home\kinder\games\steam\steamapps\common\Grand Theft Auto V\TrainerV.asi"
    "TrainerV.asi" => 0000000002320000
    LOADER: Finished loading *.asi plugins

    ScripthookV.log

    // GTA V SCRIPT HOOK (build Dec 20 2021, v1.0.2545.0)
    // (C) Alexander Blade 2015-2021
    [17:06:09] INIT: Started
    [17:06:09] INIT: Success, game version is VER_1_0_2545_0_STEAM
    [17:06:09] INIT: Registering script 'NativeTrainer.asi' (0x0000000001A5A3C0)
    [17:06:09] INIT: Registering script 'OpenInteriors.asi' (0x000000000218B950)
    [17:06:09] INIT: Registering script 'ScriptHookVDotNet.asi' (0x00000000021C1480)
    [17:06:10] INIT: Registering script 'TrainerV.asi' (0x0000000002704580)
    [17:06:17] INIT: Pool 1 extended
    [17:06:17] INIT: Pool 2 extended
    [17:06:17] INIT: Pool 3 extended
    [17:06:17] INIT: Pool 4 extended
    [17:06:23] INIT: GtaThread collection size 189
    [17:06:23] INIT: wnd proc 0x00000000FFFF0028
    [17:06:23] INIT: IDXGISwapChain 0x00000002EE0A7A30 (0x00000002EDF90920)
    [17:06:23] INIT: IDXGISwapChain set
    [17:06:30] INIT: DX init started
    [17:06:30] INIT: DX feature level B000
    [17:06:30] INIT: DX init succeeded
    [17:07:45] CORE: Requesting thread creation
    [17:07:45] CORE: Creating threads
    [17:07:45] CORE: Started control thread, id 32 active 1
    [17:07:45] CORE: Started thread 'NativeTrainer.asi' (0x0000000001A5A3C0), id 33 active 1
    [17:07:45] CORE: Started thread 'OpenInteriors.asi' (0x000000000218B950), id 34 active 1
    [17:07:45] CORE: Started thread 'ScriptHookVDotNet.asi' (0x00000000021C1480), id 35 active 1
    [17:07:45] CORE: Started thread 'TrainerV.asi' (0x0000000002704580), id 36 active 1
    [17:07:45] CORE: Launching main() for 'NativeTrainer.asi' (0x0000000001A5A3C0), id 33
    [17:07:45] CORE: Launching main() for 'OpenInteriors.asi' (0x000000000218B950), id 34
    [17:07:45] CORE: Launching main() for 'ScriptHookVDotNet.asi' (0x00000000021C1480), id 35
    [17:07:45] CORE: Launching main() for 'TrainerV.asi' (0x0000000002704580), id 36
    [17:10:35] UNINIT: Unregistering script 'TrainerV.asi'
    [17:10:35] UNINIT: Unregistering script 'OpenInteriors.asi'
    [17:10:35] UNINIT: Unregistering script 'NativeTrainer.asi'



  • @Explodingcr I really don't see anything wrong from the logs. I was expecting a mod to have created the issue but you don't have any mods, you don't have any scripts either, don't need OpenIV AFAIK.

    I would try to remove OpenInteriors.asi (just rename it) and you don't really need NativeTrainer (Not worth it). Don't know what else to suggest.

    Did you edit any game files yourself?



  • @JohnFromGWN I'll try without openinteriors and yeah I never used NativeTrainer I just never decided to get rid of it (I had no reason to) so I'll try without those. Also, this website doesn't let me reply for 10 minutes after I reply once so I'll reply by then I guess. Also, what do you mean by "Did you edit any game files yourself?" Not sure I understand the question.

    Edit: Ok I can just edit this. It still crashed without openinteriors or native trainer. I feel like the problem is in the dotnet log. Do you know what that error was?



  • @JohnFromGWN Oh I guess it didn't tag you when I edited it. Do you have any idea what the error might mean?



  • @Explodingcr Unfortunately not. I googled the error and it seems to be generic, i.e not necessarily GTA5/SHVDN related. I was hoping it was just a mod behaving badly.



  • @JohnFromGWN Well, thanks for the help. I'm still really confused what the bug is but I'll live without dotnet mods for now I guess.



  • I am also having the same issue. I am playing GTA V version 1.0.2612.1 on my laptop having windows 8. I am having an updated version of Scripthookv and Scripthookvdotnet. but as I copy those Scripthookvdotnet files in my GTA v it crashes on the loading screen.
    i h



  • @SHREE7861 check your other post, make sure you have the updated framework.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.