Log in to reply

If your map mods are missing collisions, please read this.

  • If you're dealing with collision issues, that's because the latest update, "The Contract", has broken add-on maps. But don't worry, there's an easy fix!

    Go to update\x64\dlcpacks\Your Map\dlc.rpf and open your content.xml file. Now go and check these areas:

    Check the <filesToEnable> section and make sure it contains your map's .rpf files. If it just says <filesToEnable />, then that's part of the reason why the map doesn't work, and you must add them. Sometimes, you may need to add more than just the map and its metadata. If it contains your map's .rpf files, move onto the next step. An example is shown below.


    The next step is to check the <dataFiles> section and make sure that disabled and persistent are all given a value of true for all items. An example is shown below.

    			<overlay value="false" />
    			<disabled value="true" />
    			<persistent value="true" />
    			<overlay value="false" />
    			<disabled value="true" />
    			<persistent value="true" />

    This should fix collision issues. So far, this has worked for everyone. Happy playing!

  • @WGotch07 Hopefully this gets pinned for future users.

  • Uh... I have done everything, why my map mod still disappears. Are there any ways else?

  • I had seen it and I tried every steps. No, still no. I want to say my problem is a little different and worse. My map mod doesn't disappear when I get closer, instead I can not see and just like the map dlc doesn't load. Also came the worst thing, that is after I install San Andreas DLC, my game over, RAGE Plugin Hook failling hooking my game, when I reset game, RPH still can't hook my game. Really bad and I was so angry.

  • @mrwallace888 that's interesting - I see a tall skyscraper disappear in downtown area since I use LA Revo 2.0 as the main mod. But there's no separate "map mod" within LA Revo 2.0 - how do we fix that?

  • @ShaoyeBen I can only tell, that to have the map visible (for Liberty city on my case) the <disabled value="true" /> has to be on false value, not true, for it appears on the game. (Concerning the metadata and all the sub dlc containing ybn files, at least, if disabled is on true value, nothing is loading)
    But in my case, it doesn't change the fact there's no collision, I can just see it perfectly the town, with all details, but when i try to walk/jump/fly on it, I just stay under the map, in the water. Makes me really crasy lol ! none of the true/false content.xml I've tried, did worked. If someone find an issue concerning Liberty City rewind or other map accessibility, it would be great lol !

  • @Sido200 said in If your map mods are missing collisions, please read this.:

    I have the same issue. Just installed Liberty City Rewind and fell right through the map into the water. When changing the <disabled value = "false"> & <persistent value = "false"> to <disabled value = "true"> & <persistent value = "true">, the entire map disappears - no bridges, no buildings, nothing.

    Really annoying!

  • @Suzerain001 CAN you help me with collision on Liberty City map?

  • The 'Concrap' (contract) and the latest 'rehash' updates gave me the opposite problem. Either my modded MLO buildings crash the game if I get in the vicinity or they have 'collisions' where I can see into the buildings, but can't enter. If I phase in, there's no link to the portal and I just fall through the map. Normally, I just go into the mod metadata and remove any 'streaming' assets and the maps work again in SP. These latest two updates have messed things up so bad, even that doesn't work any more. I even tried to remove the collisions from the updated dlc's and that didn't work either. Unless there's some local fix I don't know about, it will take the mod creators to update their maps (which seems like they're more 'hump and dump') to fix the issues. Not holding my breath waiting for that to happen....

  • @iammistahwolf
    its better to download a version of gta 5 that doesnt have the contact.

  • Every update R* does, something else breaks.

    This fix doesn't work, and as far as I can tell it's best to just wait until the map modders figure out a new solution.

  • @JediKarumaas or possibly might have better luck with the Rockstar Games help centre line

  • Havent read all of this thread but has anybody mentioned that rockstar changed the names of some files like collision and ymap files? For example a collision named lr_cs1_... changed to cs1_... . I noticed that using codewalker

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.