Log in to reply

Random CTD HELP!!

  • So I posted on here the other day and turns out it has nothing to do w/ police or wanted.

    After a while I get random CTD with no error message and in the rockstar launcher logs it says "Game exited with code 0xc00000fd (3221225725)". I have all the adjusters and game configs and a high end PC and getting 60+ fps consistently. I've also attached the Windows Event viewer log. Sometimes I can drive around for ages with no issues, others it crashes pretty quick. I get texture loss occassionally but when i wipe closeby cars/trains it fixes it.

    Any ideas? I Don't want to go through every mod and script trying to fix it lmao. Thanks in advance xoxoalt textalt text

  • @ChopSpeaking
    From your other thread, have you tested with the empty 'popgroups.ymt' & 'vehiclemodelsets.meta' I provided & thus also eliminated all ambiently spawning vehicles as a possible cause?
    If not, I would install those files & drive around for ages until you either, get a crash (thus confirming it isn't ambiently spawning vehicle related), or play long enough to be confident that there is no issue (thus confirming it is (most likely) ambiently spawning vehicle related).

    Also, & in a separate test (ie not initially at the same time as testing the empty 'popgroups.ymt' & 'vehiclemodelsets.meta'), have you renamed your 'scripts' folder & done the same? ie drive/run about until you confirm whether the issue is still there or not? If not, do that also & let me know your findings. Thanks :thumbsup:

  • @a63nt-5m1th So i ran with an empty Popgroups and no cars/peds spawned although a few things (Scenarios from WOV; bikers, a few random peds), and a few scattered cars with no passengers. after a while the game crashed except this time i got "gta is not responding" when normally it just freezes then CTD. will try without vehiclemodelsets tomorrow.

    I'm wondering if i've got a corrupt car and whenever that spawns thats when it crashes. because its random and usually when im in north end of the city.? but idk how to fix or to tell

  • @ChopSpeaking
    To diagnose a problem with ambient spawning vehicles, you should install both the empty 'popgroups.ymt' & 'vehiclemodelsets.meta' at the same time & see if the issue persists? Then, if that removes the issue, you move to figuring out which one of the two files is at the root of the issue.
    So, when you are testing 'vehiclemodelsets.meta' tomorrow etc, also install the empty 'popgroups.ymt' & see what you get with both files being empty. :thumbsup:
    If the issue persists through that process it's likely unrelated to ambient spawning vehicles & you move to looking for another cause.

  • @a63nt-5m1th I see, also when you say empty files, i've just been searching to find them in my mod folder and removing all the text?? (After backup of course) is this the way to do it? and theres multiple of each file...

    if theres an easier/better way, let me know pls. you've been super helpful cheers!

  • @a63nt-5m1th so i just played without zero text in popgroups and vehiclemodelsets in both mod places of each, so 4 files total. Drove around for a while and eventually had another CTD. Going to try with normal popgroups and vehiclemodelsets and no scripts?

  • @ChopSpeaking
    Using completely empty files by removing all text is a variable I cannot account for. That in & of itself could potentially cause a different crash. Use the files I provided in your initial thread on the subject as I know they will not introduce any new variables into the mix. :thumbsup:

    Generally, removing all text from files is a bad idea. Very likely to cause additional crashes/issues.

    As to the multiples of files, the ones in 'update.rpf' will be the ones loaded by the game, as long as they are in the correct locations of course:

    ...\Grand Theft Auto V\mods\update\update.rpf\common\data\ai\vehiclemodelsets.meta
    ...\Grand Theft Auto V\mods\update\update.rpf\x64\levels\gta5\popgroups.ymt

    Generally, if you remove all the text from within a file, even if it doesn't crash the game instantly on load it's possible for the game to skip using it & fall back to using one of the files in a different location or even a completely different method. This probably doesn't apply in your case, given you removed the data from all versions of the files installed, but for future reference, it's a very bad idea doing it like that & as mentioned, something I can't account for (I don't know exactly what the game does if you do it like that etc, which introduces unknown variables into the diagnostic process).
    You want to be confident the game is using the file you edited, so the best policy is to edit the file & remove only the parts you want to test while leaving the structure of the file internals in place so that the game uses it & no potential redundancy kicks in.

    To save a bit of time overall & so I can be confident of your results, when you are testing the game without scripts, also install the 'popgroups.ymt' & 'vehiclemodelsets.meta' I provided in your previous thread. If the game is then fully functional, you only have three variables to diagnose (scripts, popgroups or vehiclemodelsets), but if it still crashes you can confidently rule out those three as being at the root of the problem. :thumbsup:

  • @a63nt-5m1th Oh heck i never even saw that!! thanks man i'll chjeck it out

  • @a63nt-5m1th SO i just installed those files and also disabled scripts, there was a bunch of peds walking around and the only cars I saw were police, a couple modded ones which i guess are placed etc.. I got another CTD with no police on me. Any ideas from here?

  • @ChopSpeaking said in Random CTD HELP!!:

    a couple modded ones

    Modded cars? Do you mean 'modded' as in non-vanilla & added by you or 'modded' as in with upgrades (bodykit etc) already applied? They are likely spawned by car generators in '.ymap's, but if they had upgrades already applied, something is going on & needs to investigated.
    Also, if they were non-vanilla vehicles (ones you have replaced etc), that might be something that potentially needs eliminated as a variable. That variable could be removed by backing up the '.rpf' archive the vehicle/s is/are installed in & replacing it with a vanilla one (if installed to 'x64w.rpf' that's probably your easiest course of action, or if installed within 'dlcpacks' (in a patchday##ng dlc etc), just rename the dlc folder temporarily) & then test in game.

    Any Overclocked Components?:
    Have you overclocked any of your hardware (CPU, RAM, GPU etc) in your PC? If so, at some point might be worth removing any overclocks & testing the game to see if it's stable like that. It doesn't necessarily mean your overclock is overtly unstable, just that GTA V doesn't like it like that (it's somewhat subjective, & I've never experienced it with any of my GPU overclocks, but I've encountered people online who's apparently otherwise stable GPU overclock causes GTA V to randomly crash, albeit usually with a ERR_GFX_D3D_INIT error message). I actually doubt it's overclock related, but if you are overclocking components, let me know, as it's diagnostically valid even if you've had no issues previously etc (for example, some overclocks take a time to 'bed in' initially & may sometimes require additional voltage after that, especially CPU's) :thumbsup:

    Investigative 'mods' Folder Rebuild:
    If no overclocking, or you still get a crash with stock settings, this is the point where I would test out an investigative 'mods' folder rebuild (or partial rebuild, if you suspect certain files/archives etc) in order to gather data about where the issue may reside within the game.

    Don't worry, it's not as time consuming or difficult as you might imagine. This is just a basic investigative rebuild, most of the time will be spent either moving files or folders or loading up the game & driving around waiting for the crash to happen, rather than messing with files within archives or anything more complicated like that. :thumbsup:

    While doing this don't let anything new you might discover in the game distract you (I usually find something new of interest when doing this etc). Just make a note of it & once you have finished investigating this issue you can go back to it & investigate that instead.

    Don't delete anything while doing this either, that's a real good rule. :thumbsup: There should be no reason why you should need to delete anything while doing this. Just remind yourself of that before you start, it's too easy to delete something from the wrong folder when you have two of them open at the same time etc.

    Also, after each crash it's worth double-checking the logs to confirm it's the exact same crash. While doing a 'mods' folder rebuild it's potentially possible, depending on game setup etc, to introduce a new, but similar crash, into the mix. You want to be able to tell that any crash you experience is caused by the same issue, so checking any error logs & making sure it's the same error code/info displayed is worth a moment of your time.

    Additionally, if you are likely to get distracted or disturbed by someone while doing it, or you plan to do it over a few days etc. Create a '.txt' file on your Desktop, or use a pen & paper to make a note of what you have done & what point in the process you are at, so you can pick up where you left off, even if you don't remember exactly where you were etc. :thumbsup:

    Investigative 'mods' Folder Rebuild Process Instructions:

    • Rename the 'scripts' folder, so that it is out of the way for this entire process.

    • Then, rename your current 'mods' folder to something else (anything will do, 'mods - [RENAMED]' etc)

    • Create a new empty 'mods' folder in it's original place (ie right next to your old (now renamed) one)

    • Boot up the game at this point & see if the crash is still there?

      • If you get a crash with an empty 'mods' folder move to verifying the vanilla game files & redownload any it requires you to & see if that fixes it & report back.
      • If there is no crash with an empty 'mods' folder, you are good to continue
    • Go to your old (now renamed) 'mods' folder & move all your 'x64a>w.rpf's archives & 'common.rpf' over into the newer empty 'mods' folder you created earlier (move them, there's no need to copy & paste, although you can if you want & have enough space, but generally, its quicker & also easier to keep track of things if you move them instead of creating duplicates (which might confuse you at a later stage. Did I move them already or not? :thinking: etc))

    • Load up the game & test to see if the crash is there or not?

      • If it does crash, the issue is most likely in one of the 'x64a>w.rpf's archives or 'common.rpf'. Move half of them (any half of them will do) back into their original location within your (renamed) 'mods' folder & re-test the game. Continue like that, moving half of what is there in or out of the new active 'mods' folder (depending on results) until you narrow the crash down to one '.rpf' archive.
      • If it doesn't crash with all the 'x64a>w.rpf's archives & 'common.rpf' installed, then you know they are good & you're ready to test other parts of the game (you can leave them there or move them back to your original (renamed) 'mods' folder, it's up to you):
    • Next I would test 'update.rpf'. Create any folder structure necessary (ie, an 'update' folder within the new 'mods' folder) & move just the 'update.rpf' archive across (ie you don't want to move 'dlcpacks' over just yet)

    • Boot the game & test to see if it crashes

      • If crash, something in 'update.rpf' is causing it. Move to rebuilding 'update.rpf' from vanilla using your previously modded 'update.rpf' as a guide & source for your modded files. Do it in some kind of order. Install one, or a few files, or just one folder structure at a time & test the game inbetween each change.
      • If no crash, would suggest issue resides somewhere within 'dlcpacks', as that is all there really is left to check
    • Use a similar 50/50 process as you used with the 'x64a>w.rpf's archives earlier. Create the necessary folder structure & move half of the folders within your old 'dlcpacks' across into the new one & then test the game:

      • If crash, it's in one of the dlc's you just moved over, remove half of them back to their original location within your (renamed) 'mods' & test again. Continue like that, moving half in or out (depending on results) until you narrow it down to one dlc.
      • If no crash, issue must be in one of the dlc's that are still in your original (renamed) 'mods' folder. Move half of the remaining folders from there over into the active 'mods' folder repeating the process like that until the crash reappears & ultimately, moving the folders about, you narrow it down to one dlc.

    Moving half the folders within any one folder will save you a lot of time (see proof of concept below), but other than it taking longer there's nothing wrong with doing it one file or folder at a time.
    If you are more comfortable with that, do it that way if you prefer :thumbsup:

    50/50 Proof of Concept (starting sample 100 files/folders):

    No. of Loads of Game        No. of Files/Folders     
             0                          100
             1                          50
             2                          25
             3                          12.5 (lets call it 12)
             4                          6
             5                          3
             6                          1.5
             7                          <1 (i.e below 1, folder/archive identified)

    Might look like a lot to process, but that's more me just being thorough & it's a lot easier in practice than it looks here. Follow the general process, don't delete anything & keep a note of what you have done & where you are & you should be good.
    You have a better idea than me of where the most heavily modded parts of your game reside & what kinds of edits you have made to files etc, so feel free to adapt the general process above to your needs if you wish & are confident enough to do so. Renaming 'dlcpacks' temporarily & test loading the game is an alternate place to start for example.

    Any questions or issues, give me a shout :thumbsup:

  • SO for the first part, I mean modded as in add-on vehicles, so like there were food delivery add on vehicles spawned etc. I just turned off my overclocks AND had no ambient vehicle spawns while driving and I still got a crash after 5ish minutes. I've installed quite a few OIV installers so Ithink some may have replaced and add-on vehicles but if none of them are spawning it shouldnt affect the crash? I'm also newbie to modding so i could be testing wrong or not 100% correctly so not getting accurate results which sucks.

    I may have to do the mods folder rebuild today and let you know.

  • @ChopSpeaking
    What 'gameconfig.xml' do you have installed? Try the one from F7YO here as a quick test before doing anything else (if you don't have it installed already). Install only the correct version for the version of the game you have installed (there are multiple versions in the download, v1.0.2545.0, v1.0.2372.2 etc). Installing one designed for an older version of the game (or newer, if you have reverted your game etc) can cause issues &/or crashes sometimes (just remembered this gameconfig fixed a random City area only crash I had a while back. Worth a try :thumbsup:)

    @ChopSpeaking said in Random CTD HELP!!:

    but if none of them are spawning it shouldnt affect the crash?

    If the add-on vehicles don't appear to spawn, it would be pretty unusual for them to cause a crash, but although unlikely, they can't be ruled out completely as you have seen, they can still be spawned by car generators even if they don't spawn in traffic. You could have the game try & spawn a broken vehicle (in traffic or using car generator, it makes no difference, broken is broken) & crash instantly because of it. You wouldn't necessarily see it spawn in that situation either.
    Also, it's entirely possible for a vehicle to spawn out of sight, although I would expect with enough testing you would see it happen within view eventually.

    Don't worry about that^ too much though, once you've ruled out any potential gameconfig issues by trying F7YO's one, an investigative 'mods' folder rebuild is definitely the best & quickest next step at this point. You could waste weeks trying to figure it out testing multiple different ideas, or just go for the investigative rebuild & let it tell what's wrong & have the issue's location identified & usually fixed within a few hours to a day. :thumbsup:

    The more comfortable you are with the process, & the more you know the game, the quicker you can fix things using that process. Usually, from a random crash I can be back up & running & 100% stable within a few hours. Intermittent crashes can be far more time consuming & frustrating to solve, but often you can get a rough file location in 3>5 loads of the the game & the problem '.rpf' identified within 7>10 loads of the game. Finding the exact cause within a file can take a bit longer, depending on what '.rpf' it's in etc, but I'll be able to help you out with that once the '.rpf' is identified.

    Have a go at all that^ & let me know what you find & we'll take it from there :thumbsup:

  • @a63nt-5m1th So i followed your guide and I got a random CTD from having JUST the update.rpf in mods. ASSUMING (I really hope so hahah) this is the only error causing the CTD, what would be the most effective way to test this folder? Start with vanilla and gradually add mods back? do i try playing with just common, without dlc_patch and x64? What's the way to go from here...?

  • @ChopSpeaking
    Both ways (starting from vanilla/editing modded 'update.rpf' back to vanilla etc) can be applicable. Generally, it's cleaner overall starting from vanilla, but if for example, you are diagnosing a crash on startup or something that gives you a result quickly after starting the game etc, it's often quicker to work from the broken modded file.


    • First step is to figure out if the issue resides in 'common', 'dlc_patch' or the 'x64' folder within your 'mods' folder 'update.rpf'.
    • Backup your 'mods' folder 'update.rpf' if you haven't already (so you can revert if need be while testing or revert at the end & apply only the fix required etc)
    • Using OpenIV, access the vanilla 'update.rpf' from the 'game' folder & drag & drop it's 'common', 'dlc_patch' & the 'x64' folders into a windows folder of your choice (say, one on your Desktop etc)
    • Now still in OpenIV, go to '...\Grand Theft Auto V\mods\update\update.rpf' & drag & drop only the vanilla 'common' folder (from Desktop folder etc) into that location overwriting the one within your modded 'update.rpf'.
    • Load the game & see if you have a crash or not:
      • If that fixes it, you know the issue is in the 'common' folder structure somewhere & needs further investigation. Revert using your backup at this point, before proceeding.
      • If it still crashes, test the 'dlc_patch' folder next.
    • Proceed like that until you confirm which one of the three folder structures the issue resides in.

    Then, depending on what folder structure you find the issue in & also using your knowledge about what files you have edited within that folder structure you can either;

    • continue down into the folder structure using the same method of testing each folder structure within a folder independently (report back once you narrow it down to one folder. Unless of course you find & fix the yourself etc :thumbsup:)
      Replacing half the files/folders within a folder, ie using the 50/50 method mentioned previously, will net the quickest returns & you can always use your modded 'update.rpf' backup to revert at any point & retest something if need be etc.


    • Alternatively, if you know exactly what files have been edited within that folder/folder structure, just simply try replacing each one with it's vanilla counterpart one by one until you figure out what file is at the root of the issue. (as a general rule, in the 'Attributes' column of OpenIV, if a file says 'Compressed;Encrypted;', the file is vanilla & hasn't been edited. If it only says 'Compressed;', then that file has been edited (or at least replaced) & needs to be reverted to vanilla to test it)

    Just so you know, even when you manually replace a file with a vanilla counterpart the 'Attributes' column will continue to say only 'Compressed;'. The 'Compressed;Encrypted;' doesn't reappear after a file has been edited/replaced (even with a vanilla file), unless you revert the whole archive to vanilla etc.
    Just didn't want that to confuse you etc :thumbsup:

    You have your backup to revert to at any point, so while doing this you can test out doing whatever you want within your modded 'update.rpf'. If you know a file resides in a secondary location for example, like inside 'common.rpf', deleting it from within 'update.rpf' & test loading the game is another approach.

    See how you get on with that anyway & report back. Thanks :thumbsup:

  • So i just tried using the vanilla common, then dlc_patch, then x64 and i still got crashes with all of them. I vaguely remember getting crashes with trains so i went near the train tracks and it crashed after a few minutes so i thought maybe it was Kitsune trains 6.1... i reinstalled it correctly and then i went near the train tracks and the mod worked and spawned a train and didnt crash. In the same game, I disabled trains through the trainer and drove around for a bit and then CTD again. Now i'm really stuck :'(

  • @ChopSpeaking said in Random CTD HELP!!:

    Kitsune trains 6.1

    Completely uninstall that mod & test :thumbsup:

    In the mod comments for Kitsune trains 6.1 there are 88 references to the word 'crash'. Many people have had issues with it, especially since the Cayo Perico update. Many potential fixes are mentioned in the comments (inc. trying lots of different gameconfigs (if game loading, ur gameconfig is probably fine tho) removing the packfile limit adjuster, checking 'dlclist.xml' is good & not damaged by the mod install (if it is, you want to forget the mod & rebuild using a new 'update.rpf' as you're modded one is likely permanently damaged (reports of crashes continuing even when train mod is removed suggest that has happened to a few people)), the mod author also suggests Rockstar have broken the game for mods that require custom gameconfigs & heap adjusters & that's where the issue stems from).

    Personally, I wouldn't install anything like that that's had so many issues throughout it's entire development cycle & requires fixes after every R* update. Remove the mod completely, rebuild 'upodate.rpf' from vanilla if you continue to have crashes, & then if you really need the mod, read the comments for ideas & reinstall the minimum the mod offers (being fully aware that you might have to go through the entire process again as soon as it crashes once (especially if it damages 'dlclist.xml')

  • Thats where the issue comes in, it's two OIV files and a bunch of other stuff and theres no OIV uninstaller. Any idea the easiest way to uninstall the mods?

    and how do i know if the DLC is good/not damaged? If im rebuilding a new update.rpf wont i need to reinstall a bunch of mods again? and not know which ones??

    How do i rebuild from vanilla?

  • @ChopSpeaking
    For unistalling, grab your self a copy of 7zip & use this tut for guidance as to how to access the files within an '.oiv' installer.
    Inside the 'assembly.xml' within the '.oiv' you will be able to see exactly what files it has installed, or alternatively, you can look through the '.oiv' folder structure & check the files that way.

    Edit: (in bold)

    Make a list of the files & replace them with vanilla versions manually (this is the preferred method with issues where you don't trust the original '.oiv' installer, as a poorly written/broken '.oiv' can still damage you game files even with just vanilla files installed in it) or follow the tut & use them to create your own '.oiv' uninstaller (if you are 100% confident the original '.oiv' is good). If you don't understand anything or have any questions, just give me a shout :thumbsup:

    The variables are beginning to pile up here tho. You don't know if it's 100% the train mod causing it, you don't know whether of not 'update.rpf' is damaged beyond repair etc. Might be that starting from a vanilla 'update.rpf' & rebuilding it is you best option at this point.
    If the game loads & there are no issues with any crashes using a vanilla 'update.rpf', that's the route I would likely take if it was my game. You still have your modded 'update.rpf' to access files from, so there should be no need to lose any mods, it's just a bit time consuming rebuilding a '.rpf' one file at a time (while loading & checking the game after each change to make sure you don't reintroduce the original error/cause of the crash).
    You could get it done in a day tho, just use the same method as you used previously, backing up the 'update.rpf' you are editing before every change & dragging whole folder structures into that 'update.rpf', just this time start from a vanilla 'update.rpf' instead. If you reintroduce the crash at any point use the backup you just created before that to revert & move to installing just one or a few files at a time within that problem folder structure until you pinpoint the one causing it.

    Edit: (in bold)

    Obviously, if you suspect the train mod & have a list of the files it installs to 'update.rpf' don't install those ones while doing it. Same goes for any other mods with '.oiv' installers you remember installing, you can always test install them again once you have a stable game etc.

    If you decide to go the vanilla rebuild route, the first thing to check is that a vanilla 'update.rpf' works 100% to remove the crash? I think you did this already, but do it again, just so you are 100% sure. :thumbsup:

  • @ChopSpeaking
    Regarding the Kitsune Trains 6 '.oiv' installers, they install 'trains.xml' & 'traintracks.xml' to 'common.rpf', not 'update.rpf'. Although 'common.rpf' is the default vanilla location for these files there's the potential for those files to exist within 'update.rpf', if for example another mod installs them there, or you moved them previous to intalling Kitsune Trains 6 etc.

    Hit Ctrl+F3 in OpenIV & search your 'mods' folder only for both those files & double-check whether they exist in 'update.rpf' or not? If so, they would overrule the 'common.rpf' ones installed by Kitsune Trains 6 meaning the mod would not have been installed correctly when you originally installed it. That would likely cause a crash & is worth ruling out.

    The only file Kitsune Trains 6 installs to 'update.rpf' is 'vfxvehicleinfo.ymt' here:

    ...\Grand Theft Auto V\mods\update\update.rpf\x64\data\effects\vfxvehicleinfo.ymt

    The '.oiv' installer appears to be OK, it doesn't have the common errors in it that can damage 'update.rpf', but you should be aware that anything you automate can go wrong sometimes. Although most are totally fine, I don't use '.oiv' installers & prefer to install manually as I trust myself more than I do a random installer written by someone who's skillset I don't even know.
    Now that you know how to access the files in an '.oiv' using 7zip & how to read the 'assembly.xml' to figure out where to install the files, manually installing might be something you want to consider doing in future. Certainly use 7zip to check every '.oiv' before you install it & make sure it looks right at least (be wary of ones that have blank lines within the body of text within 'assembly.xml'. Blank lines after the text is fine) :thumbsup:

  • So before I go any further, I searched and trains.xml is in update.rpf... I completely removed update.rpf and drove around for a little but the Kitsune trains were still spawning? i didnt drive for long enough to crash but wanted to let you know before i move forward. what do you think firs step is?

  • @ChopSpeaking
    First, check to see if you are still crashing or not. If no crash rebuild 'mods' folder 'update.rpf' as mentioned previously, if still crashing, test remove/revert to vanilla your 'mods' folder 'common.rpf' & test for a crash again.

    As to the Kitsune trains still appearing, they should not be if your 'dlclist.xml' in your 'mods' folder 'update.rpf' is vanilla? (ie if the Kitsume dlc are not being loaded somehow)

  • Okay so, if i can get sorted i'm gonna need a way to transfer you $$ to buy yourself a present because i'm about to potentially ruin your night..... firstly, I have a backup folder with the latest working-ish (with the random CTD) before all this editing etc folder right.... so then I deleted my main folder and was going to reinstall and start again... when i deleted the main folder I opened rockstar launcher and it said "play" and i was very confused so i opened folder location and it was the fkn backup folder..... I really really really am hoping it somehow switched when i deleted but otherwise I may be the most stupid person on the planet and have been editing the files in the main folder when it wasnt even launching from there.....

    I swear to god if it's the latter i'm going to throw my pc out

  • @ChopSpeaking
    I suspect that is what's happened. Some of your last results don't make sense if you were editing the files loaded by the game (Kitsume trains still loading even tho 'mods' folder 'update.rpf' was vanilla/had vanilla 'dlclist.xml' etc).

    Not sure how it could have changed the game location, unless you installed the game to your backup folder at some point. Then it would have re-written the registry values for the install location to your backup folder etc.

    Find out where GTA V is installed:

    • Hit the Windows Logo keyboard key & 'R' together (opens Run box)
    • Type 'regedit' & hit '[Ok]'
    • then navigate to:
      Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Rockstar Games\Grand Theft Auto V
    • click on the 'InstallFolder' key (in right hand box) & see what folder path it says.

    Do not change anything in the registry while you are in there.

  • @a63nt-5m1th hey man sorry its been so long! work got chaotic. So i end up not being able to work it out and just created a fresh start. I obviously left out Kitsune Trains and any mods that i thought may cause an issue.... and im still getting random CTD!!!!! Ive backed up save files 4 times along the way so i have 4 seperate installs ready to go. Its frustrating as soemtimes the CTD wont happen until 20+ minutes in so its very time consuming to test. Im wondering whether its somehting on my system or something else???? It suckssssss

  • @ChopSpeaking
    The only way to diagnose it will be to start with a vanilla game, ideally a 100% fresh reinstall of the game to a new file/folder location (play that for a while & make sure there are no crashes) & then add one mod at a time, while playing thoroughly after each change, until you reintroduce the crash & figure out what is causing it.
    Do the same thing for any modded 'gameconfig.xml' you use. There are no guarantees any particular modded gameconfig will work 100% for your system/setup, so that needs to be tested/diagnosed just like any other mod as well. Just take it slow, only add one thing at a time, & be sure to playtest the game thoroughly inbetween each change.

    Other things to try:

    • Remove any overclocks you may have.
    • Run a System File Check, CheckDisk & DISM to make sure Windows is ok. Instructions in this thread.
    • Run a memory test to make sure your RAM is ok
    • Uninstall your GPU Driver in Windows Safe Mode using Display Driver Uninstaller & then reinstall a new freshly downloaded driver once you boot back into Windows normally (you can download it before going into Safe Mode).

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.