Log in to reply

Add-On Plane Causing Crash - HELP!

  • SkylineGTRFreak released his latest Blue Angels F/A-18C Hornet which is awesome. Tried adding it to my /planes/ add-on pack and the game crashes on load.

    I have many add-on planes from the same modder as well as other ones and everything works fine - adding this plane alone causes it to crash.

    Here's the dlc.rpf file so if anyone can take a look and let me know why it's crashing, I'd appreciate it - https://drive.google.com/file/d/15TmBm8PCBBVsY9ylQGqbvA0bym0kF2T_/view?usp=sharing

    I removed this plane and everything works perfectly fine so it's definitely something in this mod that's causing it.

    Please help! Thanks in advance.

  • BUMP - anyone?

  • Same for me, since a few days, I am limited to 5 addons maximum. The 6th crashes my game. I don't understand why.
    For example, if I want a new mod (car) I have to replace it with an old one.

    Same problem with Gameconfig Limitless Vehicles V27, Heapadjuster, Packfile-limit-adjuster installed...

  • @Suzerain001 said in Add-On Plane Causing Crash - HELP!:

    adding this plane alone causes it to crash

    Does the default 'demohornet' add-on crash your game?

    I tested the default F/A-18C Hornet Blue Angels US Navy Display Team 2.0 download & it works no problem for me (no crash at least, but there's no afterburner vfx (one other person in the mod comments has the same issue. Been a while since I installed a new jet, but all my other ones have afterburners working no probs)):

    F/A-18C Hornet Blue Angels US Navy Display Team 2.0

  • @a63nt-5m1th Default add-on works fine so it's definitely something in that pack. I didn't change anything in the pack - the modkit has the name 'fa18c' when the actual modkit name is 'hornet_mods.rpf.' I tried keeping it at fa18c but that didn't work either.

  • @Suzerain001
    The 'dlc.rpf' you linked to works perfectly fine for me, but I suspect that's because it doesn't even contain the Blue Angels F/A-18C Hornet?!


  • @a63nt-5m1th haha you're right! Brain-fart moment right there. Here's the updated one - https://drive.google.com/file/d/1HVtxzMmRDZxsHbUECvbuX3iobj6WuH5P/view?usp=sharing

    Please let me know. Thanks.

  • @Suzerain001
    Remove these lines from your planes 'content.xml' :thumbsup:


    		<overlay value="false"/>
    		<disabled value="true"/>
    		<persistent value="false"/>



    & delete the 'demohornet_vehiclelayouts.meta' file from 'data/ai' as well obvs. :thumbsup:

    Deleting the 'demohornet_vehiclelayouts.meta' isn't vital, but it's unused, so no point keeping it. Basically, although it existed (as 'vehiclelayouts.meta') in the original F/A-18C Hornet Blue Angels dlc it was commented out in that 'content.xml' & not used/loaded as the 'demohornet' uses 'LAYOUT_PLANE_MAMMATUS'.

    Presumably it was conflicting with something else, or the game just didn't know what to do with it etc.

  • @a63nt-5m1th man you are amazing! That was it - removed the demohornet_vehiclelayouts.meta file from the content.xml file and deleted the file from the dlc.rpf and BAM, it works!

    On that note, I'm wondering if my issue with the polcars1 add-on pack (the other thread I made) where it works fine on the Win 10 rig with NVE but not on the Win 11 rig with QuantV are the various vehiclelayouts.meta files?

    These are the vehiclelayouts.meta files I have in that RPF:


    Should I just delete all of them or...? I can respond in that thread again but wanted to ask since you helped me fix this issue with the hornet plane.

    Thanks again.

    EDIT: Just tried commenting out all the vehiclelayouts.meta files and it still crashes. :(

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.