Log in to reply

Some train mods are not working

  • I am currently trying to use https://www.gta5-mods.com/vehicles/brown-streak-add-on
    along with https://www.gta5-mods.com/maps/stations-of-san-andreas-add-on but neither are working. It still spawns only the normal freight train and does not stop at the stations. I tried removing railway engineer with no luck and I have made sure that I have installed everything properly. Please help me

  • @AUSSIE_LAD_96
    Those mods likely don't work because a default 'trains.xml' file (or a different modded one etc) likely exists here:

    ...\Grand Theft Auto V\mods\update\ update.rpf \common\data\levels\gta5\trains.xml

    & is overriding the Brown Streak etc one installed to 'common.rpf'.

    If there is no 'trains.xml' in the above location, then I'm not sure (I've never installed any trains), but place the file there anyway, as it will make sure it overrides any other you may have installed in your game. If a 'trains.xml' file does exist in that location, overwrite it with the Brown Streak etc modded one & see what you get. Hope it works :thumbsup:

  • @a63nt-5m1th I deleted those files then installed the modded ones I think it might be a script causing the trains not to stop as when I removed scripthook they would stop

  • @AUSSIE_LAD_96
    You probably figured this out on your own, but try scripthook with no other scripts installed & then reinstall the scripts one at a time until you figure out which one it is etc.

  • @a63nt-5m1th I know there is defiantly something wrong with my scriphook.net mods. I can't work out what it might be but it's causing other scripts even ones not .net to not work e.g I am supposed to have not supposed to have any game music as it's all supposed to be mute but the music plays anyways. I uninstalled through steam yesterday to try and clear and work it out with no luck I think I might have to just start fresh completely maybe

  • @AUSSIE_LAD_96
    Worth running System File Checker (make sure Windows system files are good), CheckDisk (make sure hard disk file system is good) & DISM (make sure Windows image is good), before reinstalling anything,

    If you're thinking about starting fresh, you have nothing to lose, you might as well play around with the scripts you have installed & see what you can figure out. Scripts are generally '.asi's installed in the main Grand Theft Auto V root folder (where 'GTA5.exe' is) or '.dll's installed in the 'Grand Theft Auto V/scripts' folder.

    First test would be renaming the 'scripts' folder to something else temporarily ('scripts - [RENAMED]' etc) & loading the game to see if the issue persists. If that fixes it, you know it's something to do with a script in there. Then, search you main Grand Theft Auto V root folder for '.asi' mods & back them up in a '.zip/.rar/.7z' & then either, delete them or move them somewhere else on you PC & then test load the game & check the results.

    As a further test you also might want to rename you 'mods' folder temporarily & try loading the game vanilla, but with your scripts installed/still active. See if you get the same outcome or not etc.

    You can do a preliminary test where you do all of the above together, just to confirm whether any of it will fix/change anything. Then put each part back one by one, while test loading the game between each change, until you figure out where the issue exists.

  • @a63nt-5m1th I know am certain it's not a scripts issue but I'll run a file check anyways thank you

  • @a63nt-5m1th still no luck sadly

  • @AUSSIE_LAD_96
    I'm a little confused, your info seems a little contradictory. :thinking:

    • If you remove Scripthook, do the trains stop at the stations or not?
    • Also, is the Brown Streak working or is it still broken?

    I need to know exactly what the situation is now & whether it has changed or not?
    How did you come to the conclusion that it was Scripthook related & then how did you become certain that it isn't script related?


    • What is the situation now?
    • Has anything changed? (like does Brown Streak work now? etc. So I know exactly what it is I'm diagnosing)
    • What did you do to test things & draw the conclusions you came to? (scripthook/not scripthook/other scripts broken etc)
    • & what were the steps you took & the results of each thing (including any others) you have tested?

    That's what I need to know. Don't spare the keyboard, give me all the info you have :thumbsup:

  • @a63nt-5m1th I have given up on brownsteak but am now trying to use Kitsune Trains instead. I'm seeing some of the train engines that are supposed to be on the normal tracks spawn stationary on reserve tracks instead and I know I could not have possibly gotten anything wrong here because pretty much all files can be installed automatically except maybe one or 2 that are just drag and drop. The default freight train also spawns with 1 locomotive and 2 flat flat carriages It also comes with it's own stations that it doesn't stop at. When I removed scripthook before the trains would stop at stations randomly but I haven't tried it again with this mod Kitsune Trains. I am convinced there's something wrong with OIV as I have also tried to replace some tattoo files with scars only for the normal tattoos to show. Some how some files are not being replaced properly even when deleting them then installing the modded version and I have currently nothing else installed in my mods folder other then Kitsune Trains. My oIV version is 4.1 and I do believe that is the most up to date version. Thank you for taking the time and trying help me. It is appreciated even though there's been no breakthrough yet

  • @a63nt-5m1th Add on train mods are now working! Turns out in the tuners update R* moved some files around so the train.xml that needed changing was somewhere different then the instructions being given

  • @AUSSIE_LAD_96
    I'm presuming it needed to be installed in 'update.rpf' instead of 'common.rpf'? (just in case I help anyone else out with the same issue in future etc)

    It's a good rule of thumb anyway. When you're installing a mod & it doesn't fully work etc, use Ctrl+F3 in OpenIV to search for the files it installs & make sure no others exist that might be overriding the one/s installed by the mod. Especially for older mods (pre latest update etc).

    So is that you completely fixed? :fingers_crossed:

  • @a63nt-5m1th Handy to know thank you

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.