Log in to reply

Converting ydd to ydr

  • So I have a nice ring but unofortunately it's made for MP female only. Problem is, I'm not playing with MP female characters, but rather would like to use addon peds.

    And since the ring model made for MP female ped only in .ydd extension, I can't spawn it in anywhere else.

    What I would like to ask is, can anyone convert this .ydd model to .ydr model so I can just spawn it with Menyoo as an in game object and attach it to the ped's hand <3

  • @Aurora11
    A '.ydd' is essentially just a dictionary container for '.ydr' files, so try this:

    • In OpenIV, export the '.ydd' to openformats (right-click > 'Export to openFormats (.odd)')
    • Open the resultant folder
    • In there you should find another folder & a '.odr' file
    • Drag & drop the '.odr' into OpenIV & a '.ydr' should be created

    Not sure exactly how Menyoo works with '.ydr's & whether you need to create a '.ytyp' entry for that new '.ydr' to spawn it in game or if Menyoo handles that automatically etc :thinking:, but if the '.ydr' doesn't spawn, create a '.ytyp' entry for it & see if it works then.

    I figure you probably already know this, but if you don't have your own method, mmYtypTool should help with '.ytyp' creation. :thumbsup:
    It's pretty easy to use, start it, select GTA5.exe (automatically prompts you to do so), import a '.ydr' (in 'File' tab), give the '.ytyp' a name (tick 'Edit mode' (top right) to do so) & then save it somewhere. If you install the '.ydr' to a folder already containing other '.ydr's & a '.ytyp' for them, you can open your newly created '.ytyp' in OpenIV & copy the relevant data block & paste it into that already existing '.ytyp' & do it that way as well.

  • @a63nt-5m1th Lol :sweat_smile: BIG LOL :rofl: :rofl: It works hahaha!! :D

    I can't thank you enough for this, finally I can equip diving gear on my addon peds too haha :D


    By the by @a63nt-5m1th , I wanna ask a last question if I may.

    Sometimes the umm, stuff being like awkward.
    Like from the first angle the diving suit is visible but from second angle it's looking invisible :thinking:

    (I promise the diving gear didn't get bitten by vampires :rofl: )

    Also I tinkered with addon stuff a bit and some works normal some not, some are always invisible.
    Like this sunglasses is fully working, even the transparency lol: https://i.imgur.com/ptI86UV.png
    This one has a weird awkward texture on it: https://i.imgur.com/JTg8j6a.jpg - https://i.imgur.com/urhKbTy.jpg
    Also forgot to take photo but tried a necklace and it wasn't visible at all :thinking:

    Do you have a guess how can I fix this? I mean like are these problems caused by 1 particular thingy that's having different results or do they all have to be fixed individually?

    Of course I'm not gonna even ask if they individually need some care but if it's a common reason I can give a shot to fixing it :yum: :icecream:

  • @Aurora11
    Not sure, there's a lot of variables going on there :thinking:. Do they display correctly 360° as standard props? Like, if just placed into the GTA V world with a '.ymap'/Map Editor/Menyoo etc. ie Is it the act of attaching them in menyoo that breaks them? Do you remove the collisions from objects before attaching them to peds? There's an option in Menyoo for that somewhere I think. I have no knowledge of Menyoo, but I read not doing that can cause some objects to "spaz out" sometimes.

    For the invisible/invisible from certain angles objects, usually the first thing to check is whether the bbMin/bbMax (bb = Bounding Box) values are wrong/too small for the object, or maybe the smoothing groups need redone in 3DS MAX (both those things can cause objects to turn invisible/flicker/not display from certain angles at times).

    Sunglasses look a little like the were designed & only ever intended to be used in a certain place/situation. Like in a static scene where the observer always views the object/s from a similar angle & you just texture the reflections onto the object rather than get shaders to do it in real-time etc.

    They should certainly all be fixable, but I reckon you would probably need 3DS MAX to have any kind of good go at getting it done. You could package up some, especially ones that have working equivalents, like the sunglasses etc, but any others as well & upload them somewhere & share the link (or give me a list & point me to a download location etc) & I'll download them & take a look if you want? You never know, might figure something out, I'm happy to look at them anyway :thumbsup:

  • @a63nt-5m1th Oh sure, thank you so so so much lovely friend :blush: :sparkling_heart:


    These are the ones. For the sunglasses I feel your conclusion is accurate. Because when I look at it at .ydr , the glass part is weird. The other sunglasses that works fine, it's glass part looks transparent glass with a subtle purple-ish tint, like the texture. But this one is fully black.

    I should mention though I'm not in hurry at all with these, the scuba doesn't really bother me at all anyway since it's just 1 very spesific angle, for sunglasses I found one with almost identical shape but just a tiny little bit smaller which I started feeling like it looks a bit better anyway and the necklace, well I guess since it has bracelets, earrings and such attached to it as well, probably it needs to read skeleton yft file but since it's no longer being present it's not reading it and perhaps that's why it doesn't show up. Most probably a single necklace can work fine <3 (I tried one just to check and it was worked :yum: )

  • @Aurora11
    I couldn't get Menyoo to spawn any objects/props (so I could test attaching them etc), but the edited sunglasses & scuba spawned fine with ENT. They look ok to me, but no promises lol.

    Sunglasses are probably fine/fixed, not so sure about scuba gear, I only really imported that > did smoothing groups > exported, no other changes (might have fixed something, or made it worse lol, can't really check).
    You can get the sunglasses & scuba in this '.rar' here. I embedded the textures in the '.ydr's, so no need for the '.ytd' textures anymore & so if you want to edit the colour/transparency of the sunglass lenses for example, just export them to openFormats & edit the 'sg_glass' texture.

    Don't know what is going on with the necklace, just always seems to be invisible in-game, even breaking it down in 3DS MAX & spawning the simplest parts of it as a single object in-game, they were invisible. Just couldn't get it to appear, which is unusual :thinking: (I'm no 3DS MAX expert, but that's never happened before).

    I noticed in your 'def_addonaccessories.ytyp' the bbMin/bbMax x, y & z are all 0.00000000

          <bbMin x="0.00000000" y="0.00000000" z="0.00000000"/>
          <bbMax x="0.00000000" y="0.00000000" z="0.00000000"/>

    I figured you just skipped that part for the upload, but if all your add-on props are like that, it may well cause some viewing angle problems. As mentioned tho, I've never used Menyoo before, so if it handles bounding boxes automatically or something, it's probably nothing to worry about etc.
    Like, if most things have been displaying fine up till now, it's probably not that big an issue, but might be worth looking at for select problem props, like the scuba, if it still does it. :thumbsup:

  • @a63nt-5m1th Oh yup these are working perfectly :blush: :see_no_evil: Thank you so so so much :)))

    I will check that bbMin/Max values. Actually I was made that ytyp while looking at another mod's ytyp. Will load it on codewalker and gonna do calculate bb values. Thank you so so much for pointing out that as well :sparkling_heart: :yum:

    Edit: Nevermind I used the ytyp tool you suggested, it works amazing :yum: :yum: Thank you so so much for that as well :rose:

  • @Aurora11
    Nice, glad they worked :slight_smile: :thumbsup:, wasn't 100% sure they would lol (pretty sure tho :thumbsup:).
    Try this necklace.ydr, I separated it from the earings & bangles etc. I'm less confident of it working 100%, never messed with ped related things in 3DS MAX before & something funny going on with my ability to spawn props, so can't test it in-game :rolling_eyes: , but might work, should work :fingers_crossed: (just would like to be able to confirm that before uploading it lol. Yeah, I'm looking at you GTA V, the only game I've ever modded with an intermittent multiple personality disorder :stuck_out_tongue_closed_eyes:).

    You may have sussed this out already, but for the mmYtypTool, if you add a second prop using the 'Import Ydr file' dialog & then choose not to replace previous ones in the popup that appears, it will add it to the '.ytyp' as a separate prop. You do that to add multiple props into the same '.ytyp' & then save it with all of them in it etc. :thumbsup:

  • @a63nt-5m1th I tried but it still didn't work :( Still showing invisible. I guess there is something funky going on with some objects. Also I was downloaded a handbag mod as well and that one also looked invisible. But another handbag mod for example working perfectly. Although I had to include the diffuse texture of it inside the .ydr instead of making it external as .ytd file.

    From what you did with scuba gear as well and this handbag thingy, I think it's safe to assume it is always better to include diffuse inside .ydr :thumbsup:

    Oh and yeah, that replacing the prop was kinda a bit confusing :D At first I was thought the import ydr option only for creating a ytyp with just 1 object and was tinkering with manually adding an archetype haha :rofl:

    By the by, I umm, going outside the topic a little bit and don't really want to keep bombarding you with questions, so I just wanna ask 1 last thing if I may :(
    Can the center of an object be changed by editing the .ydr / .ytyp ? Because I have this ring which looks lovely but it's center is quite away from it, so while I'm rotating it, it's turned around a center that is far away from the ring instead of turning it's own X,Y,Z axis :(
    Like this;

    alt text

    I normally wouldn't mind it much but the only problem is, when I attach an object to a ped, X, Y, Z, Pitch, Roll and Yaw settings acting differently. Like for example with Manual Placement Z value moving the object up&down but in the Attachment menu Z value moving it left&right. I mean of course the movement not too concerning, which I kinda got used to it anyway and can keep moving it slowly to place at the desired position, but the Pitch, Roll and Yaw is going totally haywire :/ (especially the Yaw :( ).

    If the center is properly placed, I think Roll option works as Yaw (if I remember correctly) but since the center is proper it's easy to set the object's desired angle. But if the center is away, huh boi .. I literally spent around 20 minutes to properly set this ring's angle lol :rofl: :rofl:

    I have taken the liberty of just uploading the ring as well, just in case if you would be curious enough to take a look and have absolutely free time you want to get yourself away from the boredom of the world :sweat_smile: :sweat_smile: :rofl:

  • @Aurora11
    For the scuba gear, I think the thing that fixed it was re-doing the smoothing groups on it in 3DS MAX, but it may well have just been the import & export that fixed it.
    There's really no major disadvantage to adding the textures to the '.ydr' as far as the game is concerned (for most props anyway, ped clothing or other things might be different, not 100% sure), & it's less work, not having to deal with any '.ytd's if dealing with a lot of props etc having them all self-contained etc.

    Cool :slight_smile:, was gonna ask you to send it over, try this one & see what you get :thumbsup:

    As to centering an object, the only easy way I know is opening it in 3DS MAX & moving the object/changing the pivot etc in there. Technically, it could be done in a '.ydr.xml', but knowing what value/s to edit in the '<Geometries>' section of the file would be a bit of a nightmare I suspect.

    It's dead easy to do in 3DS MAX. As long as the Heart Ring test worked ofc (?). If you don't find another way, you can always send select items over to me & I'll sort out the pivot for you. It's quick to do, just takes an import/export & a few seconds in 3DS MAX. Happy to do it :slight_smile: :thumbsup:

  • Thank you so so much @a63nt-5m1th . I checked the ring though however, it's center still away from the ring :( It's spawned angle changed however, it spawns upright instead of horizontal, however still turning around a pivot away from the ring :(

    I recorded video how it's behaving; https://streamable.com/pmve4f

    Also I noticed a big shadow and it's being invisible when I move close to it with camera :( There might be something wrong with the original model perhaps I'm not sure :thinking:
    I uploaded the mod at it's original .ydd state just in case maybe you wish to look, like I said maybe the object's done wrong in some way.

    This is how it's normally behaving by the by (the one with pivot points not changed); https://streamable.com/6ah1e7

    But for example the Scuba Gear thingy is perfect. https://streamable.com/c32f8s Turning around it's own axis. It's pivot point is at the center of it.

  • @Aurora11
    No probs, this one should work :thumbsup:
    Thought I checked the origin/center in OpenIV's Model Viewer, but I can't have, that new one^ is aligned to the world origin/center & shows up that way in OpenIV (previous doesn't/didn't etc). Should work, but if not, just let me know & I'll try something else, need to learn this stuff in detail anyway :thumbsup:

    If it does work, or partly/viewing issues etc, you probably want to re-do the bbmin/max for it (smaller/different center etc).

  • @a63nt-5m1th I have tried the new one, it is the pivot and center point fixed, turning as same as the scuba gear :sparkling_heart: Also the weird shadow is gone too <3 For some reason though still disappearing at certain angles and distances. I guess it's more related to the angle though because when I move the camera very close and then turn the camera to upwards it appears. But whenever I move it down a little bit it disappears :(

    I wonder is it a problem on my end though :thinking: I have also a necklace mod as well acting same too. but another necklace working fine so I'm not being able to sure either :/


    The one with red color is just the old unedited one (same as aqua colored one but with just a different color). I spawned that one for a comparison purpose.


    I also tried disabling collision and gravity with Menyoo but still disappearing :(

  • @Aurora11
    Try this one, think it's my fault, or at least this time I remembered to also re-do the smoothing groups & that should hopefully fix the viewing issues :fingers_crossed:
    Glad the centering worked :slight_smile:, now I just need to remember what I did there exactly?! :thinking: lol (nah, I'm sure I can repeat it :thumbsup:)

  • @a63nt-5m1th I just checked but the disappearing still happening :( Although I noticed something interesting.

    The ring only disappears while looking at the back side of it. Lemme show you;


    So when I saw this in the mmytyp tool I selected Double Side Rendering flag hoping it would make it work but for some reason it's still disappearing at one side :thinking:

  • @Aurora11
    Thought I had my ped prop spawning issue fixed, but no :unamused:, it's just completely random as to whether any of the AddonAccessories props spawn or not when I try. Mostly not, but every so often they will work (they either all work, or they all don't). No idea what's going on, I don't have any issues spawning any vanilla props.
    I need to fix that first anyway, whatever it is, & be able to reliably see what I've created in-game.

    I checked the last 'HeartRingAqua.ydr' I gave you & it displayed 100% correctly from all angles for me, but I did hit an OpenIV error trying to export it to openFormats, so I reckon the file is funky & will re-do it once I fix the spawning issue etc :thumbsup:

  • @a63nt-5m1th Yeah, I guess there is something wrong with the file itself :cry:

    I tried it on stock gta now but for some reason it still disappeared while looking at the other side :(

  • @Aurora11
    I took a random vanilla necklace, renamed it & added it to AddonAccessories as a new prop & it spawns no problem everytime I load the game. The other props tho (scuba, necklace, heartringaqua, sunglasses) nearly always fail, like 99% of the time.

    Is there a way to get a hold of the original props, ie where you downloaded them from, so I can see if they have the same issue etc?

  • @a63nt-5m1th That's so strange :thinking: The scuba wasn't even a mod. I was just copied it from the vanilla gta :thinking:
    From x64v.rpf\models\cdimages\streamedpeds_players.rpf\player_two\accs_005_u.ydd
    It's the Franklin's scuba gear :/

    This is the link I downloaded the ring though.

    Also using this crown;
    and this necklace;

    Though their pivots are set properly so I didn't have any problem with rotating them.

    Edit: By the by I checked it in CodeWalker and it's also disappearing there too :thinking: So strange :/

    Looks normal from this side

    alt text

    but when I rotate the other side it disappears :thinking:

    alt text

  • @Aurora11
    Not sure what was going on with AddonAccessories, but I rebuilt it manually from scratch (same files, just all new 'dlc.rpf/addonaccessories.rpf' etc) & that seems to have fixed it. Can spawn everything reliably & repeatably now :thumbsup:.

    Try this 'heartringaqua.ydr', it appears fine in my game from all angles & no export to openFormats error/s or any other issues I can see. :thumbsup:


    'necklace' remains invisible :unamused:...

    ... :tools: :boom: :book: :hammer_pick:... :bulb: ... some time later...

    :D (ingame screenshot)


    You can get that 'necklace.ydr' here & test it out. :thumbsup:

    Looks like the invisible issue was shader related. Something to do with it's use of the 'ped_hair_cutout_alpha' shader. Once I removed that parameter & replaced it with a simple standard 'ped' one, it started appearing in-game.

    This is the 'def_addonaccessories.ytyp' I'm using by the by:


    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
        <Item type="CBaseArchetypeDef">
          <lodDist value="60.00000000"/>
          <flags value="32"/>
          <specialAttribute value="0"/>
          <bbMin x="-0.01081190" y="-0.00358240" z="-0.01232980"/>
          <bbMax x="0.01138150" y="0.00898440" z="0.01262020"/>
          <bsCentre x="0.00028480" y="0.00270100" z="0.00014520"/>
          <bsRadius value="0.01783940"/>
          <hdTextureDist value="60.00000000"/>
        <Item type="CBaseArchetypeDef">
          <lodDist value="60.00000000"/>
          <flags value="32"/>
          <specialAttribute value="0"/>
          <bbMin x="-0.06069340" y="-0.04159160" z="-0.18229620"/>
          <bbMax x="0.05765270" y="0.06364360" z="0.14746650"/>
          <bsCentre x="-0.00152040" y="0.01102600" z="-0.01741480"/>
          <bsRadius value="0.18291000"/>
          <hdTextureDist value="60.00000000"/>
        <Item type="CBaseArchetypeDef">
          <lodDist value="60.00000000"/>
          <flags value="32"/>
          <specialAttribute value="0"/>
          <bbMin x="-0.23730470" y="-0.20751950" z="0.01464840"/>
          <bbMax x="0.20166020" y="0.36669920" z="0.72021480"/>
          <bsCentre x="-0.01782220" y="0.07958980" z="0.36743160"/>
          <bsRadius value="0.50503500"/>
          <hdTextureDist value="60.00000000"/>
        <Item type="CBaseArchetypeDef">
          <lodDist value="60.00000000"/>
          <flags value="32"/>
          <specialAttribute value="0"/>
          <bbMin x="-0.06312269" y="-0.08009700" z="-0.02826220"/>
          <bbMax x="0.06813559" y="0.07433930" z="0.02539470"/>
          <bsCentre x="0.00250640" y="-0.00287880" z="-0.00143370"/>
          <bsRadius value="0.10483100"/>
          <hdTextureDist value="60.00000000"/>

    & here is the rebuilt AddonAccessories 'dlc.rpf', just in case it gets to that point diagnostically, & you want to see if the props in that one spawn correctly for you etc :thumbsup:

  • @a63nt-5m1th Wow these all worked so so amazing :see_no_evil: :see_no_evil: :sparkles: Thank you so so so much @a63nt-5m1th you are truly so amazing :blush: :sparkling_heart:

    and very sorry if I bothered you too long :(

    I tried to recreate the issue I was having, that partially invisible thingy, but I couldn't manage to do it. Not sure why exactly it happened, I guess it's gta acting up again and something went wrong in somewhere :/ :thinking:
    At least though you managed to fix it and your dlc.rpf along with all the accessories you fixed working amazing now :blush: :blush: Thank you so so deeply much <3

  • @Aurora11
    Awesome :slight_smile: :thumbsup:.

    No worries on the timescale, modding be like that sometimes. Especially when you get, in typical GTA V fashion, multiple issues all appearing at once. Glad they all worked tho, got there in the end.

    Any other prop issues, send them over, doesn't take long to fix anything similar in 3DS MAX, & now I can test them before I send them back. Less trial & error etc. :thumbsup:

  • Thank you so so much @a63nt-5m1th :blush: :rose:

    I was now just attaching the new ring to my character, but wanted to leave the old ring so that I can position the new one on the almost exact position. Once I positioned it, I noticed a difference between those two.

    For some reason the new ring looking a bit less colorful :thinking: Tried it with other color options but they also acting same as well.

    alt text

    The one on the left is the new one, and the right is the old one.

    Also awkward enough, when I make my character invisible, they get more colorful :thinking: :thinking: ......

    alt text

    Tried it with another character just to be sure and that one did the same as well.

    Also I noticed tiny little black dots on the ring's frame (I think that's how it's called. That circular part I mean)

    alt text

    Is there a possibility the shader on the ring like somehow connected to the pivot point? Like umm, manipulating light direction?

  • @Aurora11
    I'll take a look at it & try some other shaders or shader parameters on it :thumbsup:.

  • @a63nt-5m1th Thank you so so much. It honestly felt weird to me it looked that way. I mean if it was necklace, I would say yeah that's normal since the shader is changed but with the ring only the pivot point is changed :thinking: I will check the 2nd ring you were uploaded though, since you figured out the disappearance was causing because of the dlc.rpf itself, maybe that 2nd one you uploaded won't have this problem <3

    Edit: I checked the 2nd and 3rd rings you uploaded by the by. Their surface looks different than the last one and turning player character to invisible effecting it differently. I'm feeling it's something to do with shadow, like the shadow being casted on the ring causing some awkward look on it I think :thinking:

    These 2 I tried with 2nd and 3rd upload (they both looked same)

    alt text
    alt text

    and these with the last one. (Wanted to take screenshots of it at the same position too)

    alt text
    alt text

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.