Log in to reply

Retail Version of GTAV (DVD Discs) Can you play the game after replacing updated files with older version files?

  • Hi, as the title reads: Can you actually start the game after replacing the updated files with older backup files? In my case the game immediately detects it and initiates the update procedure, so back to square one... Is this method only working with the Steam version of the game? Thanks

  • @S9v9F

    Try this.

    1. Download this free utility or if you prefer create a firewall rule to block these files.
    2. From the utility, do a right click on GTAVLauncher.exe and select Block Internet Access. I would do the same for GTA5.exe

    This should hopefully stop the updates - but I'm on Steam, not DVD, nor EPGS.

    I can certify that blocking GTA5.exe removes all the online ads and allows SP mode.

  • Thanks for your reply, I appreciate it. Unfortunately it doesn't work, I created outbound rules for the gtavlauncher.exe gta5.exe and playgtav.exe and no luck. I tried creating inbound rules for the same files just in case, but still no luck... The launcher acts as if no rules are created in the firewall at all.

    Btw, when I was using launcherbypass I remember creating those rules too as a "double layer of security" but it seems like the launcherbypass was actually doing the job of preventing updates. It seems like I will have to rebuy the game in Steam...

  • @S9v9F Just curious since you blocked the .exes in windows firewall rather than the utility which is what i use - did you see ads for GTA online when the game loads?
    If you did see ads for GTAO then your rule is not properly set. You shouldn't see any ads while the game is loading if properly blocked.

    The big advantage of the utility is you can block or unblock so easily and so quickly.

  • I didn't even try loading the game because the launcher immediately detects the backdated files and initiates the update procedure and reverts back to the latest 2612.1 build. I also cannot start the game with the gta5.exe file like I used to do back when the launcherbypass mod worked.

    I will try the utility you recommended and report back.

  • Tried loading the game to check for ads and I don't see any, so I assume that the rules are properly set.

  • @S9v9F Agreed, it is being blocked. Have you tried blocking the rockstar files in the installer folder and even disabling internet completely?

  • @JohnFromGWN Sorry for the late reply. Downloaded the block utility but no luck. Launcher completely "ignores" it. Not sure what files are you referring to specifically from the installer folder.

    As for disabling my internet connection, that was the first thing I actually tried but it didn't work. I used to do that 4 or 5 years ago, but even then it'd let me play offline for like 5-6 times then force me go online.

  • @S9v9F would be good to know why the steam process is different. Do they stop nagging by design? And how do the others know they need to update, do they check the executable, is there a flag in the registry, or an xml file with the status?

    What confuses me is when you say the launcher ignores the utility or firewall rule, that seems to indicate there are other files, other processes in play.

    One other possibility is to block the rockstar domain from the host file. Would need the address.

  • @S9v9F just found this thread, one member posted an address that could be used for host, no idea where he got the address however or if it worked.

    hostname prod.cloud.rockstargames.com

  • @JohnFromGWN Hey John, thanks for replying and trying to help, I appreciate it. Could you please explain what you mean by "blocking the rockstar files in the installer folder"? Sorry for my ignorance...

  • @S9v9F In my Steam version, there is a folder called Installers, which has Rockstar-Games-Launcher.exe.

  • @JohnFromGWN Ah ok, thanks for clarifying. Got to now, but I'll try tomorrow a few things and report back.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.