Log in to reply

Attack of the 'Kernel Error'....

  • Needless to say, I have had nothing but problems with the 'Contract' dlc. Other than the usual broken mods and waits for updates, even after I got all that cleared up a fresh updated config and so on I play a good 5-10 minutes and while driving the game stutters and then craps itself. I've verified files and checked all the mod logs and it's GTAV kicking out the old 'Kernel Error'. I've looked online for solutions but no one has a proper fix for this. Here's the error message:

    Faulting application name: GTA5.exe, version: 1.0.2612.1, time stamp: 0x625d7853
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.24441, time stamp: 0x5cb935a7
    Exception code: 0xc0000005
    Fault offset: 0x0000000000001b44
    Faulting process id: 0x1cb4
    Faulting application start time: 0x01d8648bfcabe753
    Faulting application path: D:\Grand Theft Auto V\GTA5.exe
    Faulting module path: C:\Windows\system32\KERNELBASE.dll
    Report Id: 326fc7c5-d082-11ec-ac25-d8cb8a8324f7
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2022-05-10T16:56:56.000000000Z" />
    <Security />
    <Data>D:\Grand Theft Auto V\GTA5.exe</Data>

    Anyone got an idea of how to fix this properly I'm all ears....

  • @iammistahwolf
    Not aware of a specific fix for GTA V 'kernelbase.dll' crashes, but here's a list of general troubleshooting to run through:

    Script Hook V:

    • Make sure your game is fully updated & you are using the newest version of Script Hook V.

    Display Driver Uninstaller (DDU):

    • Try a DDU (Display Driver Uninstaller) reinstall of your GPU drivers (uninstall in Windows Safe Mode, & then back in normal Windows reinstall the latest driver from a fresh download) to eliminate any driver issues.

    Let the game generate a new 'settings.xml':

    • Backup your 'settings.xml' in:

    /Users/YOUR_USERNAME_HERE/Documents/Rockstar Games/GTA V/settings. xml

    • & then delete it (a new one will be created on game load)
    • Set your settings again in-game, or open your backup 'settings.xml' & use it as a guide to edit the newly generated one.

    GTA V Save File Issues:

    • Try using some older saves & see if the issue persists.
    • start a new game, save as soon as you can after the first mission & test that save.

    Create new 'pc_settings.bin' & 'cfg.dat' files:

    • Search your C: (OS Install) drive for 'pc_settings.bin' & 'cfg.dat' (they should both be in the same Rockstar/Socialclub etc related folder together). Make a backup of them & then delete/move them (new ones will be created next time you start the game).


    • Remove/Rename your 'scripts' folder.
    • If that fixes it, create a new 'scripts' folder & use a process of elimination by adding in one script at a time to figure out which one is causing the crash.

    Could be 'gameconfig.xml' related:

    • Try this one or this one if not already.
    • Also install any prerequisites either of them require (like heapadjuster & packfile-limit-adjuster etc. They will be mentioned in Description tab if required/recommended).

    'mods' folder:

    • Does the 'kernelbase.dll' crash happen if you rename your 'mods' folder temporarily & test play the game?
    • If no crash running vanilla files, have a look at diagnosing your 'mods' folder using the 'Investigative 'mods' Folder Rebuild Process Instructions:' section in this post.


    • Remove any/all overclocks you may have.
    • Also, leave them removed for now while you do any other testing.

    Check Disk:

    Run check disk on all your hard drives.

    Re-register 'kernelbase.dll':

    • Hit the Windows Logo Key & type 'cmd'.
      Windows Logo Key
    • Right-click on Command Prompt ('cmd.exe') and select Run as administrator.
    • Type/copy & paste the following command and press Enter:

    regsvr32 KERNELBASE.dll

    • Once it completes, Restart your computer.

    Run a System File Scan:

    • Using the same process as above to access the Command Prompt
    • Type/copy & paste the following command and press Enter:

    SFC /scannow

    • Once it completes, Restart your computer.

    If you encounter any issues running a System File Scan or repairing corrupt files, run DISM RestoreHealth command:

    • Start Command Prompt as an administrator in the same way as above.
    • Type/copy & paste the following command and press Enter:

    DISM /Online /Cleanup-Image /RestoreHealth

    • Once it completes, Restart your computer.
    • Run System File Scan again after Restart.

    Create a new Windows Local Administrator User Account & see if issue persists:

    • If creating a new Local Administrator Windows Account (ie a new user with Administrator privileges) on your machine fixes the issue, your original Windows User Profile is likely corrupt/damaged.
    • Some options & instructions here, but it's worth doing your own research by searching the internet for 'how to fix a corrupted windows user profile in windows 10' etc, so that you are aware of all of your options & can pick the one/s that suit your situation best.
      Some options, like Window's 'Reset this PC' will result in you having to reinstall all your programs, so worth doing your research on each option & knowing what you are getting into before trying any of them. :thumbsup:

  • a63nt-5m1th - Many, many praises good Sir/Ma'am! This is the kind of help I was hoping for!!!! Whether any of this works or not, you are a gentle person and a scholar, may you be blessed with many sheep and cattle!

    Seriously, thanks. I'll get cracking on the stuff you've put out that I haven't tried.

  • @iammistahwolf
    No probs, hope something there works :thumbsup:

    If it doesn't, or you run into issues with the System File Scan & DISM RestoreHealth commands both failing to complete etc, it's worth knowing that you can reinstall Windows while also keeping all your personal files & apps by using an in-place upgrade/repair install :thumbsup:

    It's often the quickest fix for Windows related issues, & fixes most issues 99.9999% of the time (has always worked for me everytime I've used it over the last ~13 years (Windows 7/10), 100% success rate, even keeping licenses/subscriptions for apps active, but you'll see in the comments at the bottom of that linked page people that allege it didn't fix their issue. Either way, it's better to try an in-place upgrade/repair install before a 'full wipe lose everything you haven't backed-up' install if you get to a point where you are ready to reinstall Windows :thumbsup:)

    By 'personal files', it means only your personal files stored within your windows account username folder/s within 'C:\Users' (or whatever drive letter your OS install is using). Any other 'personal files' stored in locations outwith your user account folder/s will need to be backed up or placed within that folder before using the in-place upgrade/repair install if you want to keep them.

    Also, added:

    'Display Driver Uninstaller (DDU)'
    'Let the game generate a new 'settings.xml'
    'GTA V Save File Issues:'
    'Create new 'pc_settings.bin' & 'cfg.dat' files:'

    sections to previous post. Try them before you move to any Windows reinstall etc. :thumbsup:

  • @a63nt-5m1th Not to be confused with Attack of Kernel Sanders, attributable to poor quality fast food chicken.

  • So, I've been following the suggestions and so far the 'Kernel' is still causing problems. I haven't tried the SFS & DISM commands yet (though I have used SFS before). One thing I have found during my tests is mundane props all around the game map are 'doubled'. You see it first if you spawn inside Franklin's upgraded house as the lawn chairs immediately outside the bedroom door. Move one of them and they jump around trying to separate. The planter on the side of the pool next to them does the same thing. Go to any box, trash bin, trash bag, crate or any dynamic prop and kick them they'll 'explosively separate' with the potential of killing your character! I thought it may be from some mlo's I had on the map, so I removed them and it still happens. It's no wonder I can't get menyoo to spawn in maps over 600 props! This did not start happening until this shitty 'contract' dlc. Other than pulling the dlc, I have no idea how to fix this which is probably the source of the 'Kernel' malfunctions within the game.

  • @iammistahwolf As @a63nt-5m1th suggested above, and what is certainly the logical first step in troubleshooting a modded GTA5 game, is to disable all mods to see if problem persists. You can test this very simply by renaming dinput8.dll and starting your game.

    If your game run now runs stable after this simple change you can now eliminate the hundreds of potential hardware and windows software issues from the equation, saving hours of futile trial and error, and focus on which mods have totally fubared your configuration.

  • Okay, on a whim I did two things; One I did a thorough run through of my dlc packs and dlclist in OIV. Somehow I had double entries in the list and weirdly enough a copy of 'Enhanced Native Trainer' was installed into the game's root dlc's (no idea how that happened.' Cleaned up everything and ran a 'disk check' to clear up anything else happening on the drive. Next, when I checked the 'packs' a mod I thought had been removed was still there. Before actually removing it, I dug around and found three files associated with streaming the map. Pulled those three out and also removed a double entry of 'mp mappatches'. Game worked like a charm. Did some hardcore activities to initiate a crash and it kept rolling. Now, only issue left is I can't load my large maps with menyoo. I used an ASI patch to get it up to date and now menyoo will load the maps but exactly 3 seconds later, the 'Kernel' attacks and the game shits the bed. It will load maps with less than 800 props no prob. Anything bigger and....

    Thanks for all the tips. Didn't need many of them this go around, but the day is young....

  • @iammistahwolf
    Glad you got (most) of the issue resolved. :thumbsup:
    Don't know Menyoo at all, but maybe try Map Editor & Menyoo to YMap Converter to convert them to '.ymaps'. It comes with an example 'custom_maps' dlc you can use to install any '.ymap'.
    ymaps have better performance than other methods, so if you can convert any maps to ymap, it's good to do so anyway.

  • That's part of the overall 'problem'. I've converted a couple large builds over with M2YMC. That worked fine. Issues were massive occlusion with the Map Builder pieces glitching in and out of view. All the 'vanilla bits' and the 'Numbers' from MB worked just fine. I tried to convert from codewalker and only the vanilla props showed up! But as I said, M2YMC got the maps in okay except for the nasty occlusion. The main issue is I put in doors for rooms, gates and elevators that should be dynamic in the ymap version, but are not. They can be selected in Menyoo (which I guess would be okay if on a server that uses it.) However, I would like to get them loaded in Menyoo to make any adjustments. I figure they'll have to be broken down into separate maps (i.e. overall structure, windows, doors/gates and then interior props) which is something I probably should have thought of in the first place and will be a PIA to correct (if I could get the damn things to load in.) I would try to fix it in codewalker, but I haven't been able to get it to recognize the MB parts (though it would be easy to save a ymap of just the vanilla bits separately....) Mainly though, getting the ymap parts to perform as they do in Menyoo (no occlusion glitches, exterior light blasting through solid objects and so on) is my primary concern. That and getting doors and gates to perform properly in ymaps would also be good!

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.