Log in to reply
 

Can't get out of car (new add-on car mods)



  • Just added these two add-on cars today:

    1.) Sklyine R33 GTR
    2.) Honda Civic VTEC 94

    Cars work great - drives well and is fun but I can't get out of the car! The car is frozen once you try to get out ("F" on the keyboard or "Y" on the controller). Have to switch characters to continue playing.

    Added cars to my custom add-on pack - nothing was changed - just added the lines in each respective file (vehicles.meta etc.).

    I have > 1000 add-on cars and they all work great. Can someone please help me figure out why I can't exit the vehicle?

    Thanks in advance.



  • @Suzerain001 did you gain weight during the pandemic?

    To rule out a problem with your addon pack, try the cars independently. If you can get out, then you know it's your pack.

    Your issue is the reason i dont use packs. Troubleshooting becomes a PITA, and unless your computer is a real potato, individual DLCs work fine, although 1000 cars is pushing it.



  • @JohnFromGWN Yes I understand having the cars individually would make it much easier to troubleshoot. The problem is I've been modding the game ever since it came out on PC and my custom add-on packs are pushing 4GB each (with tons of vehicles in each dlc.rpf).

    Anyway, I added them individually and they do work - I can get out of the car but obviously, I want them in my add-on pack.

    I'm quite sure it has to do with the vehiclelayouts.meta file since both cars use the <LAYOUT>LAYOUT_LOW_RHD</LAYOUT> tag - I have many other cars in this pack that use that <LAYOUT> tag so I'm wondering if it's some flag in the vehicles.meta that's causing it(?). This is where I need help in narrowing it down and solving the issue.

    I've uploaded the meta files for this pack here - random2

    Please take a look and let me know.

    Thanks.



  • @Suzerain001 have you tried defragging, not as your solution, but to see if you can decrease the file size?

    And in all fairness, do you really need 1000 vehicles? Sounds like a recipe for instability - both for the memory allocation on a game not designed for modding and certainly not for 1000 addons, and also because of the potential mod conflicts given duplication of modkit ids.



  • @JohnFromGWN I tried defraggin to no avail.

    Weird thing is, same carpack works perfectly fine on my other PC. This makes zero sense to me - nothing else is different wrt these carpacks on both PCs.

    Re modkit id's, I manually edit each car I put into the add-on with a different ID so I'm 99.9% sure there are no conflicts there (is there a way to check for duplicate modkit IDs?).

    Now I notice that any car with the <LAYOUT>LAYOUT_LOW_RHD</LAYOUT> tag has the same issue (Toyota Supra A90 / A80 etc.) - these cars were installed many months ago and were working just fine.



  • @Suzerain001 there's plenty of strange shit going on with GTA5 modding. I have one ped, the punisher mod, that occasionally refuses to spawn. So no changes to the game or player and on some days he spawns, on other days nothing. I spent hours trying to figure it out, keeping all variables constant, to no avail.



  • Dayuuum I feel for you two. Frustrating as hell! I gave up trying to figure out the whys. One time my Lita WWE ped wouldn't spawn. instead some wack random ped combo?? Turned out parts of my x64v.rpf got corrupt somehow!?? I didn't touch that x64v.rpf for a looong time. No issue tho since I just needed to swap out my broke modded x64v.rpf for a perfect modded replacement. Still wtf tho.

    @Suzerain001 Yea dawg different pc's can perform totally different with the same files for some strange reason. Sux.

    @JohnFromGWN Can you roughly remember when the Punisher ped issue started? If so what new mods did you install around that time that could possibly conflict for some weird reason? Im assuming your issue isn't a broke file like mines was so mod conflict would be my best guess. This is a stab in the dark but maybe try this. Open the gameconfig with notepad and find the search, once you do type - cloth - then there should be a number 60 change that to 600 save replace and start the game! Julio also made a video about it -



  • @JohnFromGWN damn.. so what is the solution here? Do I try another <LAYOUT> tag? If so, which one for the RHD cars?



  • @Suzerain001 you'll have to experiment
    @gtavjamal too many peds installed to tell, but keep in mind the spawning is inconsistent. And cloth physics are not involved, not even sure if I have any with cloth physics for that matter, I'm just happy when they can blink.



  • @JohnFromGWN Wow you must have a lot of peds. Out of curiosity how many do you have? Easy fix then. Just go thru the list, rank them and axe the lowest ranked ones.



  • i had the same problem, thanks for the solution



  • @JohnFromGWN I can confirm that any car that has the <LAYOUT>LAYOUT_LOW_RHD</LAYOUT> tag does not work on this PC. The exact same car pack works fine on my other PC so I'm not sure what's going on.

    If I remove the _RHD from the tag, it work but obviously it looks ridiculous since the character gets out from the left side and the car clips on to the character model itself. This is super annoying so if someone can help diagnose, would be helpful.



  • @Suzerain001 there is one simple solution but it means stepping away from the all or nothing mindset, and that's to simply exclude those problematic models from your mega dlcpack, leave them as standalone, at least until you figure it out or someone here offers a solution.

    Im not a fan of this packing concept because a proper gameconfig.xml and a decent computer alleviates these issues. This might not have been the case in 2013, it is now.

    Im not a fan of packaging peds either, once more because it makes troubleshooting difficult, but i live with it because i sure as hell will not create hundreds of individual packs for the peds when current installation is a brainless and effortless drag and drop and one edit to peds.meta (i don't use the Meth0d mod)



  • @JohnFromGWN Yea I hear you - it's just that when it works on one PC and doesn't on another, it seems really weird is all. Both my rigs are beastly - RTX 3090 and 10900K - so it's not a question of PC power. The gameconfig.xml I'm using on both PCs is F7YO's custom one and it has served me well thus far.

    I guess I'll keep these two cars as separate for now on the problem build but it's nagging me since I want to see what the actual error is. Are there any decent debugging tools for GTA V to diagnose when exactly the probem occurs or what the root cause of the issue is? Would be nice to have the debugger run in the background while the game is being played and if/when a problem arises, it spits out some clues/answers on what/why the issue is happening.

    Talking about debugging, I added a few more cars to my police vehicles pack and now the game crashes on load so it must be some syntax error etc. - I've uploaded the dlc.rpf here so if you can take a look and let me know, I'd appreciate it.

    Thanks in advance.



  • @Suzerain001 im not the right person to ask because i don't create packs. If you think it's a syntax error in xml, OpenIV has a tool to check that and there are online tools for that as well.

    With regards to debugging, the only tools i know of, and i use the word tool loosely, are the log files but those won't help here.

    What I can suggest, the approach I would use, is to keep it simple. Start with one working car and one problematic one and try to make a working pack. Even better, backup your dlclist.xml and then remove every single addon line except your test pack.

    You now have a test environment with hundreds of variables and potential conflicts removed. Now you can focus on one pack, with two files, and if that works keep adding and start looking elsewhere for possible issues. I would even disable all scripts and asi mods except the essential ones including your trainer, the loaders, etc.

    As for why one PC works and the other doesn't? When i first started modding i noticed that even in the Vanilla mode i had these extremely nasty black particles floating everywhere. I even tried them on my older PC, same issue. One Ryzen, one Intel, different nVidia GPUs. Same problem. Did research and nobody had this issue. Why me? Why both PCs?

    Eventually @a63nt-5m1th gave me a file that removed the vanilla game particles and that ended this annoying asF problem. Never understood why, particularly since the GPUs and drivers were different on my 2 PCs and other users with same GPU and CPU had no issue.



  • @JohnFromGWN I solved it! It was the bleepin load-order for the pack in setup2.xml !! I changed it from 9 to 92 and BAM, it works!

    w00t



  • @Suzerain001 excellent


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.