Log in to reply
 

Unable to use the mods file



  • I am currently running the latest Gta (1.0.2628.2)

    I am currently unable to run Gta as the mods folder would active I would start the game and enter into story mode and let it run for a few seconds later it would black screen, close itself, and stop the application.

    The other mods I have within the mods folder are vehicle mods and some buildings mods as well

    asiloader https://pastebin.com/r1hWcbRh

    ScriptHookV https://pastebin.com/CwHQhKQs

    ScriptHookVDotNet2 (Unable to put it in pastebin as it reached over its max limit)

    What I have already tried was taking out all of the addon files and placing them back in one at a time but once the first addon file was in and I ran Gta it happened again. I have deleted openiv and reinstalled it and reinstall the folder and that didn't work. What should I do?



  • @Narga

    One issue is this:
    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\gtamp-unlock-all-objects.asi" "gtamp-unlock-all-objects.asi" failed to load

    Reinstalling generally is just a waste of time unless you are actively editing and deleting files in the game folder.

    First things first. Unclear from your post whether your game runs stable (30 minutes minimum) without any mods. That's the first thing to check.

    If the game runs without any mods, and I mean runs stably, next disable all asi files except OpenIV.asi and your trainer (Menyoo, Simple Trainer, whatever). Disable your scripts as well. Just rename the files and the script folder. But for the asi files rename extension bak or the asiloader will try to load them.

    If that works, next step is remove all your buildings - they are much more likely to cause a crash rather than vehicles.

    Do you have a gameconfig, heap, and pack mods installed?

    You can also look at this post if you're new to modding GTA5.

    https://forums.gta5-mods.com/topic/35789/gta5-911-help-and-checklist-what-to-do-when-mods-make-you-mad



  • @JohnFromGWN

    I have gameconfig, heap, and pack mods installed and yes I am new to modding in general. But I disabled both mods and scripts folder and ran it that worked this may be dumb to ask as I am the one who installed it in the may I ask where do I go to remove the building files



  • @Narga from dlclist.xml



  • @JohnFromGWN Found the issue it was located where you told me it took me a while to find but founding none the less thank you for the help and service



  • @Narga I'm glad. Thanks for letting us know you fixed it.



  • @JohnFromGWN You're going to have a laugh at this. As I thoroughly cleaned out the dlclist of any addon buildings and vehicles I have added and then saved it, finally downloading and placing a one new addon vehicle mod the game had done the same thing load into story mode, black out, and close itself



  • @Narga No reason to laugh. Did you use any OIV installers?



  • @JohnFromGWN by OIV you mean OpenIV then yes OpenIV.asi and OpenIV text document in the Gta directory and its installer in the new technology file



  • @Narga no, I meant an OIV installer.



  • @JohnFromGWN Then no I don't have an OIV Installer



  • @Narga Which mod you added crashed the game. Just remove it.



  • @BuffaloBill2 That would lose the point of me modding Gta then because its any mod that has been put into the mods folder



  • @Narga you wrote that your game was working, then you made additions or changes that broke it. So try to get back to that stage where it was working and only add one mod at a time then test. You can also post your log files here or better on pastebin.



  • Ok I'll test it with 4 different files 1 without mods and 3 with different addon mods

    Asi loader without mods https://pastebin.com/w1kAHjz4
    ScriptHookV without mods https://pastebin.com/9L6J6fP6

    Asi loader with just the 2017 Nissan GTR [Add-On 2017 Nissan GTR [Add-On | Tuning | Template] https://pastebin.com/aeLtXpaE
    ScriptHookV with just the 2017 Nissan GTR [Add-On 2017 Nissan GTR [Add-On | Tuning | Template] https://pastebin.com/BJkqE1us

    Asi loader with just the F-35C Lightning II [Add-On] mod https://pastebin.com/Wm2iUruh
    ScriptHookV with just the F-35C Lightning II [Add-On] mod https://pastebin.com/rHYJQWPR

    Asi loader with just the 1998 Toyota Supra (JZA80) [Add-On | Tuning | TRD | Varis-Ridox | Template] https://pastebin.com/kcBgMhrf
    ScriptHookV with just the 1998 Toyota Supra (JZA80) [Add-On | Tuning | TRD | Varis-Ridox | Template] https://pastebin.com/rHYJQWPR

    With all 3 addon mods I have experience the same thing happening to me It will load into storymode, black out, and close itself



  • Want me to send the ScriptHookVDotNet2 here or not, because I can't send it in Pastebin



  • @Narga no, from what you described at first I thought it was an addon rather than a script from scripts folder or asi. But now looking at the number of scripts you have installed I'm not surprised that you have issues. Rename your scripts folder and test.

    However, as I wrote in my first reply, please remove the asi below. Not sure if it's causing issues but remove it.

    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\gtamp-unlock-all-objects.asi" "gtamp-unlock-all-objects.asi" failed to load

    Edit: do you need or actually use all those scripts? You're just asking for instability problems because I'm certain some of those scripts are outdated, they are all loaded in memory at the same time, they may conflict with each other, and they definitely weren't designed to all be used on the same installation.

    If your problems aren't resolved by renaming scripts we know it's an addon problem, or possibly an asi one.

    If they do disappear you'll need to rethink which scripts are essential.



  • @JohnFromGWN You would be surprised but yes I do, though they were working all in unison without any hiccups or problems till this arouse. Yet I am still getting the same problem. I have the scripts folder renamed to scripts1, having the .asi deleted and having the supra mod still in the mods folder.

    Asiloader without scripts https://pastebin.com/1PtaKWYQ
    ScriptHookV without scrips https://pastebin.com/w0BFy80s



  • @Narga so it's your addons or PC.



  • @JohnFromGWN And eliminate the addons because it does that to any addon I put into the mods folder

    Edit: Is there anything I could do to fix it?



  • @JohnFromGWN It works with the scripts on or off regardless it's just any addons that are applied into the mods folder that it blacks out and closes.

    Edit: Thinking things thoroughly the only thing I can see it as is the something lingering in the mods folder more specifically the update.rpf as that is the only thing in the folder besides the empty folders. Im going to attempt to remove the rpf and have it in a different folder outside of the gta directory and add a new rpf from openiv and test it



  • Tested and nope same thing happened



  • @JohnFromGWN The only thing I can think of is the update.rpf file where the problem is originating from but I don't know where in it exactly



  • @Narga

    There are 2 update.rpf files.
    The one in your mods folder is at
    \Grand Theft Auto V\Mods\update or could be
    \GTAV\Mods\update or something similar

    The one in your games folder is at the same path but remove the mods
    \Grand Theft Auto V\update or could be
    \GTAV\update or something similar

    At this point I think your setup is really badly screwed up.
    My advice would be to first do a verify integrity to ensure the game vanilla files are not corrupted or replaced.
    Then I would strongly suggest you review your folder structure to ensure all the files are in the right place. I've seen Youtube videos where they put update.rpf in the wrong place.
    You also need to ensure your game version is compatible with the gameconfig.xml mod (and have heap and pack) .
    Finally I would strongly consider doing your entire mods from scratch - just keeping your dlclist.xml.

    This thread also can be useful to ensure you did everything right.
    https://forums.gta5-mods.com/topic/35789/gta5-911-help-and-checklist-what-to-do-when-mods-make-you-mad



  • @JohnFromGWN the update.rpf located in \Grand Theft Auto V\Mods\update but I'll do that right now I'm going to start from scratch

    Edit: Thanks for trying to help and the service


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.