Log in to reply
 

Mods folder isn't working



  • I am currently running the latest Gta (1.0.2628.2)

    I'm using "the base structure" for modding Menyoo, ScriptHookV and ScriptHookVDotNet, Addon Spawner, OpenIV, Gameconfig, Packfile, and Heap and I am unable to add any addon vehicles to the mods folder whenever Gta detects a vehicle addon mod it proceeds to black out and close

    asiloader https://pastebin.com/tbMisCr7

    ScriptHookV https://pastebin.com/WjDXCmBp

    ScriptHookVDotNet https://pastebin.com/JdQtMZwR

    I ran the addon vehicle alone no scripts: Stops working
    Ran without vehicle addon mods: works
    I have also gone through the log files and found this in the iFruitAddon2

    7/2/2022 5:06:13 PM : Error: IsUpdateAvailable - The request was aborted: Could not create SSL/TLS secure channel.



  • @Narga you were given advice in your previous post but I'm not sure you're following it.

    For example I pointed out this error to you but you didn't bother to correct it.

    ASI: Loading "C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto V\gtamp-unlock-all-objects.asi"
    "gtamp-unlock-all-objects.asi" failed to load

    Your problem is with scripts and you can easily fix it by eliminating scripts until you find the culprit.



  • @Narga your log files are fine except for
    17:06:01] [WARNING] Resolving API version 0.0.0 referenced in INMNativeUI.dll.



  • @JohnFromGWN Ok I deleted that but I still have a problem its crashing now



  • @Narga It's not the cause, but you remove a variable. It is unclear from your post what is working and what isn't.

    Does your game crash with the scripts removed (the scripts folder only) ?



  • @JohnFromGWN Renamed it to Xscripts and it is still crashing



  • @Narga Ok, now change the extension of these asi files to .bak.

     "AddonSpawner.asi" => to AddonSpawner.bak
    
     "gtamp-unlock-all-objects.asi" => delete this file or remove it, if you haven't already
    

    Now run the game but keep Scripts as Xscripts.

    We are going to do this variable by variable.



  • @JohnFromGWN Nope didn't work



  • I renamed the mods folder and everything works fine



  • @Narga I don't understand what you mean by you renamed the mods folder??



  • @JohnFromGWN My renaming it to Xmods



  • @JohnFromGWN Hello?



  • @Narga by renaming your mods folder to xmods, you're unfortunately not fixing anything, you're just running your game without any mods from that folder.



  • @Narga Your issues have been going on for quite awhile. Likely because you have too many scripts and asi files.

    This is what I recommend.

    First do a verify integrity and test your game, unmodded for at least 30 minutes to rule out any issues, even if you've done this before, do it again.

    Next, i recommend you go through some of the basic videos and articles here to better understand what could go wrong.

    https://forums.gta5-mods.com/topic/35789/gta5-911-help-and-checklist-what-to-do-when-mods-make-you-mad

    That's all i can offer as help remotely, if you want me to come to your house to fix it, you'll have to wait until the pandemic is over.



  • @JohnFromGWN Ok so I did what you told me and I have followed exactly each step and what not to do but still ended up with the same result. I guttered out everything and put in the base structure, no scripts have been added just 1 single addon mod loads the game blackout and closes. Truly up to this point I am teetering whether I should mod or not.



  • @Narga

    A while back, I posted Game Failures - Common Causes, which was an attempt to list possible reasons why your game might crash. The list tried to capture the most prevalent ones, but undoubtedly there are many more, not to mention combinations of issues.

    The fact that your game works without mods nods favorably to your hardware, drivers, and overall Windows software.

    But something beyond your control, or human error, is preventing you from getting to that stable state of modding that millions of users have reached.

    Fixing computer issues remotely is frustrating as hell. You'll need to continue on your own.

    There are times when it is something unexpected, for example hardware. A few years ago I assembled a new PC for myself with a powerful AMD graphics card and it crashed the latest Resident Evil game. I spent hours updating drivers, tweaking, and researching to no avail.

    So I returned the card, put in an equivalent Nvidia GPU, and resolved the issue immediately.

    Nobody else had reported my issue and others with similar rigs (mobo, CPU, same AMD card) didn't have any issues.

    I can't help anymore unless you have specific error messages, all I can suggest is to go through post above and with luck something will shed light.

    Good luck. Don't give up.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.