Log in to reply
 

Installation of custom maps (.ymap files) hasn't worked for me. Help?



  • I want to have custom maps on SP, but after going through multiple tutorials and guides, I just can't make any of the custom maps show up in my game. No matter if it's maps that I made myself or maps that I downloaded, nothing shows up in my game after many attempts. I followed this guide here:

    .
    Any help is appreciated!



  • @TheManDede Which maps can't you load. Unless you provide a link to a specific map it's hard to say what is the issue.

    As for guides and tutorials???

    1. Place the folder containing the dlc.rpf in your dlcpacks folder, the same one as your cars etc, and hopefully the dlcpacks in your mods folder.
    2. Add a line in dlclist.xml using the folder name. <Item>dlcpacks:/hotmap/</Item>
    3. End of tutorial

    If you are converting yourself, with the tool above (which is a total waste of time/useless) you will see a folder called custom_maps (or something like that) in the extract.

    1. Put that custom_maps folder in your dlcpacks folder.
    2. Add a line in dlclist.xml for the custom_maps
    3. Drag and drop your conversion as per the instructions that came with mod.
    4. Done


  • @TheManDede If it's the location you can't find, and unfortunately many modders think it's funny to have you search for their maps, check out the ymap (or one of them).

    Look for this:

          <Item type="CEntityDef">
          <archetypeName>designer_house</archetypeName>
          <flags value="32"/>
          <guid value="0"/>
          <position x="-2628.15700000" y="1700.86500000" z="140.67050000"/>
    
    


  • @JohnFromGWN I tried installing the custom maps (custom_maps) mod that enables you to install any map you want by dragging and dropping .ymap files into the custom_maps folder. And I tried installing one of the default maps that came with the mod, but even after following all the steps and redoing the whole process again and again, nothing shows up in my game. I know I'm doing something wrong cuz the mod still works, but I'm just not aware of what exactly I'm doing wrong. Thanks for your help :)



  • @TheManDede please post the line in dlclist.xml you have for custom maps.
    Also a sceenshot of your custom maps folder from OpenIV that clearly shows the path for your dlcpacks. Do you have any addon vehicles installed?



  • @JohnFromGWN
    This is my dlclist.xml:

    <SMandatoryPacksData>
    <Paths>
    <Item>platform:\dlcPacks\mpBeach</Item>
    <Item>platform:\dlcPacks\mpBusiness</Item>
    <Item>platform:\dlcPacks\mpChristmas</Item>
    <Item>platform:\dlcPacks\mpValentines</Item>
    <Item>platform:\dlcPacks\mpBusiness2</Item>
    <Item>platform:\dlcPacks\mpHipster</Item>
    <Item>platform:\dlcPacks\mpIndependence</Item>
    <Item>platform:\dlcPacks\mpPilot</Item>
    <Item>platform:\dlcPacks\spUpgrade</Item>
    <Item>platform:\dlcPacks\mpLTS</Item>
    <Item>platform:\dlcPacks\custom_maps</Item>
    </Paths>
    </SMandatoryPacksData>

    https://imgur.com/It06aeG
    custom_maps folder

    And no, I do not have any add-on vehicles installed. I actually only do replacing.



  • @TheManDede
    Why did you remove the closing slash in your dlclist.xml?

    Your telling OpenIV to load assets from a path that doesn't exist.
    Nothing in your dlclist.xml will load (the game version will load its crap)

    <Item>platform:\dlcPacks\custom_maps\</Item>
    not
    <Item>platform:\dlcPacks\custom_maps</Item>

    edit: that is the strangest DLC list I've ever seen - did you manually create the game dlc entries?



  • @JohnFromGWN said in Installation of custom maps (.ymap files) hasn't worked for me. Help?:

    <Item>platform:\dlcPacks\custom_maps</Item>

    I think it's because my pc can't copy left backslashes. In OpenIV, my dlclist looks completely different: https://imgur.com/DnR2ior



  • @TheManDede
    I've never seen a mod filename with spaces in the file name. I checked the page for this map and it seems there are issues with it and it also requires map builder installed. I would try to addon a vehicle or another map and see if it works, your folder structure seems fine.



  • @JohnFromGWN Still doesn't work. I tried installing 5 ymaps. 3 of them here:

    https://www.gta5-mods.com/maps/no-outlet-dead-end-road-signs
    https://www.gta5-mods.com/maps/exit-of-the-dead-eotd
    https://www.gta5-mods.com/maps/architect-design-house

    and 2 of them were maps that I made myself. But none of them pops up in my game. At this point, I'm quite lost. Normally I'm able to solve my issues when it comes to modding, but I can't wrap my head around this.

    Note: Just to be clear, this is the right path for the ymaps, right?
    GTAV/mods/update/x64/dlcpacks/custom_maps/dlc.rpf/64x/levels/gta5/_citye/maps/custom_maps.rpf



  • @TheManDede That's the correct path for converted xml to ymaps. If you downloaded a ymap already as a dlc.rpf, put it in dlcpacks.

    I'm assuming you made a typo, not a copy paste, because it's x64, not 64x.

    Menyoo maps are garbage and they don't convert properly to ymaps. I don't have a single ymap installed.

    Try to load this mlo, in dlclist.xml and dlcpacks instead, just as a test.

    https://www.gta5-mods.com/maps/malibu-mansion-add-on



  • @JohnFromGWN what version of GTA5 are you using, steam, epic, Retail, or warez?



  • @JohnFromGWN @TheManDede
    Just so you know, the missing backslashes in post#6 are a gta5-mods issue. The site removes them when you copy & paste 'dlclist.xml' data without using a codeblock. :thumbsup:

    @TheManDede
    How to post a Codeblock:

    ```xml
    Copy these three lines to a blank txt file, overwrite only this line, copy all & post into gta5-mods forum post.
    ```

    It's then converted to this when you post it (& will be 100% accurate when posting '.dat/.xml/.meta' etc data :thumbsup:):

    Copy these three lines to a blank txt file, overwrite only this line, copy all & post into gta5-mods forum post.
    


  • @a63nt-5m1th one of many issues.

    This works well too, prefer it for one liners, as the red font screams "this way!!!"

    <Item>platform:\dlcPacks\custom_maps\</Item>



  • @JohnFromGWN Yeah that was a typo. And I will try and install the map you gave the link to. And I'm using Steam :)



  • @JohnFromGWN Nope, that doesn't work either. The problem persists :( And I might have a theory why this doesn't work for me. In the GTAV files, there are multiple dlcpacks, and CodeWalker29 allows you to enable certain dlcpacks so you can look through all of them in CW. So, my theory is that CW might have somehow disabled the dlcpacks located in my mods folder. The reason why I suspect this to be the cause of the problem is that I recently installed the Red Dead Desert dlc. And when I'm in CW, I can see the map perfectly fine. But when I go into my game, it's not there. But another weird thing is that I also have the Liberty City Remix map installed, and that map shows up in my game with no problems whatsoever, even the countryside add-ons appear in my game. But now when I try to install any other dlc onto either the dlcpacks located in my mods folder or the dlcpacks I installed the Liberty City Remix map in, it just doesn't work. I really appreciate the help you are providing me, and I hope I'll be able to get this problem solved :)



  • @TheManDede Codewalker doesn’t save or disable anything.

    I'm thinking you might have corrupt save game and i realize i never suggested you do a verify integrity first.

    Adding variables, like LC and RDD, is only going to make the process more difficult if not impossible.

    You need exactly the opposite approach. Simplify, eliminate, focus.

    If the verify integrity doesn't work, try a new save game or download one from this site.
    If that doesn't work i would seriously consider deleting your mods folder and recreating it from scratch.



  • @JohnFromGWN I will try that. I think you might be right about the verify integrity, I actually never thought of trying that.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.