Log in to reply

Unable to flip and control car mid air

  • When my car rolls upside down or lands sideways, I can't flip it back on wheels normally as we do. On air, shift and control keys can't balance the car. I use arrows keys for driving controls, so I thought it might be conflicting, so on in-game settings, I did reset the controls to default, no changes. Verified game data, no changes. Uninstalled the whole game, started a fresh, well, without mods, it works. So I narrowed down trynna find which mod was the culprit. Addons have no issue, in short, my mods folder doesn't affect anything.
    I have reached a point where removing ScriptHookV.dll only (that is leaving the dinput8 and the scripthookv.net installed), the controls works.
    I'm not a pro but I think something's up with my asi files, so I tried removing each one of the asi's I have and launch the game (with scripthookv present) but controls still not responding. So far the only solution is to remove scripthookv , and we know without it, game's boring. I have the latest release of scripthook (1.0.2628.2)

  • @Yunky
    What .dll and .asi mods do you have installed?

  • @IAmJFry
    dinput, scriptHookV, scriptHookVDotNet2, scriptHookVDotNet3
    CustomGearRatios, DismembermentASI, Gears, GTAV.HeapAdjuster, InversePower, Menyoo, NFSgauge, NoBoundaryLimits, OpenIV, PackfileLimitAdjuster, ScriptHookVDotNet, TrainerV

  • @Yunky
    Oh my bad. I meant .dll mods that are in your scripts folder

  • @IAmJFry
    For map editor (ClearScript, MapEditor, NativeUI).dll, Engine_Braking.dll and Razielex's BreakLights System.dll

  • @Yunky
    Dang. Was thinking one of those would stick out as an issue. One thing you can do is remove everything from your scripts folder and test. If it’s fixed then you know it’s something there. If not, you’d have to remove one of the .asi mods at a time and test.

  • Thanks @IAmJFry Let me try withe scripts folder, since I had removed all the .dll and .asi on the main folder one by one, which did not work , unless the scriptHookV.dll, but without it the whole modding is kinda useless.

  • @Yunky
    If removing ScriptHookV fixed it then it has to be a mod of some sort. Removing the script folder is the quickest test. And hopefully removing the script folder fixes the issue and then you can start checking those mods one by one.

  • @Yunky
    Scripthookv.dll isn't your problem. Logic is at fault here.

    When you remove SH5, dinput8.dll will still load asi mods including ScriptHookVDotNet.asi - but the latter won't work without SH5 and neither will the scripts which need the SHVDN.

    So the reason your controls work is because ScriptHookVDotNet was disabled, and consequently your scripts were disabled - which temporarily solved your problem.

    P.S. When you want to remove all your mods temporarily, just rename dinput8.dll. It will keep all asi files from loading (OpenIV, ScriptHookVDotNet.asi, etc.).

    To troubleshoot your problem, as you are planning to do, just remove scripts from your script folder (assuming an asi file is not causing issue). You can do this one by one. Or remove half, and test. If problem persists, it is in that half. Rinse and Repeat.

    If problem is solved, problem exists in the half that you removed. Swap those in, swap the working ones out.

  • @IAmJFry, Unfortunately script folder doesn't do it. @JohnFromGWN I already tried all those, to the point of reinstalling the game, re-edit some previously modded dlc all in vain.
    The logs got no errors or warnings. Though I'm sure it's the mods. So, I'll work on them slow by.

    Appreciate the insights guys.

  • @Yunky Are you using Simple Trainer? It binds the crap out of every key imaginable. Try disabling it but change the asi extension so dinput8.dll doesn't attempt to load it.

  • @Yunky
    Many trainers include settings to disable the ability to control the pitch & roll when in the air & also disable the ability to roll the car back over onto it's wheels when you crash upside down etc.

    The setting usually disables all those things mentioned above with just one value/toggle, & can often be called things like 'Realistic Crashes' or some such, where it's not always intuitive to understand exactly what the setting does etc. Easy to toggle ON accidentally, or in hopes of better crashes etc, without realising it's implications/effects immediately etc.

    Disable any/all trainer/s to confirm & then, if that fixes it, hunt for the setting (which may or may not be named sensibly/intuitively) :thumbsup:

  • @a63nt-5m1th
    @Yunky said in Unable to flip and control car mid air:

    so I tried removing each one of the asi's I have and launch the game (with scripthookv present) but controls still not responding. So far the only solution is to remove scripthookv ,

    What we know is that removing ScripthookV.dll fixes the problem. Given SHVDN and Trainers require SH5 I was thinking script or Trainer.

    If disabling all the asi's did not resolve the issue (see quote above), then we can rule out all Trainers as well as OpenIV and SHVDN, as they are all asi.

    At this point nothing makes sense, controls were restored, integrity of files was verified and then a reinstall.

    Removing the scripts folder didn't help either.

    Ofc, the sequence of the steps taken is important too. Disabling SH5 will not disable OpenIV for example. So depending on what was done when, I would start the troubleshooting from the scratch but ensure it is done systematically.

    Remote troubleshooting is a bitch.

    Step 1. Disable all mods by renaming dinput8.dll (assuming no addons or replaces in vanilla game folder)
    Step 2. If problem is solved, rename dinput8.dll back and now rename scripts to test for script issue
    Step 3. If problem persists, rename mods (leave scripts renamed) to test for mod issue (addon or replace or MLO or whatever)
    Step 4. If problem persists, disable all asi ensuring extension is changed to .bak for example to test for Trainer issue or other asi (SHVDN, Heap, Pack, OpenCamera etc).
    Step 5. Test with vanilla car, if problem persists wipe disk clean and cry.

  • @JohnFromGWN
    Just wanted it 100% confirmed all trainers were definitely disabled (or at least appeared so anyway) when op tested previously :thumbsup:
    If not a script/trainer at the route cause of it, I'm not sure what it could be :thinking:, other than perhaps file system/registry corruption or some such.


    • Did you also disable all trainers when disabling all '.asi's previously? Having read your post#3, I presume so, but still confirm it & make sure you didn't miss any etc, thanks :thumbsup:
    • Good idea to run a disk check on your game install drive, as issues there could cause any manner of unpredictable behaviour. Potentially, including a script/trainer being loaded by the game, even though it now appears uninstalled/renamed in Windows Explorer etc. Restart PC when scan complete & re-download a new Script Hook V & install it before loading the game.
    • After that, run through the list @JohnFromGWN provides step by step & give us your results :thumbsup:

  • @a63nt-5m1th got it.

    The fact the controls work in vanilla mode should make this one relatively easy to troubleshoot by eliminating variables.

    You're right about the trainers being 100% disabled. You can't approach this issue half assed. Has to be systematic with patience and attention to detail. Eliminate variables and the usual suspects until you find the culprit or culprits.

    Pretty easy in theory, given this isn't a random issue, to isolate the suspects once you know vanilla works.


    1. mods folder
    2. Scripts folder
    3. Root folder

    Unlikely to be a combination and at least you can rule out hardware and windows software issues. OP has both verified integrity and even reinstalled. Corrupt save game file would likely cause issues in vanilla as well.

    I'm with you that this is likely a trainer key binding issue.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.