Log in to reply
 

OpenIV Installation Failed - Setup Unable to Write Log File - How to fix?



  • Hello, I downloaded GTA 5 (version 1.0.2699.0) for the Rockstar Game Launcher. I wanted to install mods for GTA 5 so I downloaded Open IV. Unfortunately, when I try to run Open IV, I get this message.

    alt text

    After clicking "OK" Open IV proceeds to attempt an installation but just ends up saying "OpenIV installation failed." I have tried force disabling my antivirus (as you can see below) and restarting, but that doesn't seem to work. I have also tried downloading Open IV again thinking that the file was corrupted, but that didn't work either.

    alt text

    I have been trying to fix this for two days, but have no idea how! Please help!



  • @BringTheJubilee Could be a permissions issue.

    If you google this problem you'll get quite a few hits, unfortunately each with different solutions. At least you can try.

    Definitely fixable with a little bit of research on your part.



  • When I did google it, most of the solutions seemed to revolve around turning off my antivirus. Another solution I tried involved creating a folder titled "New Technology" where it's supposed to be created after Open IV setup runs and placing Open IV setup in that folder and then running it. Unfortunately, that didn't work either. If it is a permissions issue, how would I go about fixing that?





  • I have granted full permissions to all users for ovisetup.exe, for the Grand Theft Auto V folder, and for the Users folder since Open IV writes the files to AppData which is under the Users folder. And I didn't just grant permission to one of the group or user names, I went through every one of them and granted them permission.

    alt text

    alt text

    alt text

    Unfortunately, this has still not worked. If I gave it full permissions and my antivirus is off, what could be stopping it from creating a log file? Could an older version of OVI work instead? I just don't know why this is causing me so much trouble.



  • @BringTheJubilee don't know.

    Try this. Create a blank text file and name it OpenIV.log, manually set the permissions to "everyone " without the quote ofc.

    So now you've manually created the file and set the permissions to everyone.

    P.s. try running the setup as admin, and if you already try that try running without selecting admin.



  • @BringTheJubilee in your permissions, add the keyword everyone to each folder and then select everyone. I just noticed you hadn't done this everywhere. This will help eliminate any issues and will not pose any security risks.



  • @JohnFromGWN I just got it to work. I had to move ovisetup.exe to the Rockstar Games Folder from downloads. I don't know why it couldn't write the log file from downloads, but I'm just glad it works now. Thanks for the help.



  • @BringTheJubilee I'm glad and thanks for reporting back. Changing the permissions was really a last resort because it is entirely unnecessary.

    I have no idea why you had to move the installation file. I always download to my desktop, any files, and run from my desktop.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.