Log in to reply
 

ScriptHookV not loading



  • Hi!
    So since the last update of GTA 5, ScriptHookV and ScriptHookV.net don't work anymore. I've updated them already and I placed everything correctly into the game/scripts/.... folder, but my installed scripts just won't load and I'm not sure why..



  • @xDevoidx said in ScriptHookV not loading:

    I placed everything correctly into the game/scripts/

    Unlikely.
    Do you have dinput8.dll installed in the game folder (root folder) with GTA5.exe and SH5 and SH5 dot net files? The dinput8.dll packaged with SH5.

    Does your trainer load and work? Either Menyoo or Simple Trainer or whatever trainer?

    Can you post the contents of ScriptHookV.log and asiloader.log here or on pastebin.

    A screenshot of your game folder and your scripts folder would be nice too.

    Also is this a Steam, Epic, Retail, or pirated version?



  • @JohnFromGWN dinput8.dll is installed, but I'm not sure about SH5/SH5.net since I never installed them back when it was working. The trainer doesn't load.
    Those are the log contents:
    ScriptHookV.log: couldn't find the exact file name, all I have is this.
    // GTA V SCRIPT HOOK (build Jul 27 2022, v1.0.2699.0)
    // (C) Alexander Blade 2015-2022
    [16:42:11] INIT: Started
    [16:42:11] INIT: Success, game version is VER_1_0_2699_0_STEAM
    [16:42:11] INIT: Registering script 'NativeTrainer.asi' (0x00007FF9570AA3C0)
    [16:42:11] INIT: Registering script 'OpenInteriors.asi' (0x00007FF954EAB950)
    [16:42:12] INIT: Registering script 'PedsDontRunAway.asi' (0x00007FF99F021260)
    [16:42:21] INIT: Pool 1 extended
    [16:42:21] INIT: Pool 2 extended
    [16:42:21] INIT: Pool 3 extended
    [16:42:21] INIT: Pool 4 extended
    [16:42:26] INIT: GtaThread collection size 189
    [16:42:26] INIT: wnd proc 0x00000000FFFF089F
    [16:42:26] INIT: IDXGISwapChain 0x00007FF9B40D2F20 (0x00007FF9B4063D60)
    [16:42:26] INIT: IDXGISwapChain set
    [16:42:26] INIT: DX init started
    [16:42:26] INIT: DX feature level B000
    [16:42:26] INIT: DX init succeeded
    asiloader.log: also couldn't find the exact file name, but this.
    // GTA V ASI LOADER (build May 2 2015)
    // (C) Alexander Blade 2015
    LIB: "C:\WINDOWS\system32\dinput8.dll" => 00007FF976D20000
    API: "DirectInput8Create" => 00007FF976D243D0
    API: "DllCanUnloadNow" => 00007FF976D365B0
    API: "DllGetClassObject" => 00007FF976D366C0
    API: "DllRegisterServer" => 00007FF976D45FA0
    API: "DllUnregisterServer" => 00007FF976D46280
    LOADER: Loading *.asi plugins
    ASI: Loading "D:\Spiele\steamapps\common\Grand Theft Auto V\fwBoxStreamerVariable_DecalsLimit-Patch.asi"
    "fwBoxStreamerVariable_DecalsLimit-Patch.asi" => 00007FF9B1590000
    ASI: Loading "D:\Spiele\steamapps\common\Grand Theft Auto V\NativeTrainer.asi"
    "NativeTrainer.asi" => 00007FF9570A0000
    ASI: Loading "D:\Spiele\steamapps\common\Grand Theft Auto V\OpenInteriors.asi"
    "OpenInteriors.asi" => 00007FF954EA0000
    ASI: Loading "D:\Spiele\steamapps\common\Grand Theft Auto V\OpenIV.asi"
    "OpenIV.asi" => 00007FF98D830000
    ASI: Loading "D:\Spiele\steamapps\common\Grand Theft Auto V\PedsDontRunAway.asi"
    "PedsDontRunAway.asi" => 00007FF99F020000
    LOADER: Finished loading *.asi plugins

    Screenshots can be found under these links:
    https://gyazo.com/918e6b0dceef365e940cd1fda4cf487c
    https://gyazo.com/740de70e221c3833312810852efe9f71
    https://gyazo.com/90b40917ccec8bf1b96c8a4a456c9fe7

    It's the Steam version.



  • @xDevoidx said in ScriptHookV not loading:

    @JohnFromGWN dinput8.dll is installed, but I'm not sure about SH5/SH5.net since I never installed them back when it was working. The trainer doesn't load.
    Those are the log contents:
    ScriptHookV.log: couldn't find the exact file name, all I have is this.
    asiloader.log: also couldn't find the exact file name, but this.

    Those are the correct files. The reason you don't recognize them fully is because your file extensions are hidden.

    Also SH5 is just an abbreviation for scripthookv, sorry for confusion.

    I see what's stopping your scripts from running, you don't have the community scripthookv dot net loading. The asi file, you need to turn off hidden extensions from windows explorer view menu to see file extensions. It seems to be missing? Only 1kb? Nope.

    In fact, from your screenshot, assuming it's properly in alphabetical order, you're missing scripthookv dot net xml files too.

    As for your trainer, the native trainer that comes packaged with Scripthook5 is outdated and doesn't need to be installed. Instead install Menyoo or Simple Trainer or both, but that's not the reason for script failure.

    Make sure all your mods are updated and check all requirements for installed scripts.

    You don't have packfile or heap loading either.



  • @JohnFromGWN I've put in the .net files now.
    But there's one thing. When I'm starting the game with the dinput8.dll file from ScriptHookV, it'll load and then just close without an error, so I have to use the dinput8.dll file from System32, maybe that's the problem?



  • @xDevoidx said in ScriptHookV not loading:

    so I have to use the dinput8.dll file from System32, maybe that's the problem?

    Modding requirements has been in place for about 7 years and are proven to work, yet some moron on YouTube, either as a hoax or just due to plain stupidity, decided they could reinvent the process or at least provide the 100% bullshit fix. And that baseless ignorance spread like wildfire as other brainless YouTubers jumped on the bandwagon.

    Will it work?

    https://forums.gta5-mods.com/topic/39296/dinput8-and-d3d9-fix

    But don't take my word for it, try it yourself.



  • @JohnFromGWN Okay, here’s what I also noticed.
    I’ve got a mods folder (from OpenIV) and when I rename it to something else it won’t load -> game isn’t crashing when using the .dll from ScriptHookV. And some of the .asi scripts load, but still not ScriptHookV.net and still not the scripts folder.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.