Log in to reply
 

[Help Needed] Adding additional liveries to cars with existing liveries (not replacing)



  • Hi everyone, I've been attempting to add an additional livery to the Gauntlet Hellfire, but I've not been having any luck really finding many completed tutorials on how to start from step 1 -> finish. I've seen this post https://forums.gta5-mods.com/topic/807/tutorial-accepted-multiple-liveries-methode-for-any-car?page=1 but there seems to be an insane number of steps missing.

    What I have done so far

    • Imported car to Zmodeler 3
    • Created a template for the Gauntlet Hellfire
    • Created a separate folder in OpenIV just for the Gauntlet Hellfire with gauntlet4.ytd, gauntlet4_hi.yft, gauntlet4.yft in it.
    • I opened the gauntlet4.ytd and imported the texture named as "gauntlet_livery15" based on the 14 other liveries named similarly that the car has and also attempted it renamed as gauntlet4_sign_1 and gauntlet_sign_2 to no avail.

    My question is, what am I doing wrong?

    What I want to do:

    • I do not want to make the car an add-on or replace it with a new model.
    • I would like to add an additional livery option, let's say Livery 15 that I can apply to the vehicle.

    This doesn't have to specifically be the Gauntlet Hellfire, however what I want is moreso a tutorial that I can possibly follow on how to create additional liveries for vanilla cars. Both that have existing liveries (without replacing) and for those that do not have any liveries at all.

    I would appreciate any help I can get





  • @rbsace Thank you! I will be giving this a shot. Seems to be what I was looking for



  • @rbsace Hey, sorry to bother you but do you happen to know how to find the carcols.meta and the vehicles.meta for the car? I followed the entire guide and got stuck at the last part with the carcols.meta and vehicles.meta. I know I put them in the streamed folder for the car but do I just yoink the gauntlet4 section from the carcols.meta in the DLC it's a part of from its root GTA folder so that I may stream it to FiveM?



  • for the gauntlet hellfire (gauntlet4) carcols is in: \update\x64\dlcpacks\mpvinewood\dlc.rpf\common\data and vehicles.meta: \update\x64\dlcpacks\mpvinewood\dlc.rpf\common\data\levels\gta5

    scroll both files and find gauntlet4 section then copy and replace the section to a random fivem addon car to make it easier, remember to add your extra livery to the carcols in the fivem folder, also tuning parts and liveries files to stream folder, if you get errors check if the <tags> are closed properly in the meta files



  • Thank you so much for this explanation. I'm still unable to get the livery in the server although I'm somewhat positive that I have set it up correctly. I followed the steps from what you stated, but I have not been able to get it to work. I have all the .yfts for the Gauntlet Hellfire in the stream folder along with the new livery named gauntlet4_livery14 since there are 13 liveries in game, but one odd thing I noticed is that in openiv there are only 12 livery.yft options and 13 by default in GTA V. Is there something going on there that may be causing my livery to not show considering I named my gauntlet4_livery14? Am I also streaming the car wrong? This is what my file setup looks like: https://imgur.com/a/EfPk2xq The carcols.meta and vehicles.meta I directly yoinked from the mpvinewood dlc with this being the only addition
    <Item>
    <modelName>gauntlet4_livery14</modelName>
    <modShopLabel>GAUNT4_LIV14</modShopLabel>
    <linkedModels />
    <turnOffBones />
    <type>VMT_LIVERY_MOD</type>
    <bone>chassis</bone>
    <collisionBone>chassis</collisionBone>
    <cameraPos>VMCP_DEFAULT</cameraPos>
    <audioApply value="1.000000" />
    <weight value="20" />
    <turnOffExtra value="false" />
    <disableBonnetCamera value="false" />
    <allowBonnetSlide value="true" />
    </Item>



  • are you able to spawn the addon gauntlet in fivem? make sure to name the folder and files etc to gauntlet4b or something else, because if you spawn gauntlet4 fivem will use the default gauntlet4 with default meta files, I never tried streaming only a extra livery for a default gtav car, so not sure if it would work, but renaming the car and the meta references to something else will work for sure



  • @rbsace Thanks for the response! Sorry for the bother again, but to put it simply, no lol. So far, I've not been able to find how to stream the car as an add-on. I use vMenu to type in gauntlet4b as its named in the files and the .meta's but says vehicle can't be found. I'm wondering if there's a typo somewhere although I've checked countless times. I think my main issue here is getting the car to spawn at all as an add-on. I downloaded a different gauntlet4 from here and it spawns in just fine. I've actually just used that as sort of a template and completely renamed everything in their files to gauntlet4b and still nothin. Their car loads when I type nkgauntlet4 in vmenu but mine doesn't when I type gauntlet4b. Although theirs is a modified model. Wouldn't mine theoretically still load though considering I've extracted the proper yft's and ytd's? Wondering what the difference is here.



  • @SlipperyDoot I uploaded a addon gauntlet4c here: https://easyupload.io/r31v2a with a working extra livery so you can use it as a template, using tuning id 912. if you have another car with this tuning id in carcols change it, showing 14 liveries in game: https://i.imgur.com/a3uVXxZ.png



  • @rbsace Thank you so much! I cannot thank you enough for this. It's helped me learn a lot. I'm still figuring out how to stream the car as an addon myself, with other cars, but this is fantastic. I appreciate this so much. https://i.imgur.com/Q7fDFi7.png This is just from testing it out. Works on the normal gauntlet4 as well. I somehow replaced the livery13 though but I'm sure I can just tweak the files a bit and get it perfect.

    I am so sorry for asking, but can you confirm if this is how you did it?

    Steps:
    1: Open OpenIV
    2: Find the car's ytd and yft
    3: Extract the three
    4: Find the livery extract it
    5: edit the livery and use TextureTool to import the new livery
    6: Save it as the proper livery name, in this case gauntlet4_livery14.yft
    7: Create the CARNAME folder inside of server resources and inside that, create a folder named stream
    8: Place the ytds and yfts inside the "stream" folder
    9: Create the fxmanifest.lua/__resource.lua calling to the .meta files
    10: Create/Copy the carcols.meta/vehicles.meta/carvariations.meta/handling.meta
    11: start/ensure CARNAME folder
    12: Done?

    I absolutely appreciate how generous you've been with your time so far. Can't thank you enough!

    Would you happen to know where the taco van carcols is? I've been struggling finding that one.



  • @SlipperyDoot no problem, yes and the extra liveries go in the stream folder too, also in the vehicles.meta copy the txdrelationships section relative to the car, some cars don't have carcols entries like the taco van, it does have a carvariations.meta entry for settings like lights and color in \x64a.rpf\ the livery is inside its ytd, for cars that dont need meta files editing like this van you can stream as replace, create a folder like tacovanb and a blank __resource.meta inside, also a stream folder, inside the stream folder just copy the yfts and ytd etc you want to replace ingame, this time using the default names, taco_hi.yft, taco.ytd etc. no need for the other meta files, for stream-replaces to work you need to start the resource with the server, in your server.cfg 'start tacovanb'



  • @rbsace Ah ok thank you so much! I understand. It's been working pretty well so far. I think I've nailed getting the car to spawn under a different name. I'm going through some really odd issues though. I am trying to edit the Chino Custom lowrider car and I've got it to spawn in using "chinov" as the name however, what I noticed is there is no audio for the car and there are no modifications for the car. I've extracted all the mods and placed them in their own folder but still nothing. Do I have to name the extracted mods chinov_carmodname.yft? It's currently chi2_carmodname.yft similar to the livery. The livery for this car also has a chi2_sign_1 inside of the chino2.ytd should I replace that for the livery or do the same method I did for the gauntlet hellfire? Also, it's worth noting that the Gauntlet hellfire also has no audio. I assume there's something messed up in my carcols.meta for both cars?



  • @rbsace Sorry for the double reply! But I figured out my no audio issue! It was the <audioNameHash> </audioNameHash> being empty. All I had to do was make it <audioNameHash>CHINO</audioNameHash>. As for the mods, I had a typo the entire time. In the carvariations.meta I didnd't change
    <kits>
    <Item>606_chino2_modkit</Item>
    </kits>
    to
    <kits>
    <Item>606_chinov_modkit</Item>
    </kits>
    which, of course was the simplest thing lol. Anyway, thank you so much for the help so far. I will be testing the taco van and see if I can edit that as well. The livery for the chino custom works now as well.



  • @rbsace Hey quick question, and sorry for the bother, do you happen to know what I can do if a modkit doesn't load up? I was able to fix it for the Chino Custom, but the voodoo custom isn't working. I have the mods being streamed as well inside the stream folder in its own folder named vehiclemods, and changing the modkit id hasn't helped. I even swapped the chino custom modkit I was using to the voodoo custom and nothing. Is there something else that can be causing this issue?



  • @rbsace lol I'm SO SO sorry for the double reply again. When I replied to you about the mods not working, I was completely lost. I redid the ENTIRE thing from scratch and found out where my issue was. Didn't close a couple lines properly nor did I copy the carcols.meta properly. Got that figured out and now it works! So sorry again!



  • @SlipperyDoot no problem, when this happens you can use a 'online xml validator' to check meta files, if any open tags are found, it will be highlighted making it easier to fix



  • @rbsace Thank you! Will look into this.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.