Log in to reply
 

Can't start new game with mods



  • So I've been in the process of adding a ton of mods, mostly car mods (and 99% addons). I downloaded a 100% save file and have been playing on that file for a while and testing out all my mods. And now I want to start a new game and play through the story mode with all my cool cars. But when I go to start a new game, it crashes every time. I can play normally with all my mods on the 100% file, but I can't start a new game for some reason. I have narrowed the cause of the problem down to the mods folder, because if I rename the folder, I can start a new game, but that defeats the purpose of why I want to play through story mode again so I need to figure out which mod is causing the issue. And I have around 150 cars or more. And maybe 2 folders in the "mods" folder that are related to blood and gore mods. I had 3 replacement cars, but I already tried temporarily moving the .rpf that correspoded to those and starting a new game to see if that was the issue, and it wasn't. So does anyone have any advice for me that could help my situation? I don't know why any mod would play just fine during one point in the game but not another. Thanks a lot if anyone can help. This has been a bummer. I've spent a lot of time compiling everything, organizing, customizing the cars, creating save lists in Menyoo, etc. just to play through the game again and right when I finally get done doing all the leg work with the mods, this happens. And also, I just reinstalled the game with fresh files because I think I altered one that was outside of the mods folder at one point so I took that possibility out of the equation.



  • @jp615

    This is likely due to an issue with your mods or scripts or an asi in your root folder. Unfortunately finding the culprit means trial and error. Good luck.

    First of all reinstalling a game that is working well with mods, when you want to play with mods, rarely fixes anything. A verify integrity won't help either but is much quicker.

    Ok. This is how you will get to play a new game until you find your problematic mod, assuming you can find it.

    1. Start with a clean OS to ensure clean memory - definitely don't try this after one or more crashes.
    2. Navigate to \Users\YourName\Documents\Rockstar Games\GTA V\Profiles\YourProfile
    3. Move all the local and cloud saves to a new folder (MISREP and SGTA files). The profile folder no longer contains saves, you backed them up to another folder.
    4. Restart your game and you will boot into North Yankton - if you followed the instructions above.

    From there you can play a new game with all your mods. You can try to copy back your 100% save game but you'll likely have the same crash problem if you were to start a new game a second time - until you find the real issue.



  • So I moved the save files as you mentioned and now I get stuck at an infinite loading screen. I still don't understand why any mod would cause problems at one point in the game but not another. Is that a common occurrence? I forgot to mention aside from my car mods, there are many engine sound mods, if that makes any difference. All are addons though. Am I just going to have to go through my dlc folder and temporarily move each folder to a different location one by one and restart until I get a game working, to find the culprit??



  • Also why would this be an issue with scripts or asi's, when the problem goes away when I simply rename the mods folder? Doesn't that mean the problem is specifically in the mods folder?



  • @jp615 said in Can't start new game with mods:

    Doesn't that mean the problem is specifically in the mods folder?

    It would appear that way.
    I can't explain why your game works modded but won't allow a new game.

    What I suggested worked for me when I once overloaded my game with mods. Windows unfortunately isn't very good at releasing memory back and making it all available. So what I had done was force the game to start with a new game by temporarily removing all saved games. This worked fine.

    However it was essential to do a reboot to ensure all memory was available for GTA5.



  • Well luckily I quickly narrowed the problem down to mods/common.rpf. From there, I only had a few mods that even used that location so I eventually found it was a pedhealth.meta file that was inside a brutality+gore mod. That was the file that was causing the infinite loading screen (when attempting a new game start from scratch). So I am now able to start a new game, but only if my previous save files are deleted/moved somewhere else. When I try to import them back and start a new game from within that save file, the game crashes. This however isn't that big a deal now, as I just wanted to start a new game with all my car mods. But that problem persists nonetheless and I don't know why.



  • and thanks for your help again as you got me on the right track to locating the problem


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.