Log in to reply
 

Game crashes before loading screens even show



  • An issue I have all of a sudden is when I start the game, it's normal at first but it stays in the first credits bit for a good 20 seconds before I get sent back to my desktop, normally it takes like 5 seconds before going to the loading screens bit.

    The only mod I installed today was just a retexture for a shirt, and there's no way in hell that's the cause of why this is happening, I wanna know if this is happening to others.

    My game version is 2699.0 for those curious. I have a modified gameconfig, packfile limiter , heap adjuster, all that stuff.
    I don't think that's the issue either since before nothing wrong happened. I just wanna hear if anyone has this problem so I don't sound crazy.

    I have a lot of mods too, but they all worked normally before this issue happened, so I don't think it's that either. I'm really confused at the moment.



  • @-EcLiPsE- said in Game crashes before loading screens even show:

    The only mod I installed today was just a retexture for a shirt, and there's no way in hell that's the cause of why this is happening, I wanna know if this is happening to others.

    No, most of us, I'm guessing, did not retexture any shirts today and my system didn't crash lately for the very, very, simple and obvious reason that I didn't make any improper changes. I did a shitload of ymt editing, some worked, some didn't work, but none caused any crash.

    You made a change, your game crashed, sounds pretty obvious to me that you have probable cause and effect, unless there are other changes you forgot? Remove your texture change and see if it crashes because even a small change can be a showstopper. If it still crashes start thinking what other changes you may have made.

    Newton's laws of modifications
    Stable system + no change = no crash
    Stable system + failing hardware = potential crash
    Stable system + texture edit or any significant or insignificant change = potential crash



  • @JohnFromGWN Back, it wasn't the texture or anything at all I said, game just downright freezes before the first frame of it starting, I removed my mods folder, verify integrity game files on Steam to see if I accidentally removed something important, and even downloaded the game again overnight. All meant nothing pretty much as it still freezes. This is a splendid week so far.



  • @-EcLiPsE-
    So we know that something is freezing the game right?
    In your post it's unclear whether your game runs unmodded. Removing the mods folder doesn't mean squat if you still have asi and dlls running.
    Reinstalling the game is like changing the engine on your car because you ran out of gas.

    1. Rename dinput8.dll to dinput8.bak and test your game. If it doesn't run you have PC hardware or Windows software issues. Possibly GPU drivers (did you update?), possibly DirectX, maybe file or folder permissions, Anti-Virus acting up, who knows. On the hardware side it could be HDD failing or Memory failing etc.

    Did you make any updates to Windows or your hardware? One possible resource:
    https://support.rockstargames.com/articles/205778987/GTAV-PC-General-Troubleshooting-Installation-Issues-Crashes-Freezes-Poor-Performance

    1. If your game does run without mods, then obviously it is the mods. You then move systematically through:
      2.1 Rename mods folder (this you already did)
      2.2 Rename scripts folder
      2.3 Remove all non-essential asi and dll from game's root folder (keep OpenIV and 1 trainer)

    Possible mods that screwed up your system include scripts and anything installed with an OIV, particularly Visual mods like NVE that replace dozens and dozens of files. Or it could be a badly designed (high poly, high res texture) MLO, Map, Ped, Vehicle, Weapon etc. Only 1 installed can crash a game.

    Finally, too many mods, or the wrong mod, can cause your system to crash - due to conflicts or god knows what.

    Ofc you need to have your properly installed gameconfig.xml, pack, and heap - hopefully at their default values to start, and in game Visual settings that can be handled by your PC hardware.

    Ultimate Troubleshooting Guide

    Game Failures - Common Causes



  • @JohnFromGWN Ok now, everything's working properly, installed a couple of mods to see if it can run fine, it's good.

    I don't know if it's my PC or maybe R*'s crap launcher not working right.

    But right now, we're all good!
    I'll update if anything happens.


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.