Log in to reply
 

Story Mode loading infinitely



  • I'm having an issue where GTA is loading infinitely into story mode after updating some mods/scripts.
    I've only updated Gameconfig, Menyoo, Simple Trainer and VisualVanilla.
    I've already confirmed its not the mods folder as disabling it didn't fix the issue (so it seems neither Gameconfig or VisualVanilla are the issue) , and removing Menyoo and Simple Trainer does nothing either. I have no idea what could be causing this, as these are the only mods (apart from essentials like ScriptHookV) that I've updated since the release of the latest game update. Any ideas on how to fix this issue?



  • @MRDotted A) are you running a legit copy? 'R' has seriously cracked down on piracy. So if you're trying to play a cracked version and trying to run mods on an unupdated copy....

    B) Have you run a file integrity check? If you haven't, go into the Launcher menu and find the 'verifiy files' option. Run that and it should fix any issues you've got (if running a legit copy) with the vanilla part of the game.

    C) Make sure you have the 'latest' version of scripthook. Sounds dumb, but check anyway. Then after trying to load the game, go into the gtav main folder and read the scripthook log file. Go to the very last entry. This will give you a good starting point to figure out what's broken as you can see what loaded and what didn't. If all your scripts loaded, they're fine and it's a mod causing the problem.



  • Yes, I'm running a legit copy of GTA V.

    Running a file integrity check through Steam showed no invalid or missing files.

    I have the latest version of scripthoov (v1.0.2802.0, 18 Dec 2022). All my scripts have loaded fine and scripthook.log shows no issues.



  • @MRDotted Have you tried properly removing the other ones too? Even a map mod (not an addon map just the one show up when you press P) can cause this.

    You need to disable everything until you can get your game working again. Renaming mods folder can cause some of your scripts or asis halt in the process where they rely for other stuff.

    Need to follow basic troubleshooting steps, your game may never be problem free until you revert it fully to original.



  • I had the same issue. For me the problem was with addonpeds. The program loaded when I took out the addonpeds folder from <mods/update/x64/dlcpacks>
    When I reinstalled, addonpeds did not work, but I found a line had disappeared from <mods/update/update.rpf/common/data/dlclist.xml>
    Using OpenVI I found that the following line was missing: <Item>dlcpacks:/addonpeds/</Item>
    If you use addonpeds this may be worth a try. For me it is now working.



  • I'm having the same issue. I haven't played the game for a while. I updated the game via Steam, then updated Script Hook V. I used OIV to replace the old dinput8 file and scripthookV files. I loaded into the game and it just sits on loading story mode. I had to replace the dinput8 file with one from my system32 file in order for the game to load, but then since i replaced that dinput8 file now none of my mods will load and my trainer won't load. I thought maybe I did something wrong so this this time I deleted the dinput8 and scripthookv dlls from my game folder via OIV then once again added the updated scripthookv files to the folder and once again it gets stuck on loading story mode.



  • @shoegod4935 said in Story Mode loading infinitely:

    since i replaced that dinput8 file now none of my mods will load

    Since dinput8.dll is the file which allows modding in the first place, it's perfectly normal that your game will no longer run mods when you replace it with one which has nothing to do with GTA5 modding.

    Youtube is full of clickbait scammers who invariably have a solution promoted as a 100% fix. Unfortunately this is rarely the case. Unlike fast food, modding issues can take time and patience.

    If you want to learn about troubleshooting here is a good place to start.
    https://gta5modhelp.blogspot.com/p/ultimate-troubleshooting-guide.html


Log in to reply
 

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.