Log in to reply

Invalid Model

  • Hey everyone I am trying to download the Honda Civic Type R and I have added everything according to the tutorial but I keep getting the message of "Invalid Model" when I go in game. Can anyone assist me with this.

    Honda Civic Type R Link: https://www.gta5-mods.com/vehicles/2018-honda-civic-type-r-fk8

    What I have in the dlclist.xml is: <Item>dlcpacks:/fk8/</Item>
    I have also tried it like this: <Item>dlcpacks:\fk8\</Item> which is how the read me text document for the mod suggested. Neither way works.

    I also have the correct fk8 folder placed in dlcpacks as well when I go through mods/update/x64/dlcpacks.

    I do have a game config as well as pack file adjuster and heap adjuster. So I know I am not missing those unless anyone has a specific game config suggestion.

    I am also using menyoo as my trainer in case it may be just a trainer issue.
    Menyoo Link: https://www.gta5-mods.com/scripts/menyoo-pc-sp

    If anyone has suggestions please let me know

    I tried a different car and I am receiving the same issue. The car was the 2018 Mustang GT. Link is below to view the mod. So it has to be something on my end I am doing wrong.

    2018 Mustang GT Link: https://www.gta5-mods.com/vehicles/ford-mustang-gt-2018-add-on-tuning-liveries

  • @hartleya
    Let's take a look at what you wrote item by item and see if we can figure it out.
    I downloaded the file just to confirm the spawn name is the same as the folder name. Author says it is.

    1. With respect to dlclist.xml, doesn't matter if you use forward or back slashes. It is important to use the same case (Item or item, but not Item with item) and your opening and closing tags are fine.

    2. The gameconfig, heap, and pack have absolutely nothing to do with the spawn. They are purely there for stability.

    3. The path you gave for your dlcpacks is correct, assuming mods is a direct sub folder of your installation folder.

    4. Menyoo is not your problem.

    Honestly, everything you posted is correct. I'm assuming you did unzip the cars? The folder in dlcpacks needs to be the one containing dlc.rpf.

    So, having gone through that, my guess is that it is your dlclist.xml that is screwed up. Can you post the full list here or on pastebin? Possible an item above or below your car entries is incorrect.

  • @JohnFromGWN
    Here is the full list of my dlclist.xml
    Link: https://imgur.com/a/3k1HYXZ

    Just to further assist here is the link to my dlcpacks as well
    Link: https://imgur.com/a/nyOjgzd

  • @hartleya
    I never read instructions but the author gave this:

    1:Copy FK8 folder to X:\Grand Theft Auto V\update\x64\dlcpacks

    Which might have been great in 2015, but in 2023 we use a mods folder. I know you have the correct path in your post. Just make sure it is indeed there because that's where OpenIV will load it.

    X:\Grand Theft Auto V\mods\update\x64\dlcpacks

    and NOT what's in the instructions.

  • @JohnFromGWN
    I made that mistake my first run through. Ran into a never ending loading screen and had to reinstall the game. But now I have the mods folder and anything outside of it is either in a scripts folder or things that need to be in the directory itself. Such as scripthook, open interiors, menyoo, etc..

    Also excuse my late responses I am new to the site so I have post restrictions. I can only respond every 10 minutes until I earn 1 reputation.

  • @hartleya almost never any reason to reinstall, verify integrity

  • @JohnFromGWN I mean I started fresh the folder is clear of all problems. I have been looking at tutorials and suggestions online and there is literally nothing explaining my situation. I have no idea what's causing my invalid model issue.

  • @hartleya Did you install your mods in the mods folder?

    That isn't clear in your picture and there is absolutely no reason to have all the game dlcpacks in your mods folder if that's the case.

    If your cars are in the folder the instructions came with, in other words the game version of update, it will NOT spawn. it has to be in mods\update\x64\dlcpacks.

    Note: You can put your dlcpacks wherever you want and call them whatever you want, but the path must be adjusted - but that's a story for another time.

  • @JohnFromGWN
    I mean I created a mods folder and copied the updates folder to it. But yes this is all under the mods folder.

    Here is a pic of whats under the mods folder. This is the only folder I operate under when adding this car no where else.

    Link: https://imgur.com/a/KuPHXKZ

  • @hartleya In Windows Explorer navigate to your GTA V folder then copy paste the link to your mods dlcpacks and post it here. Or just inspect it yourself.

    It should look something like this if on Steam:

    C:\SteamLibrary\steamapps\common\Grand Theft Auto V\Mods\update\x64\dlcpacks


    C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\Mods\update\x64\dlcpacks

    That has to be your problem or you overwrote your dlclist.xml, after you posted, by copying the update files from the game to your mods folder after your reinstallation.

    There are 4 copies of dlclist.xml in your game, well at least 3. Make sure the dlclist.xml you edit is here:

    Your problem is 100% a wrong installation. Either wrong folder structure, wrong installation, or you blanked out your mod version of dlclist.xml with the game's vanilla version.

  • E:\SteamLibrary\steamapps\common\Grand Theft Auto V\mods\update\x64\dlcpacks

    So I completely wiped the folder before reinstallation. I am talking about empty nothing inside. I then reinstalled the game and started with Open IV. Then created a mods folder and copied the update folder to it. Then I began trying to re add my mods.

    Could it be an issue with the game version I am using? I should note in order to get scripthooks to work I had to use a previous version of the game. Could this be a cause to the issue?

  • @hartleya honestly I'm at a loss. This is a simple process and you seem to have your house in order.

    This has nothing to do with your game version.

    The fact that Menyoo works is proof you have SH5 installed and working.
    The fact that you have dlclist.xml updated is proof you have OpenIV installed.
    You wrote you edited dlclist.xml after copying the game update so it should be intact if it is exactly like your previous post.

    The car itself must be in dlcpacks, the folder must be unzipped, and the spawn name in your case is the same as the folder name. The folder should contain one file, dlc.rpf.

    On site, at your home, we would find the error in less than a minute. Remotely it's a checklist and obviously we are both overlooking something really simple.

    I don't have a clue what to do next. Perhaps try another vehicle installation?

    If you're able to do a video, for example with OBS, that walks through your process and clearly shows your file locations etc, we would then be able to pinpoint the issue, and I guarantee it will be an, oh shit, that was it, moment.

  • @JohnFromGWN
    I have tried with another vehicle which was the mustang gt which I linked in my original post and came across the same issue. I have discord which I can screenshare if we were to get into a call and walk you through my files. If you have discord my discord is IHuffExpos#4180. I'd be able to pull up anything that you need me to show. I'm honestly amazed at how you can do everything right and nothing works lol.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.