Log in to reply

Social Club Error Code 16 - Won't Let Me Play GTA V

  • GTA V was working perfectly fine until today. I added a few add-on vehicle mods and tried to play when I saw the 'Social Club Error (Code 16)' during launch.

    I've tried the following to no avail:

    • Verified integrity of game files via Steam - no issues found
    • Uninstalled and re-installed Rockstar Social Club
    • Disabled all mods (uninstalled ASI Loader)
    • Ran SFC /SCANNOW to confirm no integrity violations of OS files

    Can't understand why this is happening - never seen this 'Code 16' error before. The online resources seem scarce regarding this error so would really appreciate some help.

    Thanks in advance.

  • Got it too. I've been using a downgrade to tuners update. Can't even play offline now after once getting the error :(

  • @kocabac yikes that doesn't sound good.

    I'm still on v2699 and everything was working great until yesterday so I have no idea what/why this happened.

    Are you able to play at all or no? This is not good.. :(

  • It must be because of rockstar games launcher update. I've try every tutorial i can found, still have no luck to fix it

  • I have this issue too glad to see im not the only one facing this issue rn

    was playing just fine earlier this evening now im completely unable to play my game at all

    Btw just a side note error code 16 refers to an "incomplete installation" which i highly doubt but i think is just rather R* or more likely Take Two pulling a Vrchat and blanket banning mods cause they have a vendetta against them.

  • @Zulfjr said in Social Club Error Code 16 - Won't Let Me Play GTA V:

    It must be because of rockstar games launcher update

    That's what caused it and it has NOTHING to do with mods. They screwed up, but not everyone is impacted.
    It will be fixed once ppl start screaming at them.

    I have a 100% unmodded, fully updated version on another PC and it is broken for now - just like my modded version

  • @JohnFromGWN said in Social Club Error Code 16 - Won't Let Me Play GTA V:

    @Zulfjr said in Social Club Error Code 16 - Won't Let Me Play GTA V:

    It must be because of rockstar games launcher update

    That's what caused it and it has NOTHING to do with mods. They screwed up, but not everyone is impacted.
    It will be fixed once ppl start screaming at them.

    I have a 100% unmodded, fully updated version on another PC and it is broken for now - just like my modded version

    It's most defiantly the launcher i downloaded a Back up of a previous version of the social club and launcher as well as blocked the updates with mc afee (should would on the control panel as well) and it worked no problem i was able to play like it never happened i hope they fix it soon.

  • @kanadianborn You can block GTA5.exe, I do, but I don't see how it is possible to run a Steam Version without the Launcher.

    If this isn't fixed, I'll use a Steam Emulator or just FiveM localhost.

    I fixed my vanilla version by deleting all the .exe and doing a verify integrity. That fixed the Code 16 and ran vanilla.

    Tried on modded, but still broken. Not going to waste anymore time.

  • @JohnFromGWN You can use an Anti virus like Mc Afee or use the Control Panel on windows to block the Rockstar Launcher it will force it to boot offline without updating and you can play modded

    you Just have to have a older version of R Launcher installed

  • Oh wow okay so it is the R* Launcher that's causing this error. Glad to know it's not some mod (was worried at first since I have so many mods installed).

    I blocked all the EXE files since I'm on an older version of the game (v2699) but that doesn't work. Hopefully they'll release a fix ASAP.

    Please post here once/when the update and/or fix is released.

  • sat there for past two days like wtf is going on with my gta now , what have i done wrong or put in the wrong bloody place now , and it was rockstars daft launcher messing , litraly what the hell is error 16 about

  • ffs i'm getting the same error and i got rid of it after i unloaded all my mods and updated my game back to the latest version.

  • It's reassuring to see that I'm not the only one. I've tried literally everything I can think of except certificates and reinstalling. For many, the issue was solved by getting a new static IP by turning off their router for 30 mins (or using VPN) for others, deleting folders or enabling OneDrive. The problem started after the rockstar launcher started updating itself so I can only assume the latest update is the issue

  • I had this issue a while ago. Uninstalled the R* launcher, deleted all its folders and installed again, and I believe I did it from an .exe that was in GTA5 root folder, which I deleted and can't remember how it was called, but I didn't even had to download anything(besides the stuff the installer itself got from their servers).

  • This is a serious issue, at least for Steam users of GTA 5, if R* did this intentionally. If they did, their motive is more likely to stop cheaters on GTAO rather than to stop modding. We may just have been collateral damage as SP players. Or if we're more cynical, yes they did this to end modding.

    Again, this is just speculation on my part but we know our modded SP can't go online - it's impossible. Neither SH5 or OpenIV will allow going online with mods.
    However cheaters do find ways, to hack, with or without tools. And the $$$$$ for R* are with GTAO, not SP.

    These are the facts as I understand them today, right or wrong:
    This error can impact anyone, at least with the Steam version, if the game is considered to be "incompletely installed". From my personal experience the R* launcher, as of yesterday's update, considers a reverted GTA 5 as incomplete. It will thus stop the game from loading and give the Code 16 error until all game files (or at least GTA5.exe) are using the current R* version.

    I don't know about the modded/updated version. I have never tried this one since it has broken so many mods, hence the reason to revert. All I know, personally, is that the new R* launcher update will not allow you to play a reverted GTA 5 - either by design or just because they don't give a shit about modders.

    @kanadianborn posted a fix, but this is just temporary. GTA 5 and social club games need authentication. You can't play them offline - not permanently. You need a bypass mod (none for Steam) or an emulator. You will have the illusion that your game is fixed permanently because authentication, unlike updates, is not forced and does not happen with every launch. The same principle exists with FiveM and RP - you can defeat online and play offline until R* authenticates.

    Sooner or later the R* launcher will force an update and then you're back to reinstalling an old version. Blocking internet access - by disabling the internet, by using a firewall rule, by using McShitFee or any AV, is a temporary measure only. The R* launcher will update eventually - or it will tell you a connection is required and end your efforts to play.

    Note: there are sites hosting old launchers but beware of malware. I'm not installing these.

    @sata. Doing a reinstall or a verify integrity will fix this problem, may or may not allow you to play mods, but I don't think it will allow you to play reverted.

    In my case, reverted back to 2372,

  • P.S. If anyone wants to temporarily disable their internet, without unplugging cables or router, without disabling the ethernet adapter or wifi, without a firewall, etc, here is how you can do it. This is for testing purposes, just to confirm game will NOT load without a connection, not regularly.

    Note: Using -scofflineonly does NOT work. It may have in the past, but it doesn't now. Doesn't matter if you place that command in a file called commandline.txt file in your game/root folder of if you put it directly in Steam startup options. Will not stop the Launcher from wanting to connect.

    I use a utility, but this is an easy way to do it from a command prompt. This is for ethernet.

    If you're a Windows beginner, do NOT try this. I'm not coming to your house to fix your PC. Don't go any further.

    1. Use an elevated command prompt (i.e. with admin)
    2. If you know the name of your ethernet adapter, skip this step. If you don't you will get it from this:
      netsh interface show interface
      For example Ethernet 1 or Ethernet 2
    3. To disable the ethernet
      netsh interface set interface "The Name of Ethernet Adapter" disable
      netsh interface set interface "Ethernet 1" disable

    To renable:
    netsh interface set interface "Ethernet 1" enable

  • This is unacceptable. I believe this is cause for a class action lawsuit. I have paid for this damn game 3 different times now only to randomly get blocked from playing GTA V OFFLINE! I don't even want to play your sh!tty online mode anymore. The game is about 10 years old, let it go! Stop the updates and work on VI already. We should NOT need internet to play the story mode of this old game. That was never the deal. I should not be penalized in any way because you can't control online modders Rockstar! Lawsuit anyone!?

  • This is straight bullshit man, I encountered this new issue outta nowhere, the usual with R* nothing new, what's next now? banning Story Mode for good? they always impress you with their endless BS.

  • @sense82
    Wonderful idea until you read the EULA.

    You, and your legal team, will then realize that your lawsuit is without merit because you don't have rights worth mentioning.

    You don't own the game, you paid for the right to play it.
    The game can't be re-engineered, in other words can't be modded.
    The game clearly and legally states you need both an account and an internet connection.
    You say it was never the deal? EULA says wrong.
    They don't update for SP, they update for the kiddies spending mommy's money on GTAO which is likely more profitable than GTA6 will ever be, particularly a non violent woke version of GTA where guns and swearing are prohibited, as is blood and gore.

    Don't like it? Next time do your homework before buying a game.

    Am I pissed? Absolutely. Am I going to bitch? Yeah.
    Am I going to do nothing? No, I'm going to examine my options which include an emulator and converting all my shit including the countless hours I spent writing scripts to FiveM local host. All my code, all my customizations, all my articles on my help blog are now obsolete. My mantra was revert to end all problems. Well Rockstar thought otherwise. I had a feeling this day would come.

    Going to also explore updating and fixing all the mods the updates broke like Liberty City. As a side note, my RDR2 and GTA4, both modded, still worked yesterday but for how long? Difference is they are not reverted.
    This leads me to think we will not be allowed to play reverted in the future.

    Good luck with your class action.

    As for me, honestly, I think I'm done with this shit. I have all the best Open World games installed and great racing sims. Time to take a break from GTA5? Will take a look at the emulators and report back if worthwhile.

  • @JohnFromGWN said in Social Club Error Code 16 - Won't Let Me Play GTA V:

    You don't own the game, you paid for the right to play it.

    EXACTLY, I paid for the right to play it, 3 times over. Now I can no longer play Storymore offline like I ALWAYS COULD. I do not have the internet so I can no longer play a game that I paid to play. All I'm saying, something needs to be done.

  • @sense82 You should still be able to play the game. I can.

    If your game isn't working, do a verify integrity or a reinstall (worst case). That will fix this error. You might need to do follow the instructions here:


    However, if you're GTA5.exe is reverted you're screwed - at least for now.

    You have the right to play vanilla updated. That's what you paid for. You don't have the right to play modded, you don't have the right to revert.

    In the past there was a bypass launcher, but unless I'm mistaken not for the Steam version. Either way, I don't think this launcher still works.

    The options right now, unless someone comes up with a better solution:

    1. Downloading an old R* launcher installer. This means possibly installing malware and infecting your computer. It is also just a temporary solution because this game can't be played offline, can't be blocked, can't be stopped from updating. Both game and launcher will eventually be updated.

    2. Using an emulator. I'm not too familiar with this process but pretty sure it is illegal. If that matters. Once more you have to be careful what you download and install. These emulators are primarily targeted for pirates as are the tools to remove DRM. For me this could be an option, but I will not risk doing something putting my system at risk, even with 20 different AV's used for scanning.

    3. Install FiveM local host and continue to play modded, reverted or not. It's free, it's simple, and I tested that it still works with the reverted GTA 5.exe.

    4. There are cracked versions of some of the launcher files available. Again, no guarantees this will work and of course once more you're possibly installing malware.

  • @JohnFromGWN said in Social Club Error Code 16 - Won't Let Me Play GTA V:

    You don't have the right to play modded, you don't have the right to revert.
    True, you got me. But I would still need the internet in order to update and play... I think that's wrong to force us to connect online to play offline mode. Maybe once, but continuously no.

    Been doing your #3 suggestion since they changed it. Like scorpex said, some bull

  • @sense82 I fully agree. Where we disagree is with respect to our rights, sadly we have none. And remember most gaming companies force us now to have accounts and internet connections...Epic, Ubi, Microsoft. Yep, I hate them all.

    Update: As I wrote before I'm fed up with this bullshit too. Not sure I want to spend too much time trying to fix shit only to have it broken tomorrow.

    I just played with Menyoo and my own menus.
    What does this mean? SH5 and dinput8.dll and SHVDN are all functional, as are the trainers.

    Unfortunately I can't play with any addons presently and I got a pattern 21 packfile error.

    My addons were broken with updated GTA5.exe so nothing new here, but I've never encountered pattern 21 error.

    I had to disable my mods folder to start the game and load Menyoo. Sorry there is no effing way I'm going through my 1, 000 addons to find out if some work and some don't.

    edit: lol. I just realized that none of my essential files, like gameconfig.xml are updated. I've been reverted for so long. But again, no magic fixes.

    Either way, not reverting means the same bullshit after every update. Waiting for SH5 to be updated (with AB gone???) and gameconfig.xml and possibly packfile limit mod? None of that was an issue once reverted.

    F*** you R*.

  • Tried it on my 2nd PC and same error. :(

    This is definitely messed up and the update to the Rockstar Launcher is the culprit. I'm surprised I don't see more of this issue being reported on Reddit, GTA Forums etc.

    I'm sure there are tons of people playing the game modded...?

  • I fixed my game, well at least it loads and has mods.
    If anyone wants to share other solutions, please do.
    Let's to try to keep the new thread devoted to fixes.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.