Log in to reply

Code 16 - a solution that worked - almost

  • I got really excited when I tried this and it worked. Or so I thought. I was congratulating myself, to myself, for having outfoxed Rockstar.

    It worked, I was able to revert and play 2372, but I then realized R* made more changes than just the verification, they also made sure that LC and similar maps could not work - well not without repairs using CW or 3D modeling software. I'm assuming R* did this intentionally to break modding so we would buy GTA 6.

    Wasn't going to publish or post this until it stood the test of time and even then, I was nervous that R* would find out and put an end to this workaround...but here it is. If it helps someone, wonderful, if not, I tried and failed.

    The thought process? If I can't stop the launcher from checking for a complete installation, can I swap the new GTA5.exe (which it checks for) with the old GTA5.exe (2372) in my case before the game loads?

    The answer is yes, you can. But you need to experiment because it depends on your hardware and even the current state of your memory usage. In other words, your game may load in 10 seconds, someone else might take 20 seconds.

    So once more you need to experiment with the timing. Too fast and you will load 2845, too slow you will get a Code 16. Goldilocks.

    Ok, the nuts and bolts. You place your old exe, renamed to something, in your game folder. Then you use a batch file to swap the new exe with the old exe simply by renaming them. You add a wait period (that's what you need to experiment with) so that the launcher has just the right amount of time to do its verification BEFORE the game loads.

    Here is the code that worked for me. I also added code to launch GTA5, but that depends on your version (Steam, EPGS, etc) .

    timeout /t 10
    ren gta5.exe gta52845.bak
    ren gta2372.exe gta5.exe

    Code explained. First line is the only tricky part. It delays execution of the rest of the code in seconds. For me, the sweetspot was 10 seconds. I kept Steam open and added a line to run GTA 5 (batch was run from game folder, had a second file for reset if timing was off).

    start steam://rungameid/271590

    The second line, takes the 2845 exe, after launcher has verfied, and renames it.
    The third line, takes my 2372 exe and renames it to GTA5.exe so that this is the version that loads.

    All my other files are exactly the same (except for SH5) so I don't understand why LC is broken. SH5 is supposed be backwards compatible and that's the only file that isn't in my normal game. I use the 2372 version of SH5. Sadly could not find a way to swap it.

  • @JohnFromGWN Awesome work!!

    Btw. I figured out what you inadvertently missed in the process. A simple mistake any expert can make.

    Solution...Re-route the MD5 # to the OC3 optical line.

    Lol jokes. That's just a classic Ownage Pranks saying.

  • @gtavjamal

    Here's a prank for you. This is version 2372 fully modded in Liberty City with a newly released Ped model. You will notice that the player and ped aren't falling through the map. This is not photoshopped. The feet aren't visible but they are not floating in air, they are on the ground.

    And yes, I used my technique, described above, to instantly run a reverted version without Code 16. This isn't FiveM either, it's GTA 5 2372 SP.

    And because the ped is brand new, it's not an old pic either.

    It is a fake. But how was it done?

    alt text

  • @JohnFromGWN After much thought and discussing the matter with the wise elders the conclusion is either one of two things. Witchcraft or lasers. Both these can make the impossible possible as you have demonstrated lol.

  • @gtavjamal
    I just froze them in place with Menyoo.

  • @JohnFromGWN Yup exactly witchcraft lol.

  • @gtavjamal

    You know it was sad. I think of an approach. I put together. I hit run on the batch file and the game starts to load. It gets by the loading screen, still loading, omg it loaded in Los Santos. I got 2372 to load. I fire up my LemonUI menu. It loads. I go to teleports. I hit Liberty City.

    What happens next? Trevor (Dante Replacement) screams as he falls 100 miles through the map and into the Pacific Ocean. Disappointment follows.

    So they didn't just change the verification process. They went further to make sure reverted mods like that map can't be played. Everything else in my root folder and mods folder is exactly the way it was. I even restored from backup. Only change is SH5 and I really doubt that's the issue but because SH5 is fucking stupid, it does an unnecessary version check, I can't revert SH5. And I tried to swap it but that didn't work because dinput8.dll needs to kick in.

  • So the collisions for Liberty City work with latest version of GTA if you move LC from east to South East. Now the problem I have in SE is that if I dont use the ASI a lot of weird texture stuff happens in LS. Is LOD related I think. Just cannot win :D.

    If you have no problem using the ASI then everything is fine.

  • This post is deleted!

  • This post is deleted!

  • @H4YDN-C

    A video from someone who doesn't even know you can record video on a PC without a camcorder or smartphone.

    Gotta admit the biggest morons have audiences on Youtube.

    One more time:

    You can revert, you can fix Code 16, without any magic solutions.

    What you can't do, not without hours of work, is fix collisions on maps - that's why we reverted in the first place.

    Rockstar doesn't care if you revert. They just don't want you playing on custom maps, especially Vice City, Liberty City, SF, and LV.

  • @JohnFromGWN
    have a question... well actually two, I am new totally new to Liberty City addon. Rather new to GTA moddding in general. I began learning awhile back when I saw an LC vid. Sadly I wanted to get rest of my game up to scratch using LS to learn. So I kinda missed the Liberty fully working.

    First question is. Was LS and LC able to fully function side by side without the ASI disabler, because my current issue with texture loss is that many of my LS dlc's, interiors for instance don't load at all. As for buildings and ground I am getting a lot of texture loss and things wont render in until I am top of them.

    I feel like it should be possible, I loaded the most broken version of LC on 5m. On a server ran from same PC I was playing on and it never even blinked amazing fps aswell actually.

    Secondly can you educate me or point me in direction where I can find info on <genericConditions>$level=MO_JIM_L11</genericConditions> this line as I gather a lot of what I am experiencing with stuff not loading stems from that, of which I have no understanding.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.