Log in to reply

Does anyone have Liberty City Remix working on the 2802 or 2845 version?

  • The YOUTUBE link above is a video that states that the mode works well even in the latest version.

    As everyone knows, the latest version is the 2845 version and the sub-compatible 2802 version.

    I've been using the previous downgrade version well, but the crash happened with a surprise update from Rockstar Launcher, forcing me to update the game.
    New launchers prevent downgrades (because CODE 16), while newer versions cause mode crashes.

    By the way, I couldn't believe the video above.
    I didn't understand because the mods that should only work in the old version were said to apply well in the latest version.
    I've tried to apply it just like them, but I can only see the texture of the city, and I can't really walk around on top of it,
    some buildings, grasses, and road textures were broken.
    I got advice from them to try again with the mods file refreshed, but the result hasn't changed.

    For your information, I'm using the rockstar version. I'm not sure about the STEAM or EPIC version.
    Currently, I've blocked the game from running without a launcher (I've blocked the offline mode running).

    Anyone know of this fix?

  • @gpdlgh614 said in Does anyone have Liberty City Remix working on the 2802 or 2845 version?:

    I've been using the previous downgrade version well, but the crash happened with a surprise update from Rockstar Launcher, forcing me to update the game.

    You'll note in the Code 16 error, when displayed on your screen, that it refers to the Social Club. It has nothing to do with the Rockstar Launcher.
    The good news is you can now revert using a bypass mod. Definitely works for Steam, hopefully works for EGS, Retail, R*.
    You can read more and get the link here:
    Code 16 Error RGSC & Proven Solution

    If you want to stay reverted, you can as well, but you'll need to fix things yourself, chiefly map static collisions no longer there.
    You can read about fixes, with some samples here:
    Falling Through the Map - 2023

    Now finally, if you want to update and play Liberty City there is good news and bad news. In passing, most YT videos are garbage, clickbait, outdated, or just work for one particular version and configuration of the game.

    The good news. Yes you can play Liberty City Updated to 2845.
    The bad news. You will need to use a different version of LC (download) and do NOT use the OIV installer as it will replace new files with old ones. Also, you don't need to install any asi files that come with it. None are necessary based on my experience.

    Where it gets really annoying. My reverted version of LC for 2372, and the new version of 2845, both shared many issues which I had to fix manually. Some weren't really issues, instead it was texture replacements, minimaps etc. Others were missing textures (head of T-Rex skeleton). I actually used some FiveM files to fix my SP version. All in all it was a PITA but 100% possible and workable. Note: the updated version of LC was not fixed by simply editing content.xml. The authors fixed the collisions I"m guessing with new ybn collision files.

    Recommendation. Downgrade and use the bypass mod. This summer, with the next R* patch/update, we will have new problems to worry about.

  • @JohnFromGWN

    Thank you very much for your sincere reply. Few people answered in this detail.
    Thanks to the link you posted, I solved the code 16 problem perfectly.
    Of course, there is a hassle of having to run an R* launcher in the middle, but I think this problem is outside your area of solution.

    I was finally able to get back to the 2372 version, and I've solved the "falling into the sea" problem that has been bothering me with regards to LC.

    There is only one problem left, and it is a texture problem.
    Road, the texture of a particular building is not normal.
    The textures change from time to time with noise every time the player moves, sometimes changing to the texture of LC or the texture of existing GTA 5.
    (etc. LC textures are also available as manholes and GTA 5 textures are also available as vehicle interior textures. There are many others.)

    Conflicts also occur in certain grass and tree designs, and problems such as the surface of the road being turned into road signs.

    This happens even when the mods file is clean, and it doesn't change when I reinstall or delete the NVR graphics patch I use.

    If the above problem is solved, I will be able to play like before.
    If you have any experience in solving this problem or know a solution, please reply again.
    No matter how much I touch the graphic, it seems like my ability is limited.

  • @gpdlgh614 said in Does anyone have Liberty City Remix working on the 2802 or 2845 version?:

    This happens even when the mods file is clean, and it doesn't change when I reinstall or delete the NVR graphics patch I use.

    I know I'm probably the only person who feels this way, but Graphic mods are giant turds. They cause all kinds of issues and for what?
    To have fake looking deep blue skies and fake looking dark green vegetation.
    Thankfully I have a decent monitor and graphics card and my eyes register colours properly.

  • @JohnFromGWN

    alt text
    alt text

    So this problem is due to NVR?
    Given that the same phenomenon occurs in a pure state, it is suspected that the NVR has not been properly erased.
    If graphic mode was the problem.

    A few months ago, there was no problem with NVR and mod, but just in case, I'll apply it again in pure condition.

    thx due

    I'll apply it again and let you know how it went.

  • @gpdlgh614
    Only way to confirm is to remove suspected mod. If you installed with an OIV, you need to look at its assembly.xml and content folder to uninstall it.

  • I'm on the latest version of the game and confirm Liberty City Remix works completely fine. I have no issues with it at all.

  • @JohnFromGWN

    I erased NVR and tried again because I thought it was a conflict with graphic mode, but the result was the same this time.
    I think I should find the assembly.xml and content folder you mentioned.

    It was installed as OIV, but there was no other option.
    Could you tell me the location of the file I need to check and what I need to check in detail?

    I'll try to fix it.

  • @gpdlgh614
    I can't tell you which file created the issue as I don't use any visual mods. What I can tell you is where to look and when in doubt just replace the OIV version with the vanilla file.

    An OIV installer is just a compressed archive, like a zip or rar. You can unzip it or peek inside. 7z is great because you can also peek inside without even extracting. Inside the OIV you will see a content folder containing all the files to be installed. Along side of it will be a file called assembly.xml.

    The file assembly.xml is the recipe, the instructions, for what is going to be installed and exactly where. It can delete, replace, add, copy....do lots of unintended damage.

    The paths can be tricky as well because GTA5 has so many similar looking paths. So just be careful and in a worst case, just restore vanilla files - they can't do anything that can't be undone. Backup if you're concerned.

    Uninstalling an OIV Mess

    Installing with OIV - The Safe Way

  • @JohnFromGWN

    As you said, I checked the OIV file and installed it one by one, and when I applied it from levels.ymt located in x64a -> data, abnormalities began to appear.

    However, if levels.ymt are not applied, the unfortunate occurrence of crashes while loading the game. levels.ymt plays a role in changing existing models to older models (ex. Diamond Casino).

    I think I'm already feeling closer to the answer, is there any further progress?
    Actually, I'm not sure what to do after this.

  • @gpdlgh614 Don't know for sure. I've never allowed any mod to change levels.ymt. Haven't noticed any issues when I didn't install it.
    But often you need to make compromises or do what I do. I have a separate mod folder for Liberty City but I moved the dlcpacks into the root folder so all addons can be shared (to remove duplication).

  • @JohnFromGWN Hi I've seen your replies back from 2 yrs ago also, surprising you're still active on this topic, can you tell where can I find the manually fixed textures or the names of the texture files that need to be fixed. I've got the FiveM files as well, just don't know which ones to use. Mine is crashing as I go anywhere near times square, is there a way to get logs on what's causing the crash? I've checked the ScriptHookV logs, nothing noticeable there.

  • @techsmoothieYT
    The reason this topic is still active, and it likely will be relevant for a long time given the importance of this map, has to do with the Code 16 that broke reverted mods. Updating fixed the problem but broke older mods including the collisions on LC.

    With respect to game crashing as you go near times square. I don't know why I had posted the crash was due to textures. I honestly don't remember. I worked on this map recently but it was to fix collisions.

    Importance of GTA 5 Log Files

  • @JohnFromGWN

    Hey due, It's finally fixed.

    While watching an earlier version of LC, I found an additional content that I had to manually put x64g in, but just in case, I copied, pasted, and ran it, and the texture issue disappeared neatly.

    I think something like this happened because of the missing textures.

    Anyway, peace has come to my game again. Thank you very much. Your topic really helped a lot.

  • @JohnFromGWN Yeah after four sleepless nights I fixed mine as well, perfectly working with the latest version (2845) and with tons of mods already installed.

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.