Log in to reply

Redux stops working after changing starfield

  • Heya guys i need some help with this redux stuff, i've been trying to make my own custom skydome (starfield) work and it just keeps coming up with "ERR_GEN_INVALID" when i try and load up the game. The only thing i changed is the "starfield" of this file: x64a.rpf. And i'm unable to open the game once that's done. Changed it from this alt text
    to this alt text

  • @FreddyVon
    '.rpf' archives can become corrupted due to editing & it's not always the exact file you have edited that causes it. Also, I've found 'x64a.rpf' to be one of the least stable in that regard.

    Try this as a test & see what happens:

    Make any backups you need to & then run whatever verify integrity method is appropriate for your version of the game & make sure your vanilla files are fully 100% vanilla before using the original to replace your 'mods' folder 'x64a.rpf' archive again:

    Methods to Verify Integrity of Game Files:

    Once you've got 'x64a.rpf' back to vanilla, test load the game to confirm it's working & then use Ctrl+F3 in OpenIV & search your 'mods folder only' for both skydome files by name & check what locations you find them in.

    Hopefully you just find them in these locations:

    ...\Grand Theft Auto V\mods\x64a.rpf\textures\skydome.ytd

    ...\Grand Theft Auto V\mods\x64a.rpf\models\skydome.ydd

    Let me know at this point if you find them anywhere else :thumbsup:

    If you only find them in those two locations above, drag & drop both (now vanilla) files out of OpenIV & into Windows (Desktop/folder etc) & then reinstall them to these locations instead (backup 'update.rpf' beforehand obvs):

    ...\Grand Theft Auto V\mods\update\update.rpf\x64\textures\skydome.ytd

    ...\Grand Theft Auto V\mods\update\update.rpf\x64\models\skydome.ydd

    Test reapplying/re-doing your edit/s, test load the game & let me know the results etc :thumbsup:

  • Hey man appreciate the detailed answer! ill try it out asap!

  • @a63nt-5m1th said in Redux stops working after changing starfield:

    Hopefully you just find them in these locations:

    I find them in both cause i put the modded files under the mods folder

    I'm sorry my guy i'm very new to all this i LEGIT have no clue what i'm doing haha

  • @a63nt-5m1th Alright i've tried everything here and i still cannot get it to work
    Originally i thought the mods folder was for something else ( Like maybe having to load the game with the mods folder instead of loading the original files ) but apparently it's just for editing the files before replacing them outside of OpenIV?

  • Skydome Files Location/OpenIV Search Area Selection:

    @FreddyVon said in Redux stops working after changing starfield:

    I find them in both

    I presume you mean in the original vanilla install & also in the 'mods' folder yeah?

    That's fine if so, all four locations would likely have shown up because you have the Ctrl+F3 search box parameters set to 'Search everywhere'. Set it to 'Search in "mods" folder only' & you should find only the two results in my last post.

    Be careful with that drop-down option. It's a good idea to always make sure it is set to 'Search in "mods" folder only' if you are searching for 'mods' folder files, so that you don't accidentally mod the vanilla/game folder files etc.
    If you are looking for vanilla files, set it to ''Search in game folder only'' (or 'Search everywhere' works for that also), but just remember to set it back to 'Search in "mods" folder only' or always check the file location before you edit a file you've found etc

    'mods' Folder:

    @FreddyVon said in Redux stops working after changing starfield:

    Like maybe having to load the game with the mods folder instead of loading the original files

    That's exactly what it's for. It just so happens to be that you can also use the 'mods' folder diagnostically like I showed in my last post, but that doesn't change it's original & intended primary use, ie as a place to load edited/modded game files from instead of loading the ones in the original install.

    @FreddyVon said in Redux stops working after changing starfield:

    but apparently it's just for editing the files before replacing them outside of OpenIV?

    I'm not sure exactly what you mean there, but I'm 100% sure your understanding is wrong :slight_smile:. I presume what I said just above should have made it clearer for you, ie a diagnostic 'mods' folder rebuild is just a novel way to use the 'mods' folder to help you identify the location of an issue, but doesn't change the 'mods' folder's original & intended use (of loading the '.rpf' archives within it instead of the originals).

    After you find the '.rpf' location of an issue using a diagnostic 'mods' folder rebuild, you move all the files from your old (renamed) mods folder & place them all in the new 'mods' folder (or vice versa & then rename the original back to 'mods') & you are back to where you started, only difference being you now know what '.rpf' archive the issue is in & can thereby narrow your search for the cause to only the files within that particular '.rpf', instead of the whole game :thumbsup:.

  • @a63nt-5m1th said in Redux stops working after changing starfield:

    Like maybe having to load the game with the mods folder instead of loading the original files

    i've just been replacing the original files with the modded ones under: \Grand Theft Auto V\x64a.rpf and \Grand Theft Auto V\x64a.rpf\textures\skydome.ytd (it worked fine except for when i edited them with my own "skyfield" so i didn't think anything of it.)

    So now my question is: How do i load the game from this folder? As i said i'm very new to this and legit have no idea haha

  • @FreddyVon
    Editing/modding the vanilla files, instead of using a 'mods' folder, is something you can get away with for most things, but sooner or later you will run into trouble. What happens if Rockstar update/patch any of the '.rpf' archives you've edited? Well, you lose all of your edits (unless you made a full '.rpf' backup of them, & even then it's work to fix).

    Better to use a 'mods' folder :thumbsup:

  • @a63nt-5m1th Right i see but i'm still confused how you make the game load the mods folder instead of the original files

  • @FreddyVon

    'mods' folder Activation/OpenIV Plugins:

    OpenIV Plugins

    To use a 'mods' folder, you only need the ASI Loader (to be able to load '.asi' mods & files like 'OpenIV.asi') & the OpenIV.ASI (to actually activate the 'mods' folder). openCamera is optional.

    Once the ASI Loader & OpenIV.ASI (at least) are installed, place a modified archive in the 'mods' folder in it's correct location & load up the game to confirm the 'mods' folder is working & that is where the files are being loaded from.

    'mods' Folder Hierarchy:

    The 'mods' folder is basically a new mirror of the main Grand Theft Auto V folder & all of the games file/folder hierarchies under both folders should be the same:

    Example 'mods' Folder File Locations:

    ...\Grand Theft Auto V\mods\update\update.rpf
    ...\Grand Theft Auto V\mods\common.rpf
    ...\Grand Theft Auto V\mods\x64a.rpf
    ...\Grand Theft Auto V\mods\update\x64\dlcpacks
    ...\Grand Theft Auto V\mods\x64\audio\sfx\STREAMED_VEHICLES_GRANULAR.rpf

    You can move all '.rpf' archives over into the 'mods' folder if you like (& have enough drive space) or just add the files that you want to edit/mod. Any '.rpf' files missing from their correct 'mods' folder locations will be loaded vanilla using the original game files instead, so both methods work, totally up to you which way you want to do it :thumbsup:.

  • @a63nt-5m1th Oh yeah i have all these installed too i just didin't know if the game would load the files within the mods folder over the normal files automatically or whatever.
    So if i have lets say vanilla x64a.rpf under "\GTAV" and a modded version of "x64a.rpf" under the mods folder the mods folder will take priority?

  • @FreddyVon
    If it's in this exact location, yeah :thumbsup::

    ...\Grand Theft Auto V\mods\x64a.rpf

  • @a63nt-5m1th

    Hey appreciate the help man i really do hehe

    are you using any type of mods/redux and if so would you mind showing me what your mods folder looks like?

    Cause when i load my game without changing the vanilla files and just put the modded ones in the mods folder my game loads up the vanilla graphics
    this is normal alt text

    and this is after i put them under \Grand Theft Auto V\
    alt text

  • @FreddyVon

    Follow this vid:

    & you should be able to see if you have your 'mods' folder set up correctly :thumbsup:

    Check your folder hierarchy against this as well:


    The GTA V at the top in that pic is the main/root 'Grand Theft Auto V' folder of the game.

    Timecycle Files:

    Also, make sure you installed all your timecycle (weather) files to this location:

    ...\Grand Theft Auto V\mods\update\update.rpf\common\data\timecycle

    All these files should be placed in there:


    OpenIV Plugins:

    Additionally, try uninstalling the OpenIV plugins mentioned previously & reinstall them again & test the game again.

    If you're still having issues after that, provide a screenshot of your folder hierarchy including where your 'mods' folder & 'update.rpf' are. Something like the pic above etc :thumbsup:.

  • My game still loads up as vanilla after putting modded files in the Mods folder. it's funny tho on the modded file "update" theres 4 time cycles but on the vanilla one theres only 3 (1 3 and 4)

    alt text

    alt text

  • @FreddyVon
    Don't worry about there only being 3 'timecycle_mods_' files in the vanilla 'update.rpf' timecycle folder. That's just how it's set up vanilla, 'timecycle_mods_2.xml' is in 'common.rpf' by default. Putting them all in the timecycle folder within your 'mods' folder's 'update.rpf' is just easier, all in the same place etc (& '...\update.rpf\common\data\timecycle' is the highest priority load location for those files anyway).

    Not sure what your issue is (file/folder structure looks fine anyway), but here are a few things to try:

    • Make sure your OpenIV plugins are showing up Green (not Blue. Blue = Uninstalled)

    • Disable any Anti-Virus you have & then try reinstalling OpenIV & then it's plugins again. If you want to make sure the plugins are installed 100% fresh, delete 'dinput8.dll' & 'OpenIV.asi' from the main root 'Grand Theft Auto V' folder & then reinstall them again from within OpenIV (the files will reappear in 'Grand Theft Auto V' folder completely new etc).

    • Go into your root 'Grand Theft Auto V' folder & right-click 'dinput8.dll' > Properties > & make sure the file is not showing up as blocked (if so, unblock it using the '[Unblock]' button). Do the same for 'OpenIV.asi'.


  • I don't have an unblock / block section in the bottom... Tried looking for it too, but without luck.
    I've also closed down any firewall / virus protection i had activated and reinstalled OpenIV (Honestly thought i already deactivated it a long time ago)
    alt text

  • @FreddyVon

    What does your 'OpenIV.log' say?

    ...\Grand Theft Auto V\OpenIV.log

    Example: (just 'mods' folder update.rpf lines only):

    18/05/2023 23:05:09.208 [9784] TRACE: [fiDeviceLocal::getFileAttr] 'mods/update/update.rpf' {M}
    18/05/2023 23:05:09.208 [9784] TRACE: [fiDeviceLocal::getFileAttr] 'mods/update/update.rpf' {M}
    18/05/2023 23:05:09.209 [9784] TRACE: [fiDeviceLocal::openBulk] 'mods/update/update.rpf' {M}
    18/05/2023 23:05:09.209 [9784] TRACE: [fiDeviceLocal::getFileTime] 'mods/update/update.rpf' {M}
    18/05/2023 23:05:09.209 [9784] TRACE: [fiDeviceLocal::filelengthByName] 'mods/update/update.rpf' {M}

    If you get any lines with a '{M}' at the end of them it means the archive it mentions is being loaded from the 'mods' folder & thus your 'mods' folder must be set up correctly for that to appear (Note: It doesn't show a '{M}' at the end of '[fiPackfile::openArchive]' lines, just ignore them).

    If any '{M}'s show up at the end of any lines anywhere within 'OpenIV.log', even if it's not in relation to 'update.rpf' directly, it would tend to suggest your 'mods' folder is working to at least some degree.

  • This is the only thing it has logged alt text

  • @FreddyVon

    • Even if I disable my 'mods' folder & just load vanilla files I get an 'OpenIV.log' that looks like this. There's something off somewhere in your GTA V/OpenIV set up, that's for sure.

    • Where did you get your installer for OpenIV from? Just that openiv.com has been down for a while, so I'm wondering if it's an old version of OpenIV you're using? (there are also likely shady malware versions dotted around the internet too).

    • Try this version of OpenIV instead (it was originally provided by the OpenIV community & is to my knowledge the latest version of OpenIV available at the moment). I haven't test installed it, as I don't want to mess with my current set up, but at 33MB, it's likely an offline installer with no need to download from openiv.com, so should install no problem.

  • this file "OpenIV.log" doesn't get added once i reinstall openIV, i can trace it but i have to restore it (it got deleted)

  • @FreddyVon
    It should be created (or edited/updated if already created) when the game loads. Did you test load the game since installing (I presume?) the version of OpenIV I linked to?

  • Yep nothing changed, it still says the same thing. And yeah i used your version this timealt text
    alt text

  • @FreddyVon

    • The most unusual thing about your install is that you have been modding the vanilla files (& your 'OpenIV.log' is just plain weird). Maybe something in the modded vanilla files or game folder is breaking some 'mods' folder/game functionality (doesn't have to be a moddable file, maybe a game '.dll' is corrupted etc). Have you ran a verify integrity to make sure all your vanilla files (includng '.dll's & such) are truly vanilla?

    Methods to Verify Integrity of Game Files:

    Also, just noticed your 'OpenIV.log' in your pics say 17/05/2023 (ie 2 days ago). So, the 'OpenIV.log' file hasn't been updated for 2 days even although you've been loading the game in that time. That's weird. Maybe delete it & see if a completely new one is created when you load the game?

    Oh, & another thing, you don't have 2 seperate installs of GTA V do you? Like another copy of the game installed in a different location?

  • @a63nt-5m1th ill try delete it and reopen the game tomorrow.
    And no i only got the game installed on epicgames atm i also verified the game files and they are 100% vanilla
    Although i could try reinstall the game

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.