Log in to reply

Redux stops working after changing starfield

  • @FreddyVon

    • Found a newer version of OpenIV (v4.1.0.47). Looks like an offline installer as well (~24.8MB). Download it using the blue 'WINDOWS EXECUTABLE' link on the right of that^ linked page.

    • Uninstall your current OpenIV first & manually move/delete any '.asi', '.log' files & 'dinput8.dll' from your 'Grand Theft Auto V' root folder before installing that^ new one. There's an 'uninstall.exe' in the OpenIV install directory, if you can't find any other way to uninstall your current one:

    C:\Users\YOUR_WINDOWS_USERNAME_HERE\AppData\Local\New Technology Studio\Apps\OpenIV\uninstall.exe

    Also, before you use that newer 'OpenIVSetup.exe', or any 'OpenIVSetup.exe' you download, check to see if it needs to be unblocked (blocked files occur a lot when sharing fully compiled files across the internet, like modders do etc):

    right-click file > Properties > '[UnBlock]' etc

    Other Things to Try If Above Doesn't Work:

    • Go into your main root 'Grand Theft Auto V' folder & move/delete all the small files in there (ie everything apart from the '.rpf' archives & the folders) & then run a verify integrity. It won't take long to download new ones (given the file sizes are so small etc) & it will make sure the only small files in that folder are all vanilla & there are no extra non-vanilla ones hiding in amongst them.
      Make any backups you need to (ENB '.ini' files if you have them etc) & reinstall the OpenIV plugins once the verify integrity completes.

    • Try running a Check Disk on the drive GTA V is installed on. Maybe a System File Check as well.

    • If you decide to go the reinstall route, try & reinstall it to a different folder location. Anywhere will do, just somewhere different etc. That will make sure as many variables as possible are created anew.

  • @a63nt-5m1th i've uninstalled it using RevoUninstaller and i've uninstalled GTA V i'm making a clean install of both programs now and setting it up from new hopefully it works this time
    I deleted every trace of OpenIV i could find now that i reinstalled it and the installations within (ASI Loader & OpenIV.ASI ) and opened GTA V i looked through my entire pc to find "OpenIV.log" and this is all i found alt text

    I've now tried moving OpenIVSetup.exe to the GTAV folder and reinstalling it now these 2 files show up alt text
    I've also tried adding a OpenIV.log file myself (Didn't work obviously)

  • I'm so sorry for taking up all your time with this bullshit.

  • @FreddyVon
    No worries :thumbsup:, but yeah, running out of ideas here :sweat:

    How about any other '.log' files? Any like 'asiloader.log' created when you run the game? (delete all old '.log' files & test load GTA V & give me a list of any new ones created in the GTA V root folder). I'm going to guess the answer is no/none created.

    • The only reason I know for no '.log' files being produced & no '.asi/.dll' mods working is that there is a duplicate/different install somewhere else on the computer (even if it's not used. Like a backup of the entire GTA V folder etc), or at the very least the '.asi/.dll's are being loaded from a different folder somewhere & thus don't work or create any '.log' files in the folder you are running the game from. That or maybe some old or incorrect GTA V file path in the Registry is confusing them.

    Some Ideas/Information Gathering:

    • Might seem silly to mention, but make 100% sure you are editing the right GTA V folder. Default install for Epic Games is 'C:\Program Files\Epic Games', so check there even if you installed somewhere else. Also have a read over this & see if anything pops out, especially if you have moved your install location at some point in the past.

    • Search your entire PC for 'dinput8.dll' & 'OpenIV.asi'. Ignore any 'dinput8.dll' you find in 'C:\Windows\' but apart from that you should just find two of each file. One in the GTA V root folder & one in the OpenIV AppData Five install. Investigate any others you find etc.

    • Open up 'RegEdit' & search your Registry for 'GTA5.exe' (Ctrl+F for Search/Find & then hit F3 to move to next result) & make a note of all the file paths you find it in & make sure they all match your current install location. Ignore any search results that don't have a file path ('value not set' etc), just F3 to the next one etc & just make note of the ones that show a file path in the 'Data' column.

    Also, going back to the 'OpenIV.log', it appears to have been working on the 17th going by your pics etc, what happened to change that?

  • I got the asiloader.log but this comes up alt text Same as with the OpenIV.log

    I've always had the same install destination for epic games

  • @FreddyVon
    That would appear to suggest 'dinput8.dll' is working at least, but not 'OpenIV.asi' apparently :thinking:.

    Search your entire PC for 'OpenIV.asi' & see what you find.

    That^ was just in response to your first line & no longer applies. Forget it etc.


    Why are you using a shortcut? Like, I've never created a shortcut to an '.asi' before, why do that?
    Just tell me whether the actual file is still there or not? 'Problem with Shortcut' means the file has been moved or deleted & no longer exists where the shortcut's file path refers to.

  • alt text

    (I can only reply once every 10 minutes which is annoying, so do you have any other platform where i might be able to reach you?) if it's not too much of a hassle on your end.

  • @FreddyVon
    I edited my previous post as it no longer applies. Re-read it etc :thumbsup:


    • Where exactly is the 'asiloader.log' being created? In your pic it looks like it is in a folder with all manner of other things etc. Is it being created in the GTA V root folder when you run the game? (& if that is the GTA V root folder, clean all of that junk out of there so you have nothing but the original vanilla game files)

  • to the first post u edited i didn't make a shortcut or delete any of the files whatsoever it did that on its own i just installed OpenIV, ASI loader and openIV.ASI haven't done anything other than that.

    Thinking of just formatting my pc to start over,

    And the asiloader.log is here: alt text

  • @FreddyVon
    So that means no 'asiloader.log' is being produced in the GTA V root folder then? (the folder where 'GTA5.exe' & your 'mods' folder are). If so, that means even 'dinput8.dll'' isn't working correctly.

    Yeah, I would just start over. The fact that it appears to have self-created a shortcut to various files on it's own suggests that is not the official version of OpenIV & possibly malware, or that you have some other malware on your PC that is highjacking '.dll/.asi' etc files for it's own use etc. It's damn weird behaviour anyway.

  • @a63nt-5m1th Yeah for sure is ill be formatting my PC asap

  • @FreddyVon
    The asiloader.log is produced by a file called dinput8.dll which came bundled with scripthookv.
    This file, also known as the asiloader, is also packaged with OpenIV. Exactly the same file.

    I'm curious as to why your log file, based on your screenshot ended up outside your game folder where GTA5.exe can be found? Or do you keep your Russian Adobe software with GTA5? The log file, dinput8.dll, and OpenIV.asi should all be in one location, the same location, and that's your game folder where Epic installed it.

    alt text

    Your installations are definitely suspect and definitely not traditional nor advisable nor successful.

    Reformatting your PC won't change the way you installed OpenIV. Better to stick to the instructions next time.

  • @JohnFromGWN i didn't install the files under "recent" lol cmon now. That's the files you see on the screenshot there they were all under "recent" my adobe was installed under a folder called Adobe 2023 (C:\Program Files\Adobe 2023) and OpenIV is under the root folder for gta, so i have no clue what you're on about lol.

  • @FreddyVon
    My mistake. It would help if you provided non-cryptic screenshots. For example, a screenshot of your game installation folder with extensions visible as well as the Mods, Updates, X64 etc. I can't guess if you're showing recent and why would you show that instead of a useful screenshot.

    Could of been the recycle bin too?

  • @JohnFromGWN he asked me where i found the specific file so i showed him 2 screenshots. If you look above i'd hope you can find it.

  • @FreddyVon
    If you provide screenshots of your game folder, mods folder, update folder etc. it might help provide some answers. Again, with extensions clearly visible.

    Also check the permissions on your folders and worst case, create new folders from Windows and dump files there. If a log file can't be written there has to be a reason why.

    When the game or mods fuck up, it's 100% human error. We make the changes, we make the errors, the game just plays the errors back for us.

  • @JohnFromGWN I've just formatted my pc, and i'm currently setting everything up again just to have a fresh start.
    Should be done in a couple of minutes
    alt text

  • @FreddyVon

    So formatting a PC means reinstalling GTA 5?
    Formatting means reinstalling your OS, all your applications, and all your games.
    Reinstalling only fixes vanilla files.
    Your problem is with mod files. So remove all the mod crap and start from scratch.

  • @JohnFromGWN Yeah reinstalled everything from scratch so i don't have anything that's not supposed to be on the pc whatsoever

    He mentioned above that it could be a fishy OpenIV download i'd have found and that was the reason it might not be working

  • @FreddyVon
    Ouch. All that because of a bad Game installation?
    Just for the record, I've crashed my game about 100 times and I've never reinstalled it.
    Because each time it crashed, i knew it was my fault, my mods.
    Never the game, never the OS.

  • @JohnFromGWN Oh yeah don't get me wrong haha i know it's my damn fault... I've got absolutely no freakin clue what i'm doing :laughing:

  • @FreddyVon

    This is a detailed and accurate guide if you're interested.
    Takes time, but if you follow it step by step it's pretty much guaranteed to work.

    Also be careful where you download OpenIV. Not necessarily malware, but different versions, different packaging.

    User provided link in this thread, but do a scan first. Interestingly when I reported a positive on this file the authorities deleted my posts. I guess it's ok when a scanner finds a virus, it must be a false positive. Yeah, right.


  • @JohnFromGWN right appreicate it mate. Seems sketchy ay

    Thats the same link my friend here in the thread provided https://drive.google.com/u/0/uc?id=1XpjodUGkGx3AUbcLETvWYqbdK7yoWGNb&export=download i suppose it's alright then?

  • alt text

Log in to reply

Looks like your connection to GTA5-Mods.com Forums was lost, please wait while we try to reconnect.